summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2007-09-01 16:38:05 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2007-09-01 16:38:05 +0000
commit4ec9b125a6a8e89d995ca7379b228d97859edce7 (patch)
tree98180751a62adce6f27c96a332bf6dc3d1ffa84d /net-zope
parentMarked ppc stable for bug #133667. (diff)
downloadgentoo-2-4ec9b125a6a8e89d995ca7379b228d97859edce7.tar.gz
gentoo-2-4ec9b125a6a8e89d995ca7379b228d97859edce7.tar.bz2
gentoo-2-4ec9b125a6a8e89d995ca7379b228d97859edce7.zip
version bump, closes #185786
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/files/digest-zope-2.10.43
-rw-r--r--net-zope/zope/zope-2.10.4.ebuild83
3 files changed, 92 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 8939a64959e1..2946f7d11035 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.129 2007/05/11 18:25:29 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.130 2007/09/01 16:38:05 radek Exp $
+
+*zope-2.10.4 (01 Sep 2007)
+
+ 01 Sep 2007; Radoslaw Stachowiak <radek@gentoo.org> +zope-2.10.4.ebuild:
+ version bump, closes #185786
11 May 2007; Bryan Østergaard <kloeri@gentoo.org> -zope-2.6.4-r1.ebuild:
Masked for a year and finally going away due to <python-2.3 being removed.
diff --git a/net-zope/zope/files/digest-zope-2.10.4 b/net-zope/zope/files/digest-zope-2.10.4
new file mode 100644
index 000000000000..4bea87f265d9
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.10.4
@@ -0,0 +1,3 @@
+MD5 07dde81bdfe42ca00f73912b3d73e0ec Zope-2.10.4-final.tgz 7231146
+RMD160 8985bf9006fedc87cdfcf5032239890b2950988e Zope-2.10.4-final.tgz 7231146
+SHA256 5d0174e3a1c84f2ccef5fb0979c041eeea0e2fda8f21b35a37b1a382870ff89f Zope-2.10.4-final.tgz 7231146
diff --git a/net-zope/zope/zope-2.10.4.ebuild b/net-zope/zope/zope-2.10.4.ebuild
new file mode 100644
index 000000000000..d06154c7345c
--- /dev/null
+++ b/net-zope/zope/zope-2.10.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.10.4.ebuild,v 1.1 2007/09/01 16:38:05 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR} || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+src_test() {
+ einfo "Tests disabled by Gentoo team."
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}