summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-24 19:54:26 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-24 19:54:26 +0000
commit5184295962b0fdded2fd1cd746b2d582881cde5d (patch)
tree1339135599979abcd1a31b2515660368d79f3e31 /net-zope/zopeinterface
parentChanging need-auto. tags to WANT_AUTO tags per bug #148719 (diff)
downloadgentoo-2-5184295962b0fdded2fd1cd746b2d582881cde5d.tar.gz
gentoo-2-5184295962b0fdded2fd1cd746b2d582881cde5d.tar.bz2
gentoo-2-5184295962b0fdded2fd1cd746b2d582881cde5d.zip
Silence deprecation warnings with python 2.5, add python herd to metadata.xml (bug #148421).
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-zope/zopeinterface')
-rw-r--r--net-zope/zopeinterface/ChangeLog10
-rw-r--r--net-zope/zopeinterface/files/digest-zopeinterface-3.0.12
-rw-r--r--net-zope/zopeinterface/files/digest-zopeinterface-3.0.1-r13
-rw-r--r--net-zope/zopeinterface/files/zopeinterface-3.0.1-with-rename.patch252
-rw-r--r--net-zope/zopeinterface/metadata.xml1
-rw-r--r--net-zope/zopeinterface/zopeinterface-3.0.1-r1.ebuild39
6 files changed, 306 insertions, 1 deletions
diff --git a/net-zope/zopeinterface/ChangeLog b/net-zope/zopeinterface/ChangeLog
index 874cdcaf5ed7..7e0ff0c8d0f1 100644
--- a/net-zope/zopeinterface/ChangeLog
+++ b/net-zope/zopeinterface/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-zope/zopeinterface
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zopeinterface/ChangeLog,v 1.21 2006/05/29 17:48:57 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zopeinterface/ChangeLog,v 1.22 2006/09/24 19:54:26 marienz Exp $
+
+*zopeinterface-3.0.1-r1 (24 Sep 2006)
+
+ 24 Sep 2006; Marien Zwart <marienz@gentoo.org>
+ +files/zopeinterface-3.0.1-with-rename.patch, metadata.xml,
+ +zopeinterface-3.0.1-r1.ebuild:
+ Silence deprecation warnings with python 2.5, add python herd to
+ metadata.xml (bug #148421).
29 May 2006; Simon Stelling <blubb@gentoo.org> zopeinterface-3.0.1.ebuild:
stable on amd64
diff --git a/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1 b/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1
index a3da2432b25c..943c51fd638f 100644
--- a/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1
+++ b/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1
@@ -1 +1,3 @@
MD5 114f302c2b132d43ad4e01d108b4d192 ZopeInterface-3.0.1.tgz 108336
+RMD160 77ae531b20e069de959807ae980a76b460e3f76c ZopeInterface-3.0.1.tgz 108336
+SHA256 04a960d6ea1d89c2a44ebf730bdf492f617a5fda9d3cba19c2b041daff492236 ZopeInterface-3.0.1.tgz 108336
diff --git a/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1-r1 b/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1-r1
new file mode 100644
index 000000000000..943c51fd638f
--- /dev/null
+++ b/net-zope/zopeinterface/files/digest-zopeinterface-3.0.1-r1
@@ -0,0 +1,3 @@
+MD5 114f302c2b132d43ad4e01d108b4d192 ZopeInterface-3.0.1.tgz 108336
+RMD160 77ae531b20e069de959807ae980a76b460e3f76c ZopeInterface-3.0.1.tgz 108336
+SHA256 04a960d6ea1d89c2a44ebf730bdf492f617a5fda9d3cba19c2b041daff492236 ZopeInterface-3.0.1.tgz 108336
diff --git a/net-zope/zopeinterface/files/zopeinterface-3.0.1-with-rename.patch b/net-zope/zopeinterface/files/zopeinterface-3.0.1-with-rename.patch
new file mode 100644
index 000000000000..85676025c2b4
--- /dev/null
+++ b/net-zope/zopeinterface/files/zopeinterface-3.0.1-with-rename.patch
@@ -0,0 +1,252 @@
+=== modified file 'Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/adapter.py'
+--- Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/adapter.py 2006-09-20 20:56:16 +0000
++++ Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/adapter.py 2006-09-20 21:19:48 +0000
+@@ -192,8 +192,8 @@
+ oldwithobs = implied[key] = {}
+
+ # v is {with -> tuple([object])}
+- for with, objects in v.iteritems():
+- oldwithobs[with] = oldwithobs.get(with, ()) + objects
++ for withob, objects in v.iteritems():
++ oldwithobs[withob] = oldwithobs.get(withob, ()) + objects
+
+ else:
+ oldbyname = implied.get(key)
+@@ -253,24 +253,24 @@
+ def unsubscribe(self, dependent):
+ del self.dependents[dependent]
+
+- def _adaptTo(self, specification, object, name='', with=()):
++ def _adaptTo(self, specification, object, name='', withob=()):
+ if object is None:
+ try:
+- del self.adapters[False, tuple(with), name, specification]
++ del self.adapters[False, tuple(withob), name, specification]
+ except KeyError:
+ pass
+ else:
+- self.adapters[False, tuple(with), name, specification
++ self.adapters[False, tuple(withob), name, specification
+ ] = object
+
+ self.dirty()
+
+- def _subscriptionAdaptTo(self, specification, object, with=()):
++ def _subscriptionAdaptTo(self, specification, object, withob=()):
+ if object is None:
+ raise TypeError, ("Unregistering subscription adapters"
+ " isn't implemented")
+
+- key = (True, tuple(with), '', specification)
++ key = (True, tuple(withob), '', specification)
+ self.adapters[key] = self.adapters.get(key, ()) + (object, )
+ self.dirty()
+
+@@ -287,13 +287,13 @@
+ # withs[j][0] extends withs[i][0].
+
+ withs = []
+- for with, value in bywith.iteritems():
++ for withob, value in bywith.iteritems():
+ for i, (w, v) in enumerate(withs):
+- if withextends(with, w):
+- withs.insert(i, (with, value))
++ if withextends(withob, w):
++ withs.insert(i, (withob, value))
+ break
+ else:
+- withs.append((with, value))
++ withs.append((withob, value))
+
+ return withs
+
+@@ -355,7 +355,7 @@
+
+ # Multi adapter
+
+- with = required[1:]
++ withob = required[1:]
+ key = provided, order
+
+ for surrogate in self.get(required[0]), self._default:
+@@ -377,7 +377,7 @@
+ for rwith, value in bywith:
+ # the `rank` describes how well the found adapter matches.
+ rank = []
+- for rspec, spec in zip(rwith, with):
++ for rspec, spec in zip(rwith, withob):
+ if not spec.isOrExtends(rspec):
+ break # This one is no good
+ # Determine the rank of this particular specification.
+@@ -459,7 +459,7 @@
+
+ # Multi
+ key = 's', provided, order
+- with = required[1:]
++ withob = required[1:]
+ result = []
+
+ for surrogate in self.get(required[0]), self._default:
+@@ -468,7 +468,7 @@
+ continue
+
+ for rwith, values in bywith:
+- for rspec, spec in zip(rwith, with):
++ for rspec, spec in zip(rwith, withob):
+ if not spec.isOrExtends(rspec):
+ break # This one is no good
+ else:
+@@ -537,22 +537,22 @@
+
+ def register(self, required, provided, name, value):
+ if required:
+- with = []
++ withob = []
+ for iface in required[1:]:
+ if iface is None:
+ iface = Interface
+- with.append(iface)
+- with = tuple(with)
++ withob.append(iface)
++ withob = tuple(withob)
+ required = self.get(required[0])
+ else:
+- with = ()
++ withob = ()
+ required = self._null
+
+ if not isinstance(name, basestring):
+ raise TypeError("The name provided to provideAdapter "
+ "must be a string or unicode")
+
+- required._adaptTo(provided, value, unicode(name), with)
++ required._adaptTo(provided, value, unicode(name), withob)
+
+ def lookupAll(self, required, provided):
+ order = len(required)
+@@ -585,7 +585,7 @@
+
+ # Multi adapter
+
+- with = required[1:]
++ withob = required[1:]
+ key = provided, order
+ first = ()
+
+@@ -599,7 +599,7 @@
+ continue
+
+ for rwith, value in bywith:
+- for rspec, spec in zip(rwith, with):
++ for rspec, spec in zip(rwith, withob):
+ if not spec.isOrExtends(rspec):
+ break # This one is no good
+ else:
+@@ -611,19 +611,19 @@
+
+ def subscribe(self, required, provided, value):
+ if required:
+- required, with = self.get(required[0]), tuple(required[1:])
++ required, withob = self.get(required[0]), tuple(required[1:])
+ else:
+ required = self._null
+- with = ()
++ withob = ()
+
+ if provided is None:
+ provided = Null
+
+- required._subscriptionAdaptTo(provided, value, with)
++ required._subscriptionAdaptTo(provided, value, withob)
+
+-def mextends(with, rwith):
+- if len(with) == len(rwith):
+- for w, r in zip(with, rwith):
++def mextends(withob, rwith):
++ if len(withob) == len(rwith):
++ for w, r in zip(withob, rwith):
+ if not w.isOrExtends(r):
+ break
+ else:
+@@ -646,19 +646,19 @@
+ # TODO: Backward compatability
+ # Don't need to handle 3-tuples some day
+ try:
+- (subscription, with, name, target) = key
++ (subscription, withob, name, target) = key
+ except ValueError:
+- (with, name, target) = key
++ (withob, name, target) = key
+ subscription = False
+
+ if subscription:
+- if with:
+- _add_multi_sub_adapter(with, target, multi, value)
++ if withob:
++ _add_multi_sub_adapter(withob, target, multi, value)
+ else:
+ _add_named_sub_adapter(target, implied, value)
+ else:
+- if with:
+- _add_multi_adapter(with, name, target, target, multi,
++ if withob:
++ _add_multi_adapter(withob, name, target, target, multi,
+ registered, value)
+ else:
+ _add_named_adapter(target, target, name, implied,
+@@ -688,10 +688,10 @@
+ _add_named_adapter(b, provided, name, implied,
+ registered, value)
+
+-def _add_multi_adapter(with, name, target, provided, implied,
++def _add_multi_adapter(withob, name, target, provided, implied,
+ registered, object):
+
+- ikey = target, (len(with) + 1)
++ ikey = target, (len(withob) + 1)
+ byname = implied.get(ikey)
+ if not byname:
+ byname = implied[ikey] = {}
+@@ -701,8 +701,8 @@
+ bywith = byname[name] = {}
+
+
+- rkey = ikey, name, with # The full key has all 4
+- if (with not in bywith
++ rkey = ikey, name, withob # The full key has all 4
++ if (withob not in bywith
+ or
+ (rkey not in registered or registered[rkey].extends(provided))
+ ):
+@@ -710,10 +710,10 @@
+ # general interface that is closer provided than what we had
+ # before
+ registered[rkey] = provided
+- bywith[with] = object
++ bywith[withob] = object
+
+ for b in target.__bases__:
+- _add_multi_adapter(with, name, b, provided, implied,
++ _add_multi_adapter(withob, name, b, provided, implied,
+ registered, object)
+
+ def _add_named_sub_adapter(target, implied, objects):
+@@ -723,13 +723,13 @@
+ for b in target.__bases__:
+ _add_named_sub_adapter(b, implied, objects)
+
+-def _add_multi_sub_adapter(with, target, implied, objects):
+- key = 's', target, (len(with) + 1)
++def _add_multi_sub_adapter(withob, target, implied, objects):
++ key = 's', target, (len(withob) + 1)
+ bywith = implied.get(key)
+ if not bywith:
+ bywith = implied[key] = {}
+
+- bywith[with] = bywith.get(with, ()) + objects
++ bywith[withob] = bywith.get(withob, ()) + objects
+
+ for b in target.__bases__:
+- _add_multi_sub_adapter(with, b, implied, objects)
++ _add_multi_sub_adapter(withob, b, implied, objects)
+
diff --git a/net-zope/zopeinterface/metadata.xml b/net-zope/zopeinterface/metadata.xml
index 46c8eea1b318..b4c64b92ffaf 100644
--- a/net-zope/zopeinterface/metadata.xml
+++ b/net-zope/zopeinterface/metadata.xml
@@ -2,4 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-zope</herd>
+<herd>python</herd>
</pkgmetadata>
diff --git a/net-zope/zopeinterface/zopeinterface-3.0.1-r1.ebuild b/net-zope/zopeinterface/zopeinterface-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..7ae0ae495f15
--- /dev/null
+++ b/net-zope/zopeinterface/zopeinterface-3.0.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zopeinterface/zopeinterface-3.0.1-r1.ebuild,v 1.1 2006/09/24 19:54:26 marienz Exp $
+
+inherit distutils eutils
+
+MY_PN="ZopeInterface"
+DESCRIPTION="Standalone Zope interface library"
+HOMEPAGE="http://zope.org/Products/ZopeInterface"
+SRC_URI="http://www.zope.org/Products/${MY_PN}/${PV}final/${MY_PN}-${PV}.tgz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.3"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ # Rename "with": python 2.5 warns about it (will be a keyword in 2.6)
+ epatch "${FILESDIR}"/${P}-with-rename.patch
+}
+
+src_install() {
+ distutils_src_install
+ if use doc ; then
+ cp -pR $MY_PN "${D}"/usr/share/doc/${PF}/
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+}