summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-19 17:43:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-19 17:43:11 +0000
commitb74b61cbad0c5c8ad4bd5dd89da9c07eaddd0ec1 (patch)
tree5e6d9b02c7fd6b862705b046499eaa23ac0ffa56 /net-zope/zope-security
parentDelete older ebuild. (diff)
downloadgentoo-2-b74b61cbad0c5c8ad4bd5dd89da9c07eaddd0ec1.tar.gz
gentoo-2-b74b61cbad0c5c8ad4bd5dd89da9c07eaddd0ec1.tar.bz2
gentoo-2-b74b61cbad0c5c8ad4bd5dd89da9c07eaddd0ec1.zip
Version bump.
(Portage version: 2.2.0_alpha9_p4/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-security')
-rw-r--r--net-zope/zope-security/ChangeLog8
-rw-r--r--net-zope/zope-security/zope-security-3.8.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-zope/zope-security/ChangeLog b/net-zope/zope-security/ChangeLog
index efc9416b5f80..e0a0c489b787 100644
--- a/net-zope/zope-security/ChangeLog
+++ b/net-zope/zope-security/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope-security
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/ChangeLog,v 1.8 2010/12/05 18:59:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/ChangeLog,v 1.9 2010/12/19 17:43:11 arfrever Exp $
+
+*zope-security-3.8.0 (19 Dec 2010)
+
+ 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zope-security-3.7.4.ebuild, +zope-security-3.8.0.ebuild:
+ Version bump.
05 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
zope-security-3.7.4.ebuild:
diff --git a/net-zope/zope-security/zope-security-3.8.0.ebuild b/net-zope/zope-security/zope-security-3.8.0.ebuild
new file mode 100644
index 000000000000..3e8ed7a65aeb
--- /dev/null
+++ b/net-zope/zope-security/zope-security-3.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/zope-security-3.8.0.ebuild,v 1.1 2010/12/19 17:43:11 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Security Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.security"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytz
+ dev-python/restrictedpython
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-exceptions
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}