summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-01 05:45:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-01 05:45:13 +0000
commitcb30468c19c96e48b5bbdbdac87c8bbb6a887cd0 (patch)
tree92fe738e3f429b6d2efcc4c7d0a5b737d85ad8c2 /net-zope/zope-publisher
parentInitial addition. (diff)
downloadgentoo-2-cb30468c19c96e48b5bbdbdac87c8bbb6a887cd0.tar.gz
gentoo-2-cb30468c19c96e48b5bbdbdac87c8bbb6a887cd0.tar.bz2
gentoo-2-cb30468c19c96e48b5bbdbdac87c8bbb6a887cd0.zip
Initial addition.
(Portage version: 14770-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-publisher')
-rw-r--r--net-zope/zope-publisher/ChangeLog10
-rw-r--r--net-zope/zope-publisher/metadata.xml6
-rw-r--r--net-zope/zope-publisher/zope-publisher-3.10.0.ebuild42
3 files changed, 58 insertions, 0 deletions
diff --git a/net-zope/zope-publisher/ChangeLog b/net-zope/zope-publisher/ChangeLog
new file mode 100644
index 000000000000..c153987d7837
--- /dev/null
+++ b/net-zope/zope-publisher/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-publisher
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-publisher/ChangeLog,v 1.1 2009/11/01 05:45:13 arfrever Exp $
+
+*zope-publisher-3.10.0 (01 Nov 2009)
+
+ 01 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-publisher-3.10.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-publisher/metadata.xml b/net-zope/zope-publisher/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-publisher/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-publisher/zope-publisher-3.10.0.ebuild b/net-zope/zope-publisher/zope-publisher-3.10.0.ebuild
new file mode 100644
index 000000000000..6e3587c784d4
--- /dev/null
+++ b/net-zope/zope-publisher/zope-publisher-3.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-publisher/zope-publisher-3.10.0.ebuild,v 1.1 2009/11/01 05:45:13 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Zope publisher publishes Python objects on the web."
+HOMEPAGE="http://pypi.python.org/pypi/zope.publisher"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/setuptools
+ net-zope/zope-authentication
+ net-zope/zope-browser
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-contenttype
+ net-zope/zope-event
+ net-zope/zope-exceptions
+ net-zope/zope-i18n
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"