summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-10-11 15:30:38 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-10-11 15:30:38 +0000
commitcee1a47ee4eda3625fcc659cb02de408ebf34c9e (patch)
tree611c3bd28b7cfccc106ea633ca70d42886da5203 /net-zope/zope-interface
parentRemove old version of pudb. (diff)
downloadgentoo-2-cee1a47ee4eda3625fcc659cb02de408ebf34c9e.tar.gz
gentoo-2-cee1a47ee4eda3625fcc659cb02de408ebf34c9e.tar.bz2
gentoo-2-cee1a47ee4eda3625fcc659cb02de408ebf34c9e.zip
Version bump zope-interface to 3.8.0.
(Portage version: 2.1.10.24/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-interface')
-rw-r--r--net-zope/zope-interface/ChangeLog7
-rw-r--r--net-zope/zope-interface/zope-interface-3.8.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-zope/zope-interface/ChangeLog b/net-zope/zope-interface/ChangeLog
index 4c9d0551b434..9b9cc99977f1 100644
--- a/net-zope/zope-interface/ChangeLog
+++ b/net-zope/zope-interface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope-interface
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/ChangeLog,v 1.25 2011/10/09 14:09:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/ChangeLog,v 1.26 2011/10/11 15:30:38 djc Exp $
+
+*zope-interface-3.8.0 (11 Oct 2011)
+
+ 11 Oct 2011; Dirkjan Ochtman <djc@gentoo.org> +zope-interface-3.8.0.ebuild:
+ Version bump to 3.8.0.
09 Oct 2011; Markos Chandras <hwoarang@gentoo.org>
zope-interface-3.7.0.ebuild:
diff --git a/net-zope/zope-interface/zope-interface-3.8.0.ebuild b/net-zope/zope-interface/zope-interface-3.8.0.ebuild
new file mode 100644
index 000000000000..773595488590
--- /dev/null
+++ b/net-zope/zope-interface/zope-interface-3.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-3.8.0.ebuild,v 1.1 2011/10/11 15:30:38 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+# Test suite requires optional extension modules not available with Jython.
+PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# net-zope/zope-fixers is required for building with Python 3.
+DEPEND="dev-python/setuptools
+ net-zope/zope-fixers"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt src/zope/interface/*.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}