summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-28 22:28:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-28 22:28:50 +0000
commit58d25f21dbf928931e7c370e56e381ea9b6c7445 (patch)
treed3553047f2cb55c9fed972e5f0b4730f5c2cb22b /net-zope/zope-app-publication
parent2.4.19-r1 is a compile-fix for ldapc++ and some additional safety checks not ... (diff)
downloadgentoo-2-58d25f21dbf928931e7c370e56e381ea9b6c7445.tar.gz
gentoo-2-58d25f21dbf928931e7c370e56e381ea9b6c7445.tar.bz2
gentoo-2-58d25f21dbf928931e7c370e56e381ea9b6c7445.zip
Initial addition.
(Portage version: 14915-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-app-publication')
-rw-r--r--net-zope/zope-app-publication/ChangeLog10
-rw-r--r--net-zope/zope-app-publication/metadata.xml6
-rw-r--r--net-zope/zope-app-publication/zope-app-publication-3.9.0.ebuild44
3 files changed, 60 insertions, 0 deletions
diff --git a/net-zope/zope-app-publication/ChangeLog b/net-zope/zope-app-publication/ChangeLog
new file mode 100644
index 000000000000..fa7f1fa5db53
--- /dev/null
+++ b/net-zope/zope-app-publication/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-app-publication
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-app-publication/ChangeLog,v 1.1 2009/11/28 22:28:50 arfrever Exp $
+
+*zope-app-publication-3.9.0 (28 Nov 2009)
+
+ 28 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-app-publication-3.9.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-app-publication/metadata.xml b/net-zope/zope-app-publication/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-app-publication/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-app-publication/zope-app-publication-3.9.0.ebuild b/net-zope/zope-app-publication/zope-app-publication-3.9.0.ebuild
new file mode 100644
index 000000000000..dba98683c408
--- /dev/null
+++ b/net-zope/zope-app-publication/zope-app-publication-3.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-app-publication/zope-app-publication-3.9.0.ebuild,v 1.1 2009/11/28 22:28:50 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope publication"
+HOMEPAGE="http://pypi.python.org/pypi/zope.app.publication"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zodb
+ net-zope/zope-authentication
+ net-zope/zope-browser
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-error
+ net-zope/zope-event
+ net-zope/zope-i18n
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-publisher
+ net-zope/zope-security
+ net-zope/zope-schema
+ net-zope/zope-testing
+ net-zope/zope-traversing"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN//-//}"
+DOCS="CHANGES.txt README.txt"