summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-22 01:40:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-22 01:40:55 +0000
commit42d9c6864d9c37598d50fc10d5068cebe85c78f0 (patch)
tree23fbbbb6af72de0b55a9a09a388f699beaa04bbf /net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild
parentInitial addition. (diff)
downloadgentoo-2-42d9c6864d9c37598d50fc10d5068cebe85c78f0.tar.gz
gentoo-2-42d9c6864d9c37598d50fc10d5068cebe85c78f0.tar.bz2
gentoo-2-42d9c6864d9c37598d50fc10d5068cebe85c78f0.zip
Initial addition.
(Portage version: 14872-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild')
-rw-r--r--net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild b/net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild
new file mode 100644
index 000000000000..f3759b736819
--- /dev/null
+++ b/net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-app-dependable/zope-app-dependable-3.4.0.ebuild,v 1.1 2009/11/22 01:40:55 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple Dependency API"
+HOMEPAGE="http://pypi.python.org/pypi/zope.app.dependable"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-annotation
+ net-zope/zope-exceptions
+ net-zope/zope-interface
+ net-zope/zope-traversing"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN//-//}"
+DOCS="CHANGES.txt README.txt"