summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 19:53:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 19:53:13 +0000
commit31c8ef3fa207686b9102ee745364ff13aae30131 (patch)
tree603e664be56b50451dc80a9ffae96660b0439366 /net-zope/zodb
parentDelete older ebuilds. (diff)
downloadgentoo-2-31c8ef3fa207686b9102ee745364ff13aae30131.tar.gz
gentoo-2-31c8ef3fa207686b9102ee745364ff13aae30131.tar.bz2
gentoo-2-31c8ef3fa207686b9102ee745364ff13aae30131.zip
Version bump.
(Portage version: 2.2.0_alpha23_p3/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zodb')
-rw-r--r--net-zope/zodb/ChangeLog8
-rw-r--r--net-zope/zodb/zodb-3.10.2.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/net-zope/zodb/ChangeLog b/net-zope/zodb/ChangeLog
index edb10916adee..e7b7d04a4643 100644
--- a/net-zope/zodb/ChangeLog
+++ b/net-zope/zodb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zodb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zodb/ChangeLog,v 1.47 2011/01/06 19:25:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zodb/ChangeLog,v 1.48 2011/02/12 19:53:13 arfrever Exp $
+
+*zodb-3.10.2 (12 Feb 2011)
+
+ 12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zodb-3.9.7.ebuild, -zodb-3.10.1.ebuild, +zodb-3.10.2.ebuild:
+ Version bump.
06 Jan 2011; Brent Baude <ranger@gentoo.org> zodb-3.10.1.ebuild:
Marking zodb-3.10.1 ~ppc for bug 341499
diff --git a/net-zope/zodb/zodb-3.10.2.ebuild b/net-zope/zodb/zodb-3.10.2.ebuild
new file mode 100644
index 000000000000..c5fdae09d7e6
--- /dev/null
+++ b/net-zope/zodb/zodb-3.10.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zodb/zodb-3.10.2.ebuild,v 1.1 2011/02/12 19:53:13 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="ZODB3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Object Database"
+HOMEPAGE="http://pypi.python.org/pypi/ZODB3 https://launchpad.net/zodb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/manuel
+ >=net-zope/transaction-1.1.0
+ net-zope/zc-lockfile
+ net-zope/zconfig
+ net-zope/zdaemon
+ net-zope/zope-event
+ net-zope/zope-interface
+ net-zope/zope-testing
+ !media-libs/FusionSound"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="doc/* HISTORY.txt README.txt"
+PYTHON_MODNAME="BTrees persistent ZEO ZODB"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 src
+}
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}