summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-21 23:43:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-21 23:43:30 +0000
commit6fb68413fba1ed1ba6071818a5d1115fa04126f5 (patch)
tree6ea30442ca45312a53515e55da7cc0f2f9626d32 /net-zope/zcatalog
parentDelete older ebuild. (diff)
downloadgentoo-2-6fb68413fba1ed1ba6071818a5d1115fa04126f5.tar.gz
gentoo-2-6fb68413fba1ed1ba6071818a5d1115fa04126f5.tar.bz2
gentoo-2-6fb68413fba1ed1ba6071818a5d1115fa04126f5.zip
Version bump.
(Portage version: 2.2.0_alpha30_p1/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zcatalog')
-rw-r--r--net-zope/zcatalog/ChangeLog8
-rw-r--r--net-zope/zcatalog/zcatalog-2.13.10.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-zope/zcatalog/ChangeLog b/net-zope/zcatalog/ChangeLog
index 3bef319b24e7..8978520f43a5 100644
--- a/net-zope/zcatalog/ChangeLog
+++ b/net-zope/zcatalog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zcatalog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/ChangeLog,v 1.6 2011/04/10 14:01:47 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/ChangeLog,v 1.7 2011/04/21 23:43:30 arfrever Exp $
+
+*zcatalog-2.13.10 (21 Apr 2011)
+
+ 21 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zcatalog-2.13.10.ebuild:
+ Version bump.
*zcatalog-2.13.9 (10 Apr 2011)
diff --git a/net-zope/zcatalog/zcatalog-2.13.10.ebuild b/net-zope/zcatalog/zcatalog-2.13.10.ebuild
new file mode 100644
index 000000000000..a0f92d4acddd
--- /dev/null
+++ b/net-zope/zcatalog/zcatalog-2.13.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/zcatalog-2.13.10.ebuild,v 1.1 2011/04/21 23:43:30 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
+
+inherit distutils
+
+MY_PN="Products.ZCatalog"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope 2's indexing and search solution."
+HOMEPAGE="http://pypi.python.org/pypi/Products.ZCatalog"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/restrictedpython
+ net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/datetime
+ net-zope/documenttemplate
+ net-zope/extensionclass
+ net-zope/missing
+ net-zope/persistence
+ net-zope/record
+ net-zope/zexceptions
+ net-zope/zodb
+ >=net-zope/zope-2.12
+ net-zope/zope-dottedname
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-testing"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+PDEPEND="net-zope/zctextindex"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="Products/PluginIndexes ${MY_PN/.//}"