summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-03 21:43:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-03 21:43:21 +0000
commitb19285690537739f9f2114f13fec06df7fc1d10b (patch)
tree06232c64c60e43da4de7ade6fe918ffdb6385ec6 /net-zope/xron
parentinitial commit (diff)
downloadgentoo-2-b19285690537739f9f2114f13fec06df7fc1d10b.tar.gz
gentoo-2-b19285690537739f9f2114f13fec06df7fc1d10b.tar.bz2
gentoo-2-b19285690537739f9f2114f13fec06df7fc1d10b.zip
initial commit
Diffstat (limited to 'net-zope/xron')
-rw-r--r--net-zope/xron/ChangeLog9
-rw-r--r--net-zope/xron/Manifest3
-rw-r--r--net-zope/xron/files/digest-xron-0.0.101
-rw-r--r--net-zope/xron/xron-0.0.10.ebuild27
4 files changed, 39 insertions, 1 deletions
diff --git a/net-zope/xron/ChangeLog b/net-zope/xron/ChangeLog
new file mode 100644
index 000000000000..0f88ee180288
--- /dev/null
+++ b/net-zope/xron/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-zope/xron
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/xron/ChangeLog,v 1.1 2003/10/03 21:43:20 robbat2 Exp $
+
+*xron-0.0.10 (03 Oct 2003)
+
+ 03 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> xron-0.0.10.ebuild:
+ initial commit
+
diff --git a/net-zope/xron/Manifest b/net-zope/xron/Manifest
index 5d3ab1250038..e7f8976875aa 100644
--- a/net-zope/xron/Manifest
+++ b/net-zope/xron/Manifest
@@ -1,2 +1,3 @@
-MD5 aa57940fcea3de3b2a4ceafad248d6bb xron-0.0.10.ebuild 568
+MD5 62d4df7d420ede5cf8388ac0a96f69ed xron-0.0.10.ebuild 778
+MD5 f54cb600197dc06ee0d9fce7cda78ed1 ChangeLog 327
MD5 39696e8d743f1d3af5a595aea8096fa8 files/digest-xron-0.0.10 59
diff --git a/net-zope/xron/files/digest-xron-0.0.10 b/net-zope/xron/files/digest-xron-0.0.10
new file mode 100644
index 000000000000..6047ad2222fb
--- /dev/null
+++ b/net-zope/xron/files/digest-xron-0.0.10
@@ -0,0 +1 @@
+MD5 23f5c4c8625c8b383597f63bd67b11c9 Xron-0-0-10.tgz 18530
diff --git a/net-zope/xron/xron-0.0.10.ebuild b/net-zope/xron/xron-0.0.10.ebuild
new file mode 100644
index 000000000000..814716b3e457
--- /dev/null
+++ b/net-zope/xron/xron-0.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/xron/xron-0.0.10.ebuild,v 1.1 2003/10/03 21:43:20 robbat2 Exp $
+
+inherit zproduct
+
+MY_PN="${PN/xron/Xron}"
+MY_PV="${PV//./-}"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="Xron schedules and executes procedures for Zope applications"
+HOMEPAGE="http://www.zope.org/Members/lstaffor/Xron"
+SRC_URI="${HOMEPAGE}/${PV}/${MY_P}.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+ZPROD_LIST="Xron"
+MYDOC="${MYDOC} *.txt"
+
+src_install() {
+ zproduct_src_install
+ # fix permissions on files
+ DIR=${D}/usr/share/zproduct/${PF}
+ find ${DIR} -exec chown zope.root \{} \;
+ find ${DIR} -exec chmod 644 \{} \;
+ find ${DIR} -type d -exec chmod +x \{} \;
+}
+