summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-30 19:42:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-30 19:42:53 +0000
commitde869c3d5b73b20db355b32747a93d81dfd0a8a2 (patch)
tree6e3c90c6d9f29bcc6a6333194ace27b3f530ad01 /net-zope/transaction
parentDelete older ebuild. (diff)
downloadgentoo-2-de869c3d5b73b20db355b32747a93d81dfd0a8a2.tar.gz
gentoo-2-de869c3d5b73b20db355b32747a93d81dfd0a8a2.tar.bz2
gentoo-2-de869c3d5b73b20db355b32747a93d81dfd0a8a2.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/transaction')
-rw-r--r--net-zope/transaction/ChangeLog8
-rw-r--r--net-zope/transaction/transaction-1.1.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/net-zope/transaction/ChangeLog b/net-zope/transaction/ChangeLog
index 76d056d10e15..050d75dc9172 100644
--- a/net-zope/transaction/ChangeLog
+++ b/net-zope/transaction/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/transaction
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/transaction/ChangeLog,v 1.5 2010/05/10 17:41:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/transaction/ChangeLog,v 1.6 2010/05/30 19:42:53 arfrever Exp $
+
+*transaction-1.1.0 (30 May 2010)
+
+ 30 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -transaction-1.0.1.ebuild, +transaction-1.1.0.ebuild:
+ Version bump.
*transaction-1.0.1 (10 May 2010)
diff --git a/net-zope/transaction/transaction-1.1.0.ebuild b/net-zope/transaction/transaction-1.1.0.ebuild
new file mode 100644
index 000000000000..a04bc594b3db
--- /dev/null
+++ b/net-zope/transaction/transaction-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/transaction/transaction-1.1.0.ebuild,v 1.1 2010/05/30 19:42:53 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Transaction management for Python"
+HOMEPAGE="http://pypi.python.org/pypi/transaction"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="CHANGES.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/transaction/tests"
+ }
+ python_execute_function -q delete_tests
+}