summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-10-23 20:17:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-10-23 20:17:18 +0000
commitd1a01085686fc53c6defa055af0925fc959db3c4 (patch)
tree4095e28571c4c7885d290e34fcf16f5195347c0b /net-zope/plone
parentamd64/x86 stable, bug #243130 (diff)
downloadgentoo-2-d1a01085686fc53c6defa055af0925fc959db3c4.tar.gz
gentoo-2-d1a01085686fc53c6defa055af0925fc959db3c4.tar.bz2
gentoo-2-d1a01085686fc53c6defa055af0925fc959db3c4.zip
Version bump to 3.1.6
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-zope/plone')
-rw-r--r--net-zope/plone/ChangeLog7
-rw-r--r--net-zope/plone/plone-3.1.6.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/net-zope/plone/ChangeLog b/net-zope/plone/ChangeLog
index 15375653d6d9..d797d9b686f6 100644
--- a/net-zope/plone/ChangeLog
+++ b/net-zope/plone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/plone
# Copyright 2003-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/ChangeLog,v 1.54 2008/07/08 06:22:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/ChangeLog,v 1.55 2008/10/23 20:17:18 tupone Exp $
+
+*plone-3.1.6 (23 Oct 2008)
+
+ 23 Oct 2008; <tupone@gentoo.org> +plone-3.1.6.ebuild:
+ Version bump to 3.1.6
08 Jul 2008; Tupone Alfredo <tupone@gentoo.org>
-files/plone-2.0.5-portrait_security.patch, -plone-1.0.5.ebuild,
diff --git a/net-zope/plone/plone-3.1.6.ebuild b/net-zope/plone/plone-3.1.6.ebuild
new file mode 100644
index 000000000000..79bd7cb88b59
--- /dev/null
+++ b/net-zope/plone/plone-3.1.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/plone-3.1.6.ebuild,v 1.1 2008/10/23 20:17:18 tupone Exp $
+
+inherit versionator zproduct
+
+MY_P="Plone-${PV}"
+DESCRIPTION="A Zope Content Management System, based on Zope CMF."
+HOMEPAGE="http://plone.org/"
+SRC_URI="https://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE=""
+
+DEPEND="app-admin/zope-config"
+RDEPEND=">=dev-python/imaging-1.1.5
+ =net-zope/zope-2.10*
+ >=net-zope/zope-2.10.5
+ dev-python/elementtree
+ >=app-admin/zprod-manager-0.3.2"
+
+S="${WORKDIR}/${MY_P}"
+
+ZPROD_LIST="
+ Archetypes
+ ATContentTypes
+ ATReferenceBrowserWidget
+ AdvancedQuery
+ CMFActionIcons
+ CMFCalendar
+ CMFCore
+ CMFDefault
+ CMFDiffTool
+ CMFDynamicViewFTI
+ CMFEditions
+ CMFFormController
+ CMFPlacefulWorkflow
+ CMFPlone
+ CMFQuickInstallerTool
+ CMFTestCase
+ CMFTopic
+ CMFUid
+ DCWorkflow
+ ExtendedPathIndex
+ ExternalEditor
+ GenericSetup
+ GroupUserFolder
+ kupu
+ Marshall
+ MimetypesRegistry
+ NuPlone
+ PasswordResetTool
+ PlacelessTranslationService
+ PloneLanguageTool
+ PlonePAS
+ PloneTestCase
+ PloneTranslations
+ PluggableAuthService
+ PluginRegistry
+ PortalTransforms
+ ResourceRegistries
+ SecureMailHost
+ ZopeVersionControl
+ statusmessages
+ validation
+ "
+ZLPROD_LIST="
+ archetypes
+ borg
+ five
+ kss
+ plone
+ wicked
+ "
+DOT_ZLFOLDER_FPATH="${ZP_DIR}/${PF}/.zlfolder.lst"
+
+src_install() {
+ zproduct_src_install
+ for N in ${ZLPROD_LIST} ; do
+ echo ${N} >> "${D}"/${DOT_ZLFOLDER_FPATH}
+ done
+}
+
+pkg_postinst() {
+ elog "This plone version is a bundled version = contains all necessary zope products"
+ elog "You should carefully manage Your zope instance manually(!) with zprod-manager tool"
+ elog "If You have simple installation (just zope and plone) you can safely execute:"
+ elog "'zprod-manager add' and then mark ${P} to be added to your instance."
+}