summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-12 18:15:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-12 18:15:55 +0000
commit65d5e261e08dacf6e188e4220357493787138e58 (patch)
tree72e04e4faa58ceed3b12ddade1acb0d42c4ca61c /net-zope/extensionclass
parentFix license from GPL-2 to GPL-3 wrt #308829 by Thomas Kahle. (diff)
downloadgentoo-2-65d5e261e08dacf6e188e4220357493787138e58.tar.gz
gentoo-2-65d5e261e08dacf6e188e4220357493787138e58.tar.bz2
gentoo-2-65d5e261e08dacf6e188e4220357493787138e58.zip
Delete older ebuild.
Diffstat (limited to 'net-zope/extensionclass')
-rw-r--r--net-zope/extensionclass/extensionclass-2.12.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-zope/extensionclass/extensionclass-2.12.0.ebuild b/net-zope/extensionclass/extensionclass-2.12.0.ebuild
deleted file mode 100644
index d6fc1cd3142d..000000000000
--- a/net-zope/extensionclass/extensionclass-2.12.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/extensionclass-2.12.0.ebuild,v 1.1 2010/02/22 11:12:50 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="ExtensionClass"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Metaclass for subclassable extension types"
-HOMEPAGE="http://pypi.python.org/pypi/ExtensionClass"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="test"
-
-DEPEND="app-arch/unzip
- test? ( dev-python/nose net-zope/zope-testing )"
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="ComputedAttribute ExtensionClass MethodObject"
-DOCS="CHANGES.txt README.txt"
-
-src_test() {
- testing() {
- local module
- for module in ComputedAttribute ExtensionClass MethodObject; do
- ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
- done
-
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- # Don't install sources.
- find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" -o -name "*.h" | xargs rm -f
-}