summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-03-27 16:34:30 +0000
committerMamoru Komachi <usata@gentoo.org>2004-03-27 16:34:30 +0000
commitea35c1708ec20c04777ba060c8e65a2b16c790e0 (patch)
treec972d6267ef578eae3a7fff1d6198621c51e933a /net-www
parentMarked as stable. Removed old ebuild. (Manifest recommit) (diff)
downloadgentoo-2-ea35c1708ec20c04777ba060c8e65a2b16c790e0.tar.gz
gentoo-2-ea35c1708ec20c04777ba060c8e65a2b16c790e0.tar.bz2
gentoo-2-ea35c1708ec20c04777ba060c8e65a2b16c790e0.zip
Applied misc patch (frame, tab, truetype, auth, ssl ...) by default. Marked stable on x86 and alpha.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/dillo/ChangeLog6
-rw-r--r--net-www/dillo/dillo-0.7.3-r5.ebuild41
2 files changed, 23 insertions, 24 deletions
diff --git a/net-www/dillo/ChangeLog b/net-www/dillo/ChangeLog
index 91fd0bd5ffa3..17567286b3b3 100644
--- a/net-www/dillo/ChangeLog
+++ b/net-www/dillo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/dillo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.31 2004/03/26 19:39:13 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.32 2004/03/27 16:34:30 usata Exp $
+
+ 28 Mar 2004; Mamoru KOMACHI <usata@gentoo.org> dillo-0.7.3-r5.ebuild:
+ Applied misc patch (frame, tab, truetype, auth, ssl ...) by default.
+ Marked stable on x86 and alpha.
*dillo-0.8.0 (27 Mar 2004)
diff --git a/net-www/dillo/dillo-0.7.3-r5.ebuild b/net-www/dillo/dillo-0.7.3-r5.ebuild
index 4397f62cff1a..616560d97f63 100644
--- a/net-www/dillo/dillo-0.7.3-r5.ebuild
+++ b/net-www/dillo/dillo-0.7.3-r5.ebuild
@@ -1,35 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r5.ebuild,v 1.2 2004/02/23 09:46:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r5.ebuild,v 1.3 2004/03/27 16:34:30 usata Exp $
inherit flag-o-matic
S2=${WORKDIR}/dillo-gentoo-extras-patch3
-I18N_P=${P}-i18n-misc-20031219
+DILLO_I18N_MISC=${P}-i18n-misc-20031219
DESCRIPTION="Lean GTK+-based web browser"
HOMEPAGE="http://www.dillo.org/"
SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
mirror://gentoo/dillo-gentoo-extras-patch3.tar.bz2
- cjk? ( http://teki.jpn.ph/pc/software/${I18N_P}.diff.bz2 )"
+ http://teki.jpn.ph/pc/software/${DILLO_I18N_MISC}.diff.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
-# Note that truetype, ssl and nls IUSE flags will take effect
-# only if you enable cjk IUSE flag.
-IUSE="ipv6 kde gnome mozilla truetype ssl cjk nls"
+KEYWORDS="x86 ~ppc ~sparc alpha ~hppa ~amd64"
+IUSE="ipv6 kde gnome mozilla truetype ssl nls"
DEPEND="=x11-libs/gtk+-1.2*
>=media-libs/jpeg-6b
>=sys-libs/zlib-1.1.3
>=media-libs/libpng-1.2.1
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl )
+ truetype? ( virtual/xft )"
src_unpack() {
unpack ${A}
cd ${S}
- use cjk && epatch ../${I18N_P}.diff
+ epatch ../${DILLO_I18N_MISC}.diff
if [ "${DILLO_ICONSET}" = "kde" ]
then
@@ -59,23 +58,19 @@ src_unpack() {
src_compile() {
replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
- local myconf
-
- if [ -n "`use cjk`" ] ; then
- if [ -n "`use truetype`" ] ; then
- CPPFLAGS="${CPPFLAGS} -I/usr/include/freetype2"
- LDFLAGS="${LDFLAGS} -L/usr/X11R6/lib -lXft"
- export CPPFLAGS LDFLAGS
- fi
- myconf="`use_enable nls`
- `use_enable ssl`
- `use_enable truetype anti-alias`
- --enable-meta-refresh
- --enable-web-search"
+ if [ -n "`use truetype`" ] ; then
+ CPPFLAGS="${CPPFLAGS} -I/usr/include/freetype2"
+ LDFLAGS="${LDFLAGS} -L/usr/X11R6/lib -lXft"
+ export CPPFLAGS LDFLAGS
fi
econf `use_enable ipv6` \
- ${myconf} || die
+ `use_enable nls` \
+ `use_enable ssl` \
+ `use_enable truetype anti-alias` \
+ --enable-meta-refresh \
+ --enable-web-search \
+ || die
emake || make || die
}