summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-06-20 03:11:21 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-06-20 03:11:21 +0000
commitdd55c9904c473e8d202484db1d37bab8289a81dc (patch)
treea14788881154f19726e200ce86de74922a974dcb /net-www
parentadd uclibc support (diff)
downloadgentoo-2-dd55c9904c473e8d202484db1d37bab8289a81dc.tar.gz
gentoo-2-dd55c9904c473e8d202484db1d37bab8289a81dc.tar.bz2
gentoo-2-dd55c9904c473e8d202484db1d37bab8289a81dc.zip
Added new version.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mplayerplug-in/ChangeLog7
-rw-r--r--net-www/mplayerplug-in/Manifest2
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-2.851
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-2.85.ebuild58
4 files changed, 67 insertions, 1 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index ce4bc7b65485..63dda1740fe2 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.39 2005/06/12 03:03:26 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.40 2005/06/20 03:11:21 josejx Exp $
+
+*mplayerplug-in-2.85 (20 Jun 2005)
+
+ 20 Jun 2005; Joseph Jezak <josejx@gentoo.org> +mplayerplug-in-2.85.ebuild:
+ Added new version.
12 Jun 2005; Joseph Jezak <josejx@gentoo.org> -mplayerplug-in-2.60.ebuild:
Removed old ebuild.
diff --git a/net-www/mplayerplug-in/Manifest b/net-www/mplayerplug-in/Manifest
index 76d1ceb11f0f..91ee1a38244d 100644
--- a/net-www/mplayerplug-in/Manifest
+++ b/net-www/mplayerplug-in/Manifest
@@ -1,6 +1,8 @@
MD5 1ddc12b49178f6340eac184e1022fc16 ChangeLog 6699
MD5 66c156160ef60780ee4c80a28873e766 metadata.xml 250
+MD5 faf28a621703ae26928ec71d967565c0 mplayerplug-in-2.85.ebuild 1440
MD5 dcf3ea4ec6dee69d83e30053dcef5c43 mplayerplug-in-2.66.ebuild 1397
MD5 3bcc5419175f3ff7ee63a586d9e0a2b7 mplayerplug-in-2.80.ebuild 1438
+MD5 c2e30e3c9bd430344299015704bc28b6 files/digest-mplayerplug-in-2.85 71
MD5 ccdd34ab806933589a0d87348456484c files/digest-mplayerplug-in-2.66 155
MD5 8642e3be6b1af51cbbf7e7790cc8ba12 files/digest-mplayerplug-in-2.80 71
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-2.85 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-2.85
new file mode 100644
index 000000000000..22a1ce455dd5
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-2.85
@@ -0,0 +1 @@
+MD5 57353e0f61640331972f860aa5fda3f1 mplayerplug-in-2.85.tar.gz 181541
diff --git a/net-www/mplayerplug-in/mplayerplug-in-2.85.ebuild b/net-www/mplayerplug-in/mplayerplug-in-2.85.ebuild
new file mode 100644
index 000000000000..31ca01fa1bdd
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-2.85.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-2.85.ebuild,v 1.1 2005/06/20 03:11:21 josejx Exp $
+
+inherit nsplugins toolchain-funcs
+
+DESCRIPTION="mplayer plug-in for Mozilla"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="gtk2"
+
+DEPEND="
+ >=media-video/mplayer-1.0_pre5
+ net-libs/gecko-sdk
+ gtk2? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1 )
+ !gtk2? (
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2* )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --with-gecko-sdk=/usr/share/gecko-sdk"
+ if use gtk2; then
+ einfo Configuring to build using gtk2
+ myconf="${myconf} --enable-gtk2"
+ else
+ einfo Configuring to build using gtk1
+ myconf="${myconf} --disable-gtk2 --enable-gtk1"
+ fi
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ # Install .xpt, bug #83162
+ insinto /opt/netscape/plugins
+ doins mplayerplug-in.xpt
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.xpt
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README TODO DOCS/tech/*.txt
+}