summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-26 22:27:53 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-26 22:27:53 +0000
commitd4cece77f1cb44ba06e1cd8c9a9dbe23e708f053 (patch)
tree2ef4cbebc026ad5cb72062a6830d61afc4dcc726 /net-www
parentAdded binary snapshot (Manifest recommit) (diff)
downloadgentoo-2-d4cece77f1cb44ba06e1cd8c9a9dbe23e708f053.tar.gz
gentoo-2-d4cece77f1cb44ba06e1cd8c9a9dbe23e708f053.tar.bz2
gentoo-2-d4cece77f1cb44ba06e1cd8c9a9dbe23e708f053.zip
really fix the sandbox problem with 0.23, add fixes to gtkhtml2 detection via virtualmake (#47879)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/straw/ChangeLog7
-rw-r--r--net-www/straw/straw-0.22.1.ebuild7
-rw-r--r--net-www/straw/straw-0.23.ebuild17
3 files changed, 21 insertions, 10 deletions
diff --git a/net-www/straw/ChangeLog b/net-www/straw/ChangeLog
index f93e25296a48..462f9f99841a 100644
--- a/net-www/straw/ChangeLog
+++ b/net-www/straw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/straw
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/straw/ChangeLog,v 1.28 2004/06/25 01:13:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/straw/ChangeLog,v 1.29 2004/06/26 22:27:53 liquidx Exp $
+
+ 26 Jun 2004; Alastair Tse <liquidx@gentoo.org> straw-0.22.1.ebuild,
+ straw-0.23.ebuild:
+ really fix the sandbox problem with 0.23, add fixes to gtkhtml2 detection via
+ virtualmake (#47879)
*straw-0.23 (08 Jun 2004)
diff --git a/net-www/straw/straw-0.22.1.ebuild b/net-www/straw/straw-0.22.1.ebuild
index 20bb5300fb01..5afa9b7aeb55 100644
--- a/net-www/straw/straw-0.22.1.ebuild
+++ b/net-www/straw/straw-0.22.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.22.1.ebuild,v 1.6 2004/06/25 01:13:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.22.1.ebuild,v 1.7 2004/06/26 22:27:53 liquidx Exp $
-inherit gnome2 python distutils
+inherit gnome2 python distutils virtualx
DESCRIPTION="RSS/RDF News Aggregator"
HOMEPAGE="http://www.nongnu.org/straw/"
@@ -28,7 +28,8 @@ RDEPEND="${DEPEND}
# foser <foser@gentoo.org> 18 Feb 2004
pkg_setup() {
- if ! python -c 'import gtk; import gtkhtml2'; then
+ export maketype="python"
+ if ! echo "import gtkhtml2" | virtualmake; then
eerror "The gnome-python gtkhtml2 module was not found."
eerror "Rebuild gnome-python using:"
eerror " USE=\"gtkhtml\" emerge gnome-python"
diff --git a/net-www/straw/straw-0.23.ebuild b/net-www/straw/straw-0.23.ebuild
index 3c40dd2e331a..a9fddae16f21 100644
--- a/net-www/straw/straw-0.23.ebuild
+++ b/net-www/straw/straw-0.23.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.23.ebuild,v 1.3 2004/06/25 01:13:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.23.ebuild,v 1.4 2004/06/26 22:27:53 liquidx Exp $
-inherit gnome2 python distutils
+inherit gnome2 python distutils virtualx
DESCRIPTION="RSS/RDF News Aggregator"
HOMEPAGE="http://www.nongnu.org/straw/"
@@ -23,12 +23,14 @@ RDEPEND="${DEPEND}
>=dev-python/bsddb3-3.4.0
>=dev-python/egenix-mx-base-2
!ppc? ( >=dev-python/adns-python-1.0.0 )"
+
# REMIND : egenix-mx-base is only needed for the conversion of
# pre 0.22 straw databases. It should be removed at some point.
# foser <foser@gentoo.org> 18 Feb 2004
pkg_setup() {
- if ! python -c 'import gtk; import gtkhtml2'; then
+ export maketype="python"
+ if ! echo "import gtkhtml2" | virtualmake; then
eerror "The gnome-python gtkhtml2 module was not found."
eerror "Rebuild gnome-python using:"
eerror " USE=\"gtkhtml\" emerge gnome-python"
@@ -36,13 +38,16 @@ pkg_setup() {
fi
}
-src_install() {
+src_compile() {
+ return
+}
+src_install() {
+ # work around bug in straw's install script
distutils_src_install \
--prefix=/usr \
- --sysconfdir=/etc \
+ --sysconfdir=${D}/etc \
--disable-schemas-install
-
}
pkg_postinst() {