summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-10-31 16:57:08 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-10-31 16:57:08 +0000
commitd1faa1430353bee7b0f7cccb38441cecbb75cc38 (patch)
treec18e6f6b4f3accc23dc4c5e9782adc087217163e /net-www
parentMasked opera-static-6.1 for testing. (diff)
downloadgentoo-2-d1faa1430353bee7b0f7cccb38441cecbb75cc38.tar.gz
gentoo-2-d1faa1430353bee7b0f7cccb38441cecbb75cc38.tar.bz2
gentoo-2-d1faa1430353bee7b0f7cccb38441cecbb75cc38.zip
Updated to 6.1.
Now installing a symlink /usr/bin/opera -> /opt/opera/bin/opera. Masked out for testing.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/opera-static/ChangeLog9
-rw-r--r--net-www/opera-static/files/digest-opera-static-6.11
-rw-r--r--net-www/opera-static/opera-static-6.1.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/net-www/opera-static/ChangeLog b/net-www/opera-static/ChangeLog
index cf19e97ef698..4444cd961a4e 100644
--- a/net-www/opera-static/ChangeLog
+++ b/net-www/opera-static/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/opera-static
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/opera-static/ChangeLog,v 1.6 2002/10/21 05:44:53 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/opera-static/ChangeLog,v 1.7 2002/10/31 16:57:08 agenkin Exp $
+
+*opera-static-6.1 (31 Oct 2002)
+
+ 31 Oct 2002; Arcady Genkin <agenkin@gentoo.org> opera-static-6.1.ebuild :
+
+ Updated to 6.1.
+ Now installing a symlink in /usr/bin.
*opera-static-6.03-r1 (21 Oct 2002)
diff --git a/net-www/opera-static/files/digest-opera-static-6.1 b/net-www/opera-static/files/digest-opera-static-6.1
new file mode 100644
index 000000000000..3e68d09a39bd
--- /dev/null
+++ b/net-www/opera-static/files/digest-opera-static-6.1
@@ -0,0 +1 @@
+MD5 0bbf000275745f51ece957c190e2bca0 opera-6.10-20021029.1-static-qt.i386.tar.bz2 4642353
diff --git a/net-www/opera-static/opera-static-6.1.ebuild b/net-www/opera-static/opera-static-6.1.ebuild
new file mode 100644
index 000000000000..41a3047d23d1
--- /dev/null
+++ b/net-www/opera-static/opera-static-6.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/opera-static/opera-static-6.1.ebuild,v 1.1 2002/10/31 16:57:08 agenkin Exp $
+
+DESCRIPTION="Opera web browser, statically built."
+HOMEPAGE="http://www.opera.com/linux/"
+LICENSE="OPERA"
+
+DEPEND="virtual/x11
+ x11-libs/lesstif"
+KEYWORDS="x86 -ppc sparc sparc64"
+SLOT="0"
+
+NV=6.10-20021029.1-static-qt.i386
+SRC_URI="http://www.panix.com/opera/files/linux/610/final/en/i386/static/opera-${NV}.tar.bz2"
+
+S=${WORKDIR}/opera-${NV}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ sed -e "s:/etc:${D}/etc:g" \
+ -e "s:config_dir=\"/etc\":config_dir=\"${D}/etc/\":g" \
+ -e "s:read install_config:install_config=yes:" \
+ -e "s:/usr/share/applnk:${D}/usr/share/applnk:g" \
+ -e "s:/usr/share/pixmaps:${D}/usr/share/pixmaps:g" \
+ -e "s:/usr/share/icons:${D}/usr/share/icons:g" \
+ -e "s:/etc/X11:${D}/etc/X11:g" \
+ -e "s:/usr/share/gnome:${D}/usr/share/gnome:g" \
+ < install.sh >install.sh.hacked || die
+ mv install.sh.hacked install.sh
+ chmod +x install.sh
+
+}
+
+src_compile() {
+ # Nothing to do.
+ true
+}
+
+src_install() {
+
+ dodir /etc
+ ./install.sh --prefix="${D}"/opt/opera || die
+ rm ${D}/opt/opera/share/doc/opera/help
+ dosym /opt/share/doc/opera/help /opt/opera/share/opera/help
+ dosed /opt/opera/bin/opera
+
+ #install the icons
+ insinto /usr/share/icons /etc/X11/wmconfig /etc/X11/applnk/Internet \
+ /usr/share/pixmaps /usr/share/gnome/pixmaps
+ doins images/opera.xpm
+
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/pixmaps
+ doins images/opera.xpm
+ fi
+
+ # Install a symlink /usr/bin/opera
+ dodir /usr/bin
+ dosym /opt/opera/bin/opera /usr/bin/opera
+
+}