summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-23 14:36:24 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-23 14:36:24 +0000
commitc0ddccc68015b5c46d0ad87edf300cdba91767c1 (patch)
tree654fbdbc1af0297c23d14fc68ef52f743a06a351 /net-www
parentstable x86, bug 186180 (diff)
downloadgentoo-2-c0ddccc68015b5c46d0ad87edf300cdba91767c1.tar.gz
gentoo-2-c0ddccc68015b5c46d0ad87edf300cdba91767c1.tar.bz2
gentoo-2-c0ddccc68015b5c46d0ad87edf300cdba91767c1.zip
Fix building with --as-needed and swscaler enabled ffmpeg-20070616-r1 for bug 183714.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gnash/ChangeLog7
-rw-r--r--net-www/gnash/files/gnash-0.8.0-ffmpeg.patch103
-rw-r--r--net-www/gnash/gnash-0.8.0.ebuild20
3 files changed, 120 insertions, 10 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index 058fc5f57ea5..98737419dded 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.48 2007/07/22 07:44:54 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.49 2007/07/23 14:36:24 drac Exp $
+
+ 23 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/gnash-0.8.0-ffmpeg.patch, gnash-0.8.0.ebuild:
+ Fix building with --as-needed and swscaler enabled ffmpeg-20070616-r1 for
+ bug 183714.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; gnash-0.8.0.ebuild,
gnash-9999.ebuild:
diff --git a/net-www/gnash/files/gnash-0.8.0-ffmpeg.patch b/net-www/gnash/files/gnash-0.8.0-ffmpeg.patch
new file mode 100644
index 000000000000..b9b763ba4357
--- /dev/null
+++ b/net-www/gnash/files/gnash-0.8.0-ffmpeg.patch
@@ -0,0 +1,103 @@
+diff -ur gnash-0.8.0.orig/backend/sound_handler_sdl.h gnash-0.8.0/backend/sound_handler_sdl.h
+--- gnash-0.8.0.orig/backend/sound_handler_sdl.h 2007-05-28 18:40:58.000000000 +0300
++++ gnash-0.8.0/backend/sound_handler_sdl.h 2007-07-23 16:13:13.000000000 +0300
+@@ -26,7 +26,11 @@
+ #include "log.h"
+
+ #ifdef USE_FFMPEG
++
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
++
+ #elif defined(USE_MAD)
+ #include <mad.h>
+ #endif
+diff -ur gnash-0.8.0.orig/configure.ac gnash-0.8.0/configure.ac
+--- gnash-0.8.0.orig/configure.ac 2007-06-09 03:48:15.000000000 +0300
++++ gnash-0.8.0/configure.ac 2007-07-23 17:14:05.000000000 +0300
+@@ -881,6 +881,7 @@
+
+ if test x"$media_handler" = x"ffmpeg"; then
+ GNASH_PATH_FFMPEG
++ PKG_CHECK_MODULES(FFMPEG, libavutil libavformat libavcodec libswscale, HAVE_FFMPEG=yes, AC_MSG_ERROR([FFMPEG not found.]))
+ if test x"${media_handler_specified}" = xfalse; then
+ # If the library is not found, or its version is not ok, we'll try gst
+ if test x"${ac_cv_path_ffmpeg_lib}" = x -o x"${ffmpeg_version}" != xok; then
+@@ -890,6 +891,8 @@
+ fi
+ fi
+
++AC_SUBST(FFMPEG_LIBS)
++
+ if test "$media_handler" = "gst"; then
+ GNASH_PKG_FIND(gstreamer, [gst/gst.h], [gstreamer library], gst_init, [0.10])
+ if test x"${media_handler_specified}" = xfalse; then
+diff -ur gnash-0.8.0.orig/libbase/embedVideoDecoderFfmpeg.cpp gnash-0.8.0/libbase/embedVideoDecoderFfmpeg.cpp
+--- gnash-0.8.0.orig/libbase/embedVideoDecoderFfmpeg.cpp 2007-06-08 21:44:16.000000000 +0300
++++ gnash-0.8.0/libbase/embedVideoDecoderFfmpeg.cpp 2007-07-23 16:10:45.000000000 +0300
+@@ -26,7 +26,11 @@
+ #include "embedVideoDecoderFfmpeg.h"
+
+ #ifdef HAVE_SWSCALE_H
++
++extern "C" {
+ #include <ffmpeg/swscale.h>
++}
++
+ #endif
+
+ #include <boost/scoped_array.hpp>
+diff -ur gnash-0.8.0.orig/libbase/embedVideoDecoderFfmpeg.h gnash-0.8.0/libbase/embedVideoDecoderFfmpeg.h
+--- gnash-0.8.0.orig/libbase/embedVideoDecoderFfmpeg.h 2007-06-08 07:18:37.000000000 +0300
++++ gnash-0.8.0/libbase/embedVideoDecoderFfmpeg.h 2007-07-23 16:10:37.000000000 +0300
+@@ -28,7 +28,11 @@
+
+ #include <vector>
+ #include "embedVideoDecoder.h"
++
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
++
+ #include "image.h"
+
+ namespace gnash {
+diff -ur gnash-0.8.0.orig/libbase/Makefile.am gnash-0.8.0/libbase/Makefile.am
+--- gnash-0.8.0.orig/libbase/Makefile.am 2007-05-21 18:46:48.000000000 +0300
++++ gnash-0.8.0/libbase/Makefile.am 2007-07-23 17:01:18.000000000 +0300
+@@ -160,7 +160,7 @@
+ if USE_FFMPEG_ENGINE
+ libgnashbase_la_SOURCES += embedVideoDecoderFfmpeg.cpp
+ noinst_HEADERS += embedVideoDecoderFfmpeg.h
+-libgnashbase_la_LIBADD += $(FFMPEG_LIBS)
++libgnashbase_la_LIBADD += $(FFMPEG_LIBS) @FFMPEG_LIBS@
+ libgnashbase_la_CPPFLAGS += $(FFMPEG_CFLAGS)
+ endif
+
+diff -ur gnash-0.8.0.orig/server/asobj/NetStreamFfmpeg.h gnash-0.8.0/server/asobj/NetStreamFfmpeg.h
+--- gnash-0.8.0.orig/server/asobj/NetStreamFfmpeg.h 2007-06-04 15:02:16.000000000 +0300
++++ gnash-0.8.0/server/asobj/NetStreamFfmpeg.h 2007-07-23 16:11:27.000000000 +0300
+@@ -39,7 +39,9 @@
+ #include "impl.h"
+ #include "video_stream_instance.h"
+
++extern "C" {
+ #include <ffmpeg/avformat.h>
++}
+
+ #include "image.h"
+ #include "StreamProvider.h"
+diff -ur gnash-0.8.0.orig/server/asobj/SoundFfmpeg.h gnash-0.8.0/server/asobj/SoundFfmpeg.h
+--- gnash-0.8.0.orig/server/asobj/SoundFfmpeg.h 2007-05-28 18:41:08.000000000 +0300
++++ gnash-0.8.0/server/asobj/SoundFfmpeg.h 2007-07-23 16:11:53.000000000 +0300
+@@ -32,7 +32,9 @@
+ #include <boost/bind.hpp>
+ #include <boost/thread/mutex.hpp>
+
++extern "C" {
+ #include <ffmpeg/avformat.h>
++}
+
+ namespace gnash {
+
diff --git a/net-www/gnash/gnash-0.8.0.ebuild b/net-www/gnash/gnash-0.8.0.ebuild
index a9c0aead945e..11ffc62186e0 100644
--- a/net-www/gnash/gnash-0.8.0.ebuild
+++ b/net-www/gnash/gnash-0.8.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.0.ebuild,v 1.5 2007/07/22 07:44:54 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.0.ebuild,v 1.6 2007/07/23 14:36:24 drac Exp $
+
+WANT_AUTOMAKE="1.9"
inherit nsplugins kde-functions qt3 multilib flag-o-matic autotools
-set-kdedir
+set-kdedir eutils
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
@@ -49,6 +51,9 @@ RDEPEND="
agg? ( x11-libs/agg )"
#cairo? ( x11-libs/cairo )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
pkg_setup() {
if use agg && use kde; then
eerror "Building klash with the agg based renderer is not supported"
@@ -75,13 +80,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
- #as-needed breaks, see bug 183714
- #
- # TODO - does not work for me
- #epatch ${FILESDIR}/gnash-no-asneeded.patch
- #filter-ldflags -Wl,--as-needed --as-needed
- #eautoconf
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ffmpeg.patch
+ eautoconf
+ eautomake
}
src_compile() {