summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-11 15:57:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-11 15:57:45 +0000
commitade48739101bf850b35bb0f9463c2fd990f20333 (patch)
tree6de07f88b0b1f00b6c13bdbc057e9aae2e3c0ecf /net-www
parentfixed small typ0 (diff)
downloadgentoo-2-ade48739101bf850b35bb0f9463c2fd990f20333.tar.gz
gentoo-2-ade48739101bf850b35bb0f9463c2fd990f20333.tar.bz2
gentoo-2-ade48739101bf850b35bb0f9463c2fd990f20333.zip
fix0rs
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/ChangeLog24
-rw-r--r--net-www/links/files/digest-links-2.1_pre2-r22
-rw-r--r--net-www/links/links-2.1_pre2-r2.ebuild100
3 files changed, 125 insertions, 1 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index 9fbdb1b9e66a..6a43bd47bbfb 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,6 +1,28 @@
# ChangeLog for net-www/links
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.13 2002/08/29 22:42:37 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.14 2002/09/11 15:57:45 seemant Exp $
+
+*links-2.1_pre2 (11 Sep 2002)
+
+ 11 Sep 2002; Seemant Kulleen <seemant@gentoo.org> links-2.1_pre2-r2.ebuild
+ files/digest-links-2.1_pre2-r2 :
+
+ From: kevin@aptbasilicata.it (Maurizio Disimino) in bug # 7809
+
+ at the moment, links will be compiled with --enable-graphics only if
+ USE="png". If --enable-graphics is not supplied, fb WILL NOT WORK.
+ Moreover, --enable-graphis should be enabled for 'X' or 'fbcon'.
+
+ Note: if X or fbcon usegflag are enabled, links will be built in
+ graphic mode. libpng is required to compile links in graphic mode
+ not required in textmode),so let's add libpng for X? and fbcon?
+
+ X? ( virtual/x11 >=media-libs/libpng-1.2.1 )
+ fbcon? ( >=media-libs/libpng-1.2.1 )"
+
+ - Fixed DEPEND and src_compile().
+ - Some cosmetic changes.
+
29 Aug 2002; Seemant Kulleen <seemant@gentoo.org> links-0.96-r2.ebuild
links-2.1_pre2-r1.ebuild :
diff --git a/net-www/links/files/digest-links-2.1_pre2-r2 b/net-www/links/files/digest-links-2.1_pre2-r2
new file mode 100644
index 000000000000..d3dda5e8d4bb
--- /dev/null
+++ b/net-www/links/files/digest-links-2.1_pre2-r2
@@ -0,0 +1,2 @@
+MD5 e8db2be73ebc47d2096e7496a0ec16bd links-2.1pre2.tar.bz2 3509541
+MD5 d52a2167074dda20abbdc95853a5a4f1 links-2.1_pre2-patch.tar.bz2 2287
diff --git a/net-www/links/links-2.1_pre2-r2.ebuild b/net-www/links/links-2.1_pre2-r2.ebuild
new file mode 100644
index 000000000000..b4a73131000f
--- /dev/null
+++ b/net-www/links/links-2.1_pre2-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre2-r2.ebuild,v 1.1 2002/09/11 15:57:45 seemant Exp $
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/links-2.1_pre2-patch.tar.bz2"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic mode.
+# libpng is required to compile links in graphic mode (not required in text mode),
+# so let's add libpng for X? and fbcon?
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ java? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 )
+ X? ( virtual/x11 >=media-libs/libpng-1.2.1 )
+ fbcon? ( >=media-libs/libpng-1.2.1 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_compile (){
+
+ local myconf
+ myconf="--program-suffix=2"
+
+ use X \
+ && myconf="${myconf} --enable-graphics --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --with-libpng" \
+ || myconf="${myconf} --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-graphics --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use java \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+
+ # This patch adds support for various little fixes
+ patch -p1 < ${WORKDIR}/links.patch || die "Failed to apply the patch"
+
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install (){
+ einstall
+
+ if [ ! -f /usr/bin/links ]
+ then
+ dosym links2 /usr/bin/links
+ fi
+
+ # Only install links icon if X driver was compiled in ...
+ use X && { insinto /usr/share/pixmaps ; doins graphics/links.xpm ; }
+
+ # links needs to be setuid for it to work with svga
+ use svga && { fperms 4755 /usr/bin/links2 ; }
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}