summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-09-20 05:11:35 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-09-20 05:11:35 +0000
commit8febd3ba030319b661d4fa6e79d91af5e704f569 (patch)
treeeb552767dcbeef149613d62e7e5ab506f08817c1 /net-www
parent(#148281) Change herd to sci-chemistry from sci. (diff)
downloadgentoo-2-8febd3ba030319b661d4fa6e79d91af5e704f569.tar.gz
gentoo-2-8febd3ba030319b661d4fa6e79d91af5e704f569.tar.bz2
gentoo-2-8febd3ba030319b661d4fa6e79d91af5e704f569.zip
Remove no-suexec USE-flag from 1.3 and 2.0 as it's broken and requires modification to configuration to get it working. Fixes bug 148082.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog9
-rw-r--r--net-www/apache/apache-1.3.34-r10.ebuild15
-rw-r--r--net-www/apache/apache-1.3.34-r11.ebuild15
-rw-r--r--net-www/apache/apache-1.3.34-r14.ebuild15
-rw-r--r--net-www/apache/apache-1.3.37.ebuild15
-rw-r--r--net-www/apache/apache-2.0.54-r31.ebuild26
-rw-r--r--net-www/apache/apache-2.0.58-r2.ebuild26
-rw-r--r--net-www/apache/apache-2.0.58.ebuild26
-rw-r--r--net-www/apache/apache-2.0.59.ebuild26
9 files changed, 108 insertions, 65 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 5ee52e2c6b0f..84a1ccc832fb 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/apache
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.498 2006/09/10 17:35:00 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.499 2006/09/20 05:11:34 vericgar Exp $
+
+ 20 Sep 2006; Michael Stewart <vericgar@gentoo.org>
+ apache-1.3.34-r10.ebuild, apache-1.3.34-r11.ebuild,
+ apache-1.3.34-r14.ebuild, apache-1.3.37.ebuild, apache-2.0.54-r31.ebuild,
+ apache-2.0.58.ebuild, apache-2.0.58-r2.ebuild, apache-2.0.59.ebuild:
+ Remove no-suexec USE-flag from 1.3 and 2.0 as it's broken and requires
+ modification to configuration to get it working. Fixes bug 148082.
10 Sep 2006; Javier Villavicencio <the_paya@gentoo.org>
apache-2.2.3.ebuild:
diff --git a/net-www/apache/apache-1.3.34-r10.ebuild b/net-www/apache/apache-1.3.34-r10.ebuild
index ae54ffa8c625..c13856c36d4c 100644
--- a/net-www/apache/apache-1.3.34-r10.ebuild
+++ b/net-www/apache/apache-1.3.34-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r10.ebuild,v 1.9 2006/07/21 03:36:06 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r10.ebuild,v 1.10 2006/09/20 05:11:35 vericgar Exp $
inherit eutils fixheadtails multilib
@@ -25,7 +25,7 @@ SRC_URI="mirror://apache/httpd/apache_${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc ssl pam lingerd no-suexec static-modules selinux"
+IUSE="doc ssl pam lingerd static-modules selinux"
DEPEND="dev-lang/perl
|| ( sys-libs/gdbm ~sys-libs/db-1.85 )
@@ -103,7 +103,10 @@ src_compile() {
select_modules_config || die "determining modules"
- if ! useq no-suexec; then
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if ! useq no-suexec; then
myconf="${myconf}
--enable-suexec
--suexec-uidmin=1000 \
@@ -113,7 +116,7 @@ src_compile() {
--suexec-docroot=/var/www \
--suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--suexec-logfile=/var/log/apache/suexec_log"
- fi
+# fi
if useq ssl; then
myconf="${myconf} --enable-rule=EAPI"
@@ -151,10 +154,10 @@ src_install() {
dodoc ABOUT_APACHE Announcement INSTALL LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache/lib
diff --git a/net-www/apache/apache-1.3.34-r11.ebuild b/net-www/apache/apache-1.3.34-r11.ebuild
index 6a2f330ac701..1e21f9322c49 100644
--- a/net-www/apache/apache-1.3.34-r11.ebuild
+++ b/net-www/apache/apache-1.3.34-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r11.ebuild,v 1.10 2006/07/21 03:36:06 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r11.ebuild,v 1.11 2006/09/20 05:11:35 vericgar Exp $
inherit eutils fixheadtails multilib
@@ -25,7 +25,7 @@ SRC_URI="mirror://apache/httpd/apache_${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="doc ssl pam lingerd no-suexec static-modules selinux"
+IUSE="doc ssl pam lingerd static-modules selinux"
DEPEND="dev-lang/perl
|| ( sys-libs/gdbm ~sys-libs/db-1.85 )
@@ -108,7 +108,10 @@ src_compile() {
select_modules_config || die "determining modules"
- if ! useq no-suexec; then
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if ! useq no-suexec; then
myconf="${myconf}
--enable-suexec
--suexec-uidmin=1000 \
@@ -118,7 +121,7 @@ src_compile() {
--suexec-docroot=/var/www \
--suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--suexec-logfile=/var/log/apache/suexec_log"
- fi
+# fi
if useq ssl; then
myconf="${myconf} --enable-rule=EAPI"
@@ -156,10 +159,10 @@ src_install() {
dodoc ABOUT_APACHE Announcement INSTALL LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache/lib
diff --git a/net-www/apache/apache-1.3.34-r14.ebuild b/net-www/apache/apache-1.3.34-r14.ebuild
index 5c9d54709738..396212f923a5 100644
--- a/net-www/apache/apache-1.3.34-r14.ebuild
+++ b/net-www/apache/apache-1.3.34-r14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r14.ebuild,v 1.3 2006/09/08 21:33:40 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r14.ebuild,v 1.4 2006/09/20 05:11:35 vericgar Exp $
inherit eutils fixheadtails multilib
@@ -25,7 +25,7 @@ SRC_URI="mirror://apache/httpd/apache_${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="doc ssl pam lingerd no-suexec static-modules selinux"
+IUSE="doc ssl pam lingerd static-modules selinux"
DEPEND="dev-lang/perl
|| ( sys-libs/gdbm ~sys-libs/db-1.85 )
@@ -108,7 +108,10 @@ src_compile() {
select_modules_config || die "determining modules"
- if ! useq no-suexec; then
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if ! useq no-suexec; then
myconf="${myconf}
--enable-suexec
--suexec-uidmin=1000 \
@@ -118,7 +121,7 @@ src_compile() {
--suexec-docroot=/var/www \
--suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--suexec-logfile=/var/log/apache/suexec_log"
- fi
+# fi
if useq ssl; then
myconf="${myconf} --enable-rule=EAPI"
@@ -156,10 +159,10 @@ src_install() {
dodoc ABOUT_APACHE Announcement INSTALL LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache/lib
diff --git a/net-www/apache/apache-1.3.37.ebuild b/net-www/apache/apache-1.3.37.ebuild
index 42dbd97f3b56..e2d6d6edc86e 100644
--- a/net-www/apache/apache-1.3.37.ebuild
+++ b/net-www/apache/apache-1.3.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.37.ebuild,v 1.3 2006/09/02 15:49:47 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.37.ebuild,v 1.4 2006/09/20 05:11:35 vericgar Exp $
inherit eutils fixheadtails multilib
@@ -25,7 +25,7 @@ SRC_URI="mirror://apache/httpd/apache_${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc ssl pam lingerd no-suexec static-modules selinux"
+IUSE="doc ssl pam lingerd static-modules selinux"
DEPEND="dev-lang/perl
sys-libs/gdbm
@@ -114,7 +114,10 @@ src_compile() {
select_modules_config || die "determining modules"
- if ! useq no-suexec; then
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if ! useq no-suexec; then
myconf="${myconf}
--enable-suexec
--suexec-uidmin=1000 \
@@ -124,7 +127,7 @@ src_compile() {
--suexec-docroot=/var/www \
--suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--suexec-logfile=/var/log/apache/suexec_log"
- fi
+# fi
if useq ssl; then
myconf="${myconf} --enable-rule=EAPI"
@@ -162,10 +165,10 @@ src_install() {
dodoc ABOUT_APACHE Announcement INSTALL LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache/lib
diff --git a/net-www/apache/apache-2.0.54-r31.ebuild b/net-www/apache/apache-2.0.54-r31.ebuild
index 6b44d855596b..808265572217 100644
--- a/net-www/apache/apache-2.0.54-r31.ebuild
+++ b/net-www/apache/apache-2.0.54-r31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.21 2006/07/21 03:36:06 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.22 2006/09/20 05:11:34 vericgar Exp $
inherit eutils gnuconfig multilib
@@ -18,7 +18,7 @@ SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2
LICENSE="Apache-2.0"
SLOT="2"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="apache2 debug doc ldap mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker no-suexec ssl static-modules threads selinux"
+IUSE="apache2 debug doc ldap mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker ssl static-modules threads selinux"
RDEPEND="dev-lang/perl
|| ( ~dev-libs/apr-0.9.12 ~dev-libs/apr-0.9.7 ~dev-libs/apr-0.9.6 )
@@ -127,9 +127,12 @@ src_compile() {
# and the glibc (pthread) source
echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
- if useq no-suexec; then
- myconf="${myconf} --disable-suexec"
- else
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if useq no-suexec; then
+# myconf="${myconf} --disable-suexec"
+# else
myconf="${myconf}
--with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--with-suexec-logfile=/var/log/apache2/suexec_log \
@@ -141,7 +144,7 @@ src_compile() {
--with-suexec-gidmin=100 \
--with-suexec-umask=077 \
--enable-suexec=shared"
- fi
+# fi
# common confopts
myconf="${myconf} \
@@ -190,10 +193,10 @@ src_install () {
dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache2/lib
@@ -247,7 +250,8 @@ src_install () {
mv -v usr/sbin/list_hooks.pl usr/sbin/list_hooks2.pl
mv -v usr/sbin/logresolve.pl usr/sbin/logresolve2.pl
useq ssl && mv -v usr/sbin/ab-ssl usr/sbin/ab2-ssl
- useq no-suexec || mv -v usr/sbin/suexec usr/sbin/suexec2
+# useq no-suexec ||
+ mv -v usr/sbin/suexec usr/sbin/suexec2
# do the man pages
for i in htdigest.1 htpasswd.1 dbmmanage.1; do
@@ -256,7 +260,9 @@ src_install () {
for i in ab.8 apxs.8 logresolve.8 rotatelogs.8; do
mv -v usr/share/man/man8/${i} usr/share/man/man8/${i/./2.}
done
- useq no-suexec || mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+ #useq no-suexec ||
+ mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+
mv -v usr/share/man/man8/apachectl.8 usr/share/man/man8/apache2ctl.8
mv -v usr/share/man/man8/httpd.8 usr/share/man/man8/apache2.8
diff --git a/net-www/apache/apache-2.0.58-r2.ebuild b/net-www/apache/apache-2.0.58-r2.ebuild
index 7edf2e3fe2d0..ffd246859dc1 100644
--- a/net-www/apache/apache-2.0.58-r2.ebuild
+++ b/net-www/apache/apache-2.0.58-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.58-r2.ebuild,v 1.5 2006/09/08 21:33:40 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.58-r2.ebuild,v 1.6 2006/09/20 05:11:34 vericgar Exp $
inherit eutils flag-o-matic gnuconfig multilib
@@ -18,7 +18,7 @@ SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2
LICENSE="Apache-2.0"
SLOT="2"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="apache2 debug doc ldap mpm-itk mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker no-suexec ssl static-modules threads selinux"
+IUSE="apache2 debug doc ldap mpm-itk mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker ssl static-modules threads selinux"
RDEPEND="dev-lang/perl
~dev-libs/apr-0.9.12
@@ -131,9 +131,12 @@ src_compile() {
# and the glibc (pthread) source
echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
- if useq no-suexec; then
- myconf="${myconf} --disable-suexec"
- else
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if useq no-suexec; then
+# myconf="${myconf} --disable-suexec"
+# else
myconf="${myconf}
--with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--with-suexec-logfile=/var/log/apache2/suexec_log \
@@ -145,7 +148,7 @@ src_compile() {
--with-suexec-gidmin=100 \
--with-suexec-umask=077 \
--enable-suexec=shared"
- fi
+# fi
# common confopts
myconf="${myconf} \
@@ -194,10 +197,10 @@ src_install () {
dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache2/lib
@@ -251,7 +254,8 @@ src_install () {
mv -v usr/sbin/list_hooks.pl usr/sbin/list_hooks2.pl
mv -v usr/sbin/logresolve.pl usr/sbin/logresolve2.pl
useq ssl && mv -v usr/sbin/ab-ssl usr/sbin/ab2-ssl
- useq no-suexec || mv -v usr/sbin/suexec usr/sbin/suexec2
+# useq no-suexec ||
+ mv -v usr/sbin/suexec usr/sbin/suexec2
# do the man pages
for i in htdigest.1 htpasswd.1 dbmmanage.1; do
@@ -260,7 +264,9 @@ src_install () {
for i in ab.8 apxs.8 logresolve.8 rotatelogs.8; do
mv -v usr/share/man/man8/${i} usr/share/man/man8/${i/./2.}
done
- useq no-suexec || mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+ #useq no-suexec ||
+ mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+
mv -v usr/share/man/man8/apachectl.8 usr/share/man/man8/apache2ctl.8
mv -v usr/share/man/man8/httpd.8 usr/share/man/man8/apache2.8
diff --git a/net-www/apache/apache-2.0.58.ebuild b/net-www/apache/apache-2.0.58.ebuild
index b3313b09985e..24ffe61eb3e3 100644
--- a/net-www/apache/apache-2.0.58.ebuild
+++ b/net-www/apache/apache-2.0.58.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.58.ebuild,v 1.10 2006/07/21 03:36:06 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.58.ebuild,v 1.11 2006/09/20 05:11:35 vericgar Exp $
inherit eutils flag-o-matic gnuconfig multilib
@@ -18,7 +18,7 @@ SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2
LICENSE="Apache-2.0"
SLOT="2"
KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="apache2 debug doc ldap mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker no-suexec ssl static-modules threads selinux"
+IUSE="apache2 debug doc ldap mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker ssl static-modules threads selinux"
RDEPEND="dev-lang/perl
~dev-libs/apr-0.9.12
@@ -129,9 +129,12 @@ src_compile() {
# and the glibc (pthread) source
echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
- if useq no-suexec; then
- myconf="${myconf} --disable-suexec"
- else
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if useq no-suexec; then
+# myconf="${myconf} --disable-suexec"
+# else
myconf="${myconf}
--with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--with-suexec-logfile=/var/log/apache2/suexec_log \
@@ -143,7 +146,7 @@ src_compile() {
--with-suexec-gidmin=100 \
--with-suexec-umask=077 \
--enable-suexec=shared"
- fi
+# fi
# common confopts
myconf="${myconf} \
@@ -192,10 +195,10 @@ src_install () {
dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache2/lib
@@ -249,7 +252,8 @@ src_install () {
mv -v usr/sbin/list_hooks.pl usr/sbin/list_hooks2.pl
mv -v usr/sbin/logresolve.pl usr/sbin/logresolve2.pl
useq ssl && mv -v usr/sbin/ab-ssl usr/sbin/ab2-ssl
- useq no-suexec || mv -v usr/sbin/suexec usr/sbin/suexec2
+# useq no-suexec ||
+ mv -v usr/sbin/suexec usr/sbin/suexec2
# do the man pages
for i in htdigest.1 htpasswd.1 dbmmanage.1; do
@@ -258,7 +262,9 @@ src_install () {
for i in ab.8 apxs.8 logresolve.8 rotatelogs.8; do
mv -v usr/share/man/man8/${i} usr/share/man/man8/${i/./2.}
done
- useq no-suexec || mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+ #useq no-suexec ||
+ mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+
mv -v usr/share/man/man8/apachectl.8 usr/share/man/man8/apache2ctl.8
mv -v usr/share/man/man8/httpd.8 usr/share/man/man8/apache2.8
diff --git a/net-www/apache/apache-2.0.59.ebuild b/net-www/apache/apache-2.0.59.ebuild
index d8d6f9dfac14..275c0ef427a9 100644
--- a/net-www/apache/apache-2.0.59.ebuild
+++ b/net-www/apache/apache-2.0.59.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.59.ebuild,v 1.1 2006/07/30 05:14:55 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.59.ebuild,v 1.2 2006/09/20 05:11:35 vericgar Exp $
inherit eutils flag-o-matic gnuconfig multilib
@@ -18,7 +18,7 @@ SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2
LICENSE="Apache-2.0"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="apache2 debug doc ldap mpm-itk mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker no-suexec ssl static-modules threads selinux"
+IUSE="apache2 debug doc ldap mpm-itk mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker ssl static-modules threads selinux"
RDEPEND="dev-lang/perl
~dev-libs/apr-0.9.12
@@ -138,9 +138,12 @@ src_compile() {
# and the glibc (pthread) source
echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
- if useq no-suexec; then
- myconf="${myconf} --disable-suexec"
- else
+# no more USE=no-suexec because of bug 148082
+# see the 2.2 ebuilds for how this can be done cleanly with a working system
+# "out of the box"
+# if useq no-suexec; then
+# myconf="${myconf} --disable-suexec"
+# else
myconf="${myconf}
--with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
--with-suexec-logfile=/var/log/apache2/suexec_log \
@@ -152,7 +155,7 @@ src_compile() {
--with-suexec-gidmin=100 \
--with-suexec-umask=077 \
--enable-suexec=shared"
- fi
+# fi
# common confopts
myconf="${myconf} \
@@ -201,10 +204,10 @@ src_install () {
dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt
# protect the suexec binary
- if ! useq no-suexec; then
+# if ! useq no-suexec; then
fowners root:apache /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
- fi
+# fi
# apxs needs this to pickup the right lib for install
dosym /usr/$(get_libdir) /usr/$(get_libdir)/apache2/lib
@@ -258,7 +261,8 @@ src_install () {
mv -v usr/sbin/list_hooks.pl usr/sbin/list_hooks2.pl
mv -v usr/sbin/logresolve.pl usr/sbin/logresolve2.pl
useq ssl && mv -v usr/sbin/ab-ssl usr/sbin/ab2-ssl
- useq no-suexec || mv -v usr/sbin/suexec usr/sbin/suexec2
+# useq no-suexec ||
+ mv -v usr/sbin/suexec usr/sbin/suexec2
# do the man pages
for i in htdigest.1 htpasswd.1 dbmmanage.1; do
@@ -267,7 +271,9 @@ src_install () {
for i in ab.8 apxs.8 logresolve.8 rotatelogs.8; do
mv -v usr/share/man/man8/${i} usr/share/man/man8/${i/./2.}
done
- useq no-suexec || mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+ #useq no-suexec ||
+ mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+
mv -v usr/share/man/man8/apachectl.8 usr/share/man/man8/apache2ctl.8
mv -v usr/share/man/man8/httpd.8 usr/share/man/man8/apache2.8