summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-06-17 16:57:48 +0000
committerDonny Davies <woodchip@gentoo.org>2003-06-17 16:57:48 +0000
commit8e3eca8d895f500ac45349ad9716b8f9c0ebdf3d (patch)
tree15f13bee80a485b9fea0a9afd249fa05b8f6f89a /net-www
parentImproved pkg_postinst (diff)
downloadgentoo-2-8e3eca8d895f500ac45349ad9716b8f9c0ebdf3d.tar.gz
gentoo-2-8e3eca8d895f500ac45349ad9716b8f9c0ebdf3d.tar.bz2
gentoo-2-8e3eca8d895f500ac45349ad9716b8f9c0ebdf3d.zip
small build fixes.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog6
-rw-r--r--net-www/apache/Manifest4
-rw-r--r--net-www/apache/apache-2.0.46.ebuild17
3 files changed, 18 insertions, 9 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 591ee5ddc9f2..3426b954132d 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/apache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.53 2003/06/05 04:08:34 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.54 2003/06/17 16:57:40 woodchip Exp $
+
+ 17 Jun 2003; Donny Davies <woodchip@gentoo.org> apache-2.0.46.ebuild:
+ Close #13191; GNU deprecated the -1 shortcuts (/me shakes head).
+ Add fixes to use `getent' instead of grepping through /etc/{passwd,group}.
*apache-2.0.46 (28 May 2003)
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index a8e227486a4a..d29f5a0bcd5c 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -1,4 +1,4 @@
-MD5 9f23a14b253b4b0efcbda11ea6af8b14 ChangeLog 10779
+MD5 ab1e866cb477525347ceb1ea3fb2905d ChangeLog 10996
MD5 21612edc47a4856367e269687587cb28 apache-1.3.27-r1.ebuild 7684
MD5 293d43996b56379dd46d9bda26776f96 apache-1.3.27-r2.ebuild 8156
MD5 e4c89cfcf1223c75beeacec2e0746c29 apache-1.3.27-r3.ebuild 7684
@@ -7,7 +7,7 @@ MD5 c93896f4268e681a335c92a01f22eddd apache-1.3.27.ebuild 8540
MD5 db01dbe8b200d4abfb604b8af8c648cf apache-2.0.43-r1.ebuild 9296
MD5 043a7cbb495f4c01245aa1447fcc7acf apache-2.0.44.ebuild 9269
MD5 8df3983c53028854b58c32b4a3338a31 apache-2.0.45.ebuild 10329
-MD5 fa31b662c0215cacb3420cdce2c02f2c apache-2.0.46.ebuild 10381
+MD5 91587791c6e5edaec632673b366ecb4f apache-2.0.46.ebuild 10479
MD5 f2c60b199c12729b25716ed451a24e38 files/apache-2.0.44-gentoo.diff 4895
MD5 9dc40e1918a2d30a578ebf1653f7182c files/apache-2.0.45-gentoo.diff 5448
MD5 c8c70224d0f41de7f02387f13911e539 files/apache-2.0.46-gentoo.diff 3963
diff --git a/net-www/apache/apache-2.0.46.ebuild b/net-www/apache/apache-2.0.46.ebuild
index b75495a48d1f..55f5b354e9f0 100644
--- a/net-www/apache/apache-2.0.46.ebuild
+++ b/net-www/apache/apache-2.0.46.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.46.ebuild,v 1.2 2003/06/05 04:08:34 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.46.ebuild,v 1.3 2003/06/17 16:57:40 woodchip Exp $
inherit eutils
@@ -28,10 +28,15 @@ src_unpack() {
cd ${S} || die
epatch ${FILESDIR}/${P}-gentoo.diff
+ #avoid utf-8 charset problems
+ export LC_CTYPE=C
+
+ #The GNU people deprecated the -1 shortcut!
+ perl -pi -e 's|head -1|head -n 1|;' srclib/apr/build/buildcheck.sh
+
#give it the stamp
perl -pi -e 's|" PLATFORM "|Gentoo/Linux|;' server/core.c
- #fix perl with perl! and avoid utf-8 charset problems
- export LC_CTYPE=C
+ #fix perl with perl!
find -type f | xargs perl -pi -e \
"s|/usr/local/bin/perl|/usr/bin/perl|g; \
s|/usr/local/bin/perl5|/usr/bin/perl|g; \
@@ -42,7 +47,7 @@ src_unpack() {
#allow users to customize their data directory by setting the
#home directory of the 'apache' user elsewhere.
- local datadir=`grep ^apache: /etc/passwd | cut -d: -f6`
+ local datadir=`getent passwd apache | cut -d: -f6`
if [ -z "$datadir" ]
then
datadir="/home/httpd"
@@ -176,7 +181,7 @@ src_install () {
perl -pi -e "s/(APU_BUILD_DIR=).*/\1\"\"/" ${D}/usr/bin/apu-config
#protect the suexec binary
- local gid=`grep ^apache: /etc/group |cut -d: -f3`
+ local gid=`getent group apache |cut -d: -f3`
[ -z "${gid}" ] && gid=81
fowners root.${gid} /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
@@ -226,7 +231,7 @@ src_install () {
use ldap && doins ${FILESDIR}/2.0.40/46_mod_ldap.conf
#drop in a convenient link to the manual
- local datadir=`grep ^apache: /etc/passwd | cut -d: -f6`
+ local datadir=`getent passwd apache | cut -d: -f6`
[ -z "$datadir" ] && datadir="/home/httpd"
dosym /usr/share/doc/${PF}/manual ${datadir}/htdocs/manual