summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-01-05 00:07:45 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-01-05 00:07:45 +0000
commit579f40eddc4f825cfa3a19705d8d7bba174a14aa (patch)
treed61bcc09d071618d7bf9c61ccd7185b4fc50e14c /net-www
parentBumping to 1.18, fixes #165300, thanks to RB <aoz.syn@gmail.com> (diff)
downloadgentoo-2-579f40eddc4f825cfa3a19705d8d7bba174a14aa.tar.gz
gentoo-2-579f40eddc4f825cfa3a19705d8d7bba174a14aa.tar.bz2
gentoo-2-579f40eddc4f825cfa3a19705d8d7bba174a14aa.zip
new test snap, new utf8 initscript, cleanup, fixed src_uri to berlios mirror
(Portage version: 2.1.6.4/cvs/Linux 2.6.21-xen-main-r1 i686)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/xxv/ChangeLog11
-rw-r--r--net-www/xxv/files/xxv.utf871
-rw-r--r--net-www/xxv/xxv-1.0.1-r1.ebuild6
-rw-r--r--net-www/xxv/xxv-1.2-r1.ebuild6
-rw-r--r--net-www/xxv/xxv-1.2.1383.ebuild189
5 files changed, 243 insertions, 40 deletions
diff --git a/net-www/xxv/ChangeLog b/net-www/xxv/ChangeLog
index 61bad5730138..e5b596300da4 100644
--- a/net-www/xxv/ChangeLog
+++ b/net-www/xxv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/xxv
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/ChangeLog,v 1.12 2008/11/18 16:20:59 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/ChangeLog,v 1.13 2009/01/05 00:07:45 hd_brummy Exp $
+
+*xxv-1.2.1383 (05 Jan 2009)
+
+ 05 Jan 2009; Joerg Bornkessel <hd_brummy@gentoo.org> files/xxv.utf8,
+ xxv-1.0.1-r1.ebuild, xxv-1.2-r1.ebuild, +xxv-1.2.1383.ebuild:
+ new test snap, new utf8 initscript, cleanup, fixed src_uri to berlios
+ mirror
18 Nov 2008; Torsten Veller <tove@gentoo.org> xxv-1.0.1-r1.ebuild,
xxv-1.2-r1.ebuild, xxv-1.2.1308.ebuild, xxv-1.2.1315.ebuild,
diff --git a/net-www/xxv/files/xxv.utf8 b/net-www/xxv/files/xxv.utf8
index 5956251fa761..25806e37e569 100644
--- a/net-www/xxv/files/xxv.utf8
+++ b/net-www/xxv/files/xxv.utf8
@@ -1,21 +1,20 @@
#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/files/xxv.utf8,v 1.1 2008/03/11 21:48:01 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/files/xxv.utf8,v 1.2 2009/01/05 00:07:44 hd_brummy Exp $
-RUNAS_USER="vdr"
+RUNAS_USER="root"
+
+# Set Verbose Level 0 -> 5
+VERBOSE="1"
+
+#set -xv
# some fixed Path
CONFIGFILE="/etc/xxv/xxvd.cfg"
PIDFILE="/var/run/xxv/xxvd.pid"
XXV_BIN="/usr/bin/xxvd"
-LANGUAGE="de_DE.utf8"
-
-# Set Verbose Level 0 -> 5
-VERBOSE="3"
-
-#set -xv
depend() {
need vdr
@@ -24,54 +23,62 @@ depend() {
kill_vdradmin() {
- # Check at first, is VDR-Admin running
- # Stopping, while running on same ports
- # You can comment the next 4 Lines if you running VDR-Admind on different Ports
- if [ -f /var/run/vdradmind.pid ] ; then
+ # Check at first, is VDR-Admin running
+ # Stopping, while running on same ports
+ # You can comment the next 4 Lines if you running VDR-Admind on different Ports
+ if [ -f /var/run/vdradmind.pid ] ; then
ebegin "VDR-Admin will Stop at first now"
/etc/init.d/vdradmind stop
- fi
+ fi
}
xxv_kill_pid() {
- # After unclear stop, xxvd.pid will not removed, fixed with next line
- if [ -e ${PIDFILE} -a ! -L /var/lib/init.d/started/xxv ] ; then
- rm ${PIDFILE}
- killall xxvd 2>&1 > /dev/null
- fi
+ # After unclear stop, xxvd.pid will not removed, fixed with next line
+ if [ -e ${PIDFILE} -a ! -L /var/lib/init.d/started/xxv ] ; then
+ rm ${PIDFILE}
+ killall xxvd 2>&1 > /dev/null
+ fi
}
xxv_kill_initfile() {
- # After unclear stop, init file in /var/lib/init.d/started/ still not removed
- if [ -L /var/lib/init.d/started/xxv -a ! -e ${PIDFILE} ] ; then
- rm /var/lib/init.d/started/xxv
- /etc/init.d/xxv zap
- killall xxvd 2>&1 > /dev/null
- fi
+ # After unclear stop, init file in /var/lib/init.d/started/ still not removed
+ if [ -L /var/lib/init.d/started/xxv -a ! -e ${PIDFILE} ] ; then
+ rm /var/lib/init.d/started/xxv
+ /etc/init.d/xxv zap
+ killall xxvd 2>&1 > /dev/null
+ fi
+}
+
+set_utf8_charset() {
+ local capfile=/usr/share/vdr/capabilities.sh
+ [ -e "${capfile}" ] && . ${capfile}
+ if [ "${CAP_UTF8}" = "1" -o "${VDR_CAN_HANDLE_UTF8}" = "yes" ]; then
+ # do not clean out utf8
+ XXV_UTF8="-utf8"
+ fi
}
start() {
-
- kill_vdradmin
-
- # Finaly start XXV :)
- export LANG="${LANGUAGE}"
ebegin "Start xxv"
+# kill_vdradmin
+ set_utf8_charset
+
start-stop-daemon --nicelevel 15 --pidfile ${PIDFILE} --start -c ${RUNAS_USER} --exec ${XXV_BIN} -- \
- -configfile=${CONFIGFILE} -verbose=${VERBOSE} -pidfile=${PIDFILE} --utf8
+ ${XXV_UTF8} -configfile=${CONFIGFILE} -verbose=${VERBOSE} -pidfile=${PIDFILE}
eend $?
}
stop() {
- ebegin "Stopping xxv"
+ ebegin "Stopping xxvd"
start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
xxv_kill_pid
xxv_kill_initfile
+# killall xxvd 2>&1 > /dev/null
eend $?
}
diff --git a/net-www/xxv/xxv-1.0.1-r1.ebuild b/net-www/xxv/xxv-1.0.1-r1.ebuild
index e5b4bba10d4a..774301e48824 100644
--- a/net-www/xxv/xxv-1.0.1-r1.ebuild
+++ b/net-www/xxv/xxv-1.0.1-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/xxv-1.0.1-r1.ebuild,v 1.3 2008/11/18 16:20:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/xxv-1.0.1-r1.ebuild,v 1.4 2009/01/05 00:07:45 hd_brummy Exp $
inherit eutils
DESCRIPTION="WWW Admin for the VDR (Video Disk Recorder)"
HOMEPAGE="http://xxv.berlios.de/content/view/37/1/"
-SRC_URI="http://download.berlios.de/${PN}/${P}.tgz"
+SRC_URI="mirror://berlios/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-www/xxv/xxv-1.2-r1.ebuild b/net-www/xxv/xxv-1.2-r1.ebuild
index e299e927628b..11bb1108aa39 100644
--- a/net-www/xxv/xxv-1.2-r1.ebuild
+++ b/net-www/xxv/xxv-1.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/xxv-1.2-r1.ebuild,v 1.2 2008/11/18 16:20:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/xxv-1.2-r1.ebuild,v 1.3 2009/01/05 00:07:45 hd_brummy Exp $
inherit eutils
DESCRIPTION="WWW Admin for the VDR (Video Disk Recorder)"
HOMEPAGE="http://xxv.berlios.de/content/view/40/1/"
-SRC_URI="http://download.berlios.de/${PN}/${P}.tgz"
+SRC_URI="mirror://berlios/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-www/xxv/xxv-1.2.1383.ebuild b/net-www/xxv/xxv-1.2.1383.ebuild
new file mode 100644
index 000000000000..207eb6a5dcf1
--- /dev/null
+++ b/net-www/xxv/xxv-1.2.1383.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/xxv/xxv-1.2.1383.ebuild,v 1.1 2009/01/05 00:07:45 hd_brummy Exp $
+
+inherit eutils versionator
+
+MY_PV=$(get_version_component_range 3)
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="WWW Admin for the VDR (Video Disk Recorder)"
+HOMEPAGE="http://xxv.berlios.de/content/view/40/1/"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mplayer themes"
+
+RDEPEND=">=media-video/vdr-1.2.6
+ media-video/vdr2jpeg
+ media-fonts/ttf-bitstream-vera
+ dev-db/mysql
+ virtual/perl-CGI
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-MIME-Base64
+ virtual/perl-Time-HiRes
+ virtual/perl-Compress-Zlib
+ dev-perl/Config-Tiny
+ dev-perl/Digest-HMAC
+ dev-perl/Encode-Detect
+ dev-perl/GD
+ dev-perl/DateManip
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ dev-perl/Event
+ dev-perl/IO-Socket-INET6
+ dev-perl/JSON
+ dev-perl/Linux-Inotify2
+ dev-perl/Locale-gettext
+ dev-perl/MP3-Info
+ dev-perl/Net-Amazon
+ dev-perl/Net-Telnet
+ dev-perl/Net-XMPP
+ dev-perl/Proc-ProcessTable
+ dev-perl/TextToHTML
+ dev-perl/Template-Toolkit
+ dev-perl/SOAP-Lite
+ dev-perl/XML-RSS
+ themes? ( >=x11-themes/${PN}-skins-${PV} )"
+
+PDEPEND="mplayer? ( media-video/mplayer )"
+
+SHAREDIR="/usr/share/${PN}"
+LIBDIR="/usr/lib/${PN}"
+
+DB_VERS="31"
+
+db_update_check() {
+
+ DB_VERS_OLD="`cat /var/db/pkg/net-www/xxv-*/xxv-*.ebuild | grep DB_VERS | head -n 1 | cut -c10-11`"
+
+ if [ "${DB_VERS_OLD}" -lt "${DB_VERS}" ]; then
+ echo
+ elog "An update of XXV Database is needed !!!"
+ echo
+ elog "cd ${SHAREDIR}/contrib"
+ elog "run ./update-xxv -h for more info"
+ echo
+ else
+ elog "If this is a new install"
+ elog "You have to create an empty DB for XXV"
+ echo
+ elog "do this by:"
+ elog "cd ${SHAREDIR}/contrib"
+ eerror "read the README"
+ elog "edit create-database.sql and run"
+ elog "emerge --config ${PN}"
+ echo
+ elog "Set your own language in"
+ elog "${SHAREDIR}/locale"
+ echo
+ elog "For First Time Login in Browser use:"
+ elog "Pass:Login = xxv:xxv"
+ echo
+ eerror "edit /etc/xxv/xxvd.cfg !"
+ fi
+}
+
+pkg_setup() {
+
+ if ! built_with_use dev-perl/GD png gif ; then
+ echo
+ eerror "Please recompile dev-perl/GD with"
+ eerror "USE=\"png gif\""
+ die "dev-perl/GD need png and gif support"
+ fi
+
+ if ! has_version "net-www/${PN}"; then
+ echo
+ einfo "Before you install xxv at first time you should read"
+ einfo "http://www.vdr-wiki.de/wiki/index.php/Xxv German only available"
+ echo
+ fi
+
+ db_update_check
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "${S}"/bin/xxvd \
+ -e "s:debian:Gentoo:" \
+ -e "s:/var/log/xxvd.log:/var/log/xxv/xxvd.log:" \
+ -e "s:/var/run/xxvd.pid:/var/run/xxv/xxvd.pid:" \
+ -e "s:\$RealBin/../lib:${LIBDIR}:" \
+ -e "s:\$RealBin/../locale:${SHAREDIR}/locale:" \
+ -e "s:\$RealBin/../lib/XXV/MODULES:${LIBDIR}/XXV/MODULES:" \
+ -e "s:\$RealBin/../etc/xxvd.cfg:/etc/xxv/xxvd.cfg:" \
+ -e "s:\$RealBin/../doc:/usr/share/doc/${P}:" \
+ -e "s:HTMLDIR => \"\$RealBin/../:HTMLDIR => \"${SHAREDIR}/skins:" \
+ -e "s:\$RealBin/../share/vtx:${SHAREDIR}/vtx:" \
+ -e "s:\$RealBin/../lib/XXV/OUTPUT:${LIBDIR}/XXV/OUTPUT:" \
+ -e "s:\$RealBin/../share/news:${SHAREDIR}/news:" \
+ -e "s:\$RealBin/../contrib:${SHAREDIR}/contrib:" \
+ -e "s:\$RealBin/../share/fonts/:/usr/share/fonts/:"
+
+ sed -i "s:\$RealBin/../lib:${LIBDIR}:" ./locale/xgettext.pl
+}
+
+src_compile() {
+:
+}
+
+src_install() {
+
+ newinitd "${FILESDIR}"/xxv.utf8 xxv
+
+ dobin bin/xxvd
+
+ insinto /etc/"${PN}"
+ newins "${FILESDIR}"/xxvd-1.0.cfg xxvd.cfg
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/xxvd-logrotate xxvd
+
+ diropts -m755 -ovdr -gvdr
+ keepdir /var/cache/xxv
+ keepdir /var/run/xxv
+ keepdir /var/log/xxv
+
+ insinto "${LIBDIR}"
+ doins -r "${S}"/lib/*
+
+ insinto "${SHAREDIR}"
+ doins -r "${S}"/share/news
+
+ insinto "${SHAREDIR}"/locale
+ doins -r "${S}"/locale/*
+ fperms 0755 "${SHAREDIR}"/locale/xgettext.pl
+
+ insinto "${SHAREDIR}"/contrib
+ doins -r "${S}"/contrib/*
+ fperms 0755 "${SHAREDIR}"/contrib/update-xxv
+
+ insinto "${SHAREDIR}"/skins
+ doins -r "${S}"/{html,wml}
+ doins "${S}"/doc/docu.tmpl
+
+ cd "${S}"/doc
+ insinto /usr/share/doc/"${P}"
+ doins docu.tmpl CHANGELOG LIESMICH NEWS README TUTORIAL.txt.gz
+ fowners vdr:vdr /usr/share/doc/"${P}"
+
+ doman xxvd.1
+}
+
+pkg_config() {
+
+ cd "${ROOT}"/"${SHAREDIR}"
+ cat ./contrib/create-database.sql | mysql -u root -p
+}
+
+pkg_postrm() {
+
+ einfo "Cleanup for old "${P}" files"
+ rm -r /usr/share/doc/"${P}"
+}