summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-30 23:30:09 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-30 23:30:09 +0000
commit2272a3de8dafa2141c0d693868f68bad8a076dc5 (patch)
tree3046e506de436a091e3896dd7cf48d32c34dc68f /net-www
parentchanged the deps and masked (diff)
downloadgentoo-2-2272a3de8dafa2141c0d693868f68bad8a076dc5.tar.gz
gentoo-2-2272a3de8dafa2141c0d693868f68bad8a076dc5.tar.bz2
gentoo-2-2272a3de8dafa2141c0d693868f68bad8a076dc5.zip
New version
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/ChangeLog7
-rw-r--r--net-www/links/files/digest-links-2.1_pre71
-rw-r--r--net-www/links/links-2.1_pre7.ebuild107
3 files changed, 114 insertions, 1 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index e61cb216fab6..e86b07363944 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/links
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.20 2002/12/15 11:58:45 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.21 2003/01/30 23:30:09 foser Exp $
+
+*links-2.1_pre7 (30 Jan 2003)
+
+ 30 Jan 2003; foser <foser@gentoo.org> links-2.1_pre7.ebuild :
+ New version
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-www/links/files/digest-links-2.1_pre7 b/net-www/links/files/digest-links-2.1_pre7
new file mode 100644
index 000000000000..d7a58952bfe7
--- /dev/null
+++ b/net-www/links/files/digest-links-2.1_pre7
@@ -0,0 +1 @@
+MD5 73579a90ed96d43a5db053d67ddaf261 links-2.1pre7.tar.bz2 3533997
diff --git a/net-www/links/links-2.1_pre7.ebuild b/net-www/links/links-2.1_pre7.ebuild
new file mode 100644
index 000000000000..d6ae770e05c8
--- /dev/null
+++ b/net-www/links/links-2.1_pre7.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre7.ebuild,v 1.1 2003/01/30 23:30:09 foser Exp $
+
+IUSE="ssl java png X gpm tiff fbcon svga jpeg"
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ java? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 >=media-libs/libpng-1.2.1 )
+ X? ( virtual/x11 >=media-libs/libpng-1.2.1 )
+ fbcon? ( >=media-libs/libpng-1.2.1 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_compile (){
+
+ local myconf
+ myconf="--program-suffix=2"
+
+ use X \
+ && myconf="${myconf} --enable-graphics --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --with-libpng" \
+ || myconf="${myconf} --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --enable-graphics --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-graphics --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use java \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install (){
+ einstall
+
+ if [ ! -f /usr/bin/links ]
+ then
+ dosym links2 /usr/bin/links
+ fi
+
+ # Only install links icon if X driver was compiled in ...
+ use X && { insinto /usr/share/pixmaps ; doins graphics/links.xpm ; }
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}
+
+
+pkg_postinst() {
+
+ if use svga
+ then
+ einfo "You had the svga USE flag enabled, but for security reasons"
+ einfo "the links2 binary is NOT setuid by default. In order to"
+ einfo "enable links2 to work in SVGA, please change the permissions"
+ einfo "of /usr/bin/links2 to enable suid."
+ fi
+}