summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-11-23 16:58:23 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-11-23 16:58:23 +0000
commit4ea4946efd22d7154dcdad063f619f1fece1d3d4 (patch)
treea67d5d12493a576a8a108c7b42e0edee441b201d /net-www/zope
parentadd dep on >=automake-1.6.3 on ppc or kde 3.1, as reported by doctomoe. also ... (diff)
downloadgentoo-2-4ea4946efd22d7154dcdad063f619f1fece1d3d4.tar.gz
gentoo-2-4ea4946efd22d7154dcdad063f619f1fece1d3d4.tar.bz2
gentoo-2-4ea4946efd22d7154dcdad063f619f1fece1d3d4.zip
Updated version; thanks to Maurizio Disimino.
Diffstat (limited to 'net-www/zope')
-rw-r--r--net-www/zope/ChangeLog9
-rw-r--r--net-www/zope/files/digest-zope-2.6.0-r11
-rw-r--r--net-www/zope/zope-2.6.0-r1.ebuild66
-rw-r--r--net-www/zope/zope-2.6.0.ebuild8
4 files changed, 79 insertions, 5 deletions
diff --git a/net-www/zope/ChangeLog b/net-www/zope/ChangeLog
index c1d2a5ecef00..d09b89c30aaa 100644
--- a/net-www/zope/ChangeLog
+++ b/net-www/zope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/zope
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/zope/ChangeLog,v 1.4 2002/10/24 12:44:03 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/zope/ChangeLog,v 1.5 2002/11/23 16:58:23 g2boojum Exp $
+
+*zope-2.6.1 (23 Nov 2002)
+
+ 23 Nov 2002; Grant Goodyear <g2boojum@gentoo.org> zope-2.6.0-r1.ebuild :
+ Added ebuild from Bug #10758 (thanks to Maurizio Disimino!) which should
+ ensure that python 2.1.3* is used, the init script is now properly
+ located in /etc/init.d, and probably one or two other fixes.
*zope-2.6.0 (24 Oct 2002)
diff --git a/net-www/zope/files/digest-zope-2.6.0-r1 b/net-www/zope/files/digest-zope-2.6.0-r1
new file mode 100644
index 000000000000..c2e2d34bcace
--- /dev/null
+++ b/net-www/zope/files/digest-zope-2.6.0-r1
@@ -0,0 +1 @@
+MD5 a0bb91ca1df775aebfc8ff8c46afa3a9 Zope-2.6.0-src.tgz 2291282
diff --git a/net-www/zope/zope-2.6.0-r1.ebuild b/net-www/zope/zope-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..0c23885bf64f
--- /dev/null
+++ b/net-www/zope/zope-2.6.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/zope/zope-2.6.0-r1.ebuild,v 1.1 2002/11/23 16:58:23 g2boojum Exp $
+
+S="${WORKDIR}/Zope-${PV}-src"
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites."
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-src.tgz"
+LICENSE="ZPL"
+SLOT="0"
+
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ =dev-lang/python-2.1.3*"
+
+ZOPEDIR="${DESTTREE}/share/zope/${PV}/"
+
+src_compile() {
+ python2.1 wo_pcgi.py || die "Failed to compile."
+}
+
+src_install() {
+
+ dodoc LICENSE.txt README.txt
+ docinto doc ; dodoc doc/*.txt
+ docinto doc/PLATFORMS ; dodoc doc/PLATFORMS/*
+ docinto doc/changenotes ; dodoc doc/changenotes/*
+
+ # using '/etc/init.d/zope'
+ rm -Rf start stop LICENCE.txt doc/
+
+ # copy the remaining contents of ${S} into the ${D}.
+ dodir ${ZOPEDIR}
+ cp -a . ${D}${ZOPEDIR}
+
+ # Add a rc-script.
+ exeinto /etc/init.d ; newexe ${FILESDIR}/${PV}/zope.initd zope
+
+ # Add a env.d script.
+ insinto /etc/env.d ; doins ${FILESDIR}/${PV}/zope.envd
+
+ # Fill in an env.d variable.
+ sed -i -e "/ZOPE_HOME/ c\\ZOPE_HOME=${ZOPEDIR}\\" ${D}/etc/env.d/zope.envd
+
+ # Add a conf.d script.
+ dodir /etc/conf.d
+ echo -e "ZOPE_OPTS='-u root'\nZOPE_HOME=${ZOPEDIR}" > ${D}/etc/conf.d/zope
+
+ # Keep others from overwritting PID files
+ fperms o+t ${ZOPEDIR}var/
+
+ # Useful link
+ dosym /usr/share/doc/${P}/doc/ ${ZOPEDIR}doc
+}
+
+pkg_postinst() {
+ einfo "To get zope running you must execure the following:"
+ einfo "\tebuild /var/db/pkg/net-www/${PF}/${P}.ebuild config"
+}
+
+pkg_config() {
+ einfo ">>> Create inital user..."
+ python2.1 ${ROOT}${ZOPEDIR}zpasswd.py ${ROOT}${ZOPEDIR}inituser
+}
diff --git a/net-www/zope/zope-2.6.0.ebuild b/net-www/zope/zope-2.6.0.ebuild
index a89233809039..92e6458e0c8d 100644
--- a/net-www/zope/zope-2.6.0.ebuild
+++ b/net-www/zope/zope-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/zope/zope-2.6.0.ebuild,v 1.1 2002/10/24 12:44:03 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/zope/zope-2.6.0.ebuild,v 1.2 2002/11/23 16:58:23 g2boojum Exp $
S="${WORKDIR}/Zope-${PV}-src"
@@ -56,11 +56,11 @@ src_install() {
cp -a . ${D}${ZOPEDIR}
# Add a rc-script.
- into /etc/init.d
- doins ${FILESDIR}/${PV}/zope.initd
+ insinto /etc/init.d
+ newins ${FILESDIR}/${PV}/zope.initd zope
# Add a env.d script.
- into /etc/env.d
+ insinto /etc/env.d
doins ${FILESDIR}/${PV}/zope.envd
# Fill in an env.d variable.