summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-01-04 00:17:54 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-01-04 00:17:54 +0000
commitb3c5103e44f26db1bf4a6838847ea0358e01d8e0 (patch)
treedda0324f747b201eb9b8e021db912869115ca778 /net-www/nspluginwrapper
parentBlock older findutils to avoid having more people run into problems (#148570) (diff)
downloadgentoo-2-b3c5103e44f26db1bf4a6838847ea0358e01d8e0.tar.gz
gentoo-2-b3c5103e44f26db1bf4a6838847ea0358e01d8e0.tar.bz2
gentoo-2-b3c5103e44f26db1bf4a6838847ea0358e01d8e0.zip
Version bump, changed installation dir of plugins as per suggestion made by Christian Birchinger <joker@gentoo.org>, bug #159157. Clean out older version.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'net-www/nspluginwrapper')
-rw-r--r--net-www/nspluginwrapper/ChangeLog13
-rw-r--r--net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.23
-rw-r--r--net-www/nspluginwrapper/nspluginwrapper-0.9.91.2.ebuild68
3 files changed, 82 insertions, 2 deletions
diff --git a/net-www/nspluginwrapper/ChangeLog b/net-www/nspluginwrapper/ChangeLog
index a4ab3b945e7d..7a9c8fb665e2 100644
--- a/net-www/nspluginwrapper/ChangeLog
+++ b/net-www/nspluginwrapper/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/nspluginwrapper
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/ChangeLog,v 1.7 2006/11/22 15:58:08 chutzpah Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/ChangeLog,v 1.8 2007/01/04 00:17:53 chutzpah Exp $
+
+*nspluginwrapper-0.9.91.2 (04 Jan 2007)
+
+ 04 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
+ -files/nspluginwrapper-0.9.90.3-gentoo.patch,
+ -nspluginwrapper-0.9.90.3.ebuild, +nspluginwrapper-0.9.91.2.ebuild:
+ Version bump, changed installation dir of plugins as per suggestion made by
+ Christian Birchinger <joker@gentoo.org>, bug #159157. Clean out older
+ version.
22 Nov 2006; Patrick McLean <chutzpah@gentoo.org>
files/nspluginwrapper-0.9.90.4-gentoo.patch:
diff --git a/net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.2 b/net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.2
new file mode 100644
index 000000000000..ed6fc7c04071
--- /dev/null
+++ b/net-www/nspluginwrapper/files/digest-nspluginwrapper-0.9.91.2
@@ -0,0 +1,3 @@
+MD5 74e40fa501ded6f1670684b3e42464c7 nspluginwrapper-0.9.91.2.tar.bz2 256748
+RMD160 3745e772bcdf450dbcc6c98469615ccdea4cc7a5 nspluginwrapper-0.9.91.2.tar.bz2 256748
+SHA256 43899df6d305f48066044edaec8b1963f06ccd229327a0bd14840cf9c5c1ca62 nspluginwrapper-0.9.91.2.tar.bz2 256748
diff --git a/net-www/nspluginwrapper/nspluginwrapper-0.9.91.2.ebuild b/net-www/nspluginwrapper/nspluginwrapper-0.9.91.2.ebuild
new file mode 100644
index 000000000000..7cfc3093ebd2
--- /dev/null
+++ b/net-www/nspluginwrapper/nspluginwrapper-0.9.91.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/nspluginwrapper/nspluginwrapper-0.9.91.2.ebuild,v 1.1 2007/01/04 00:17:53 chutzpah Exp $
+
+inherit nsplugins flag-o-matic multilib
+
+DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
+HOMEPAGE="http://www.gibix.net/projects/nspluginwrapper/"
+SRC_URI="http://www.gibix.net/projects/nspluginwrapper/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-gtklibs
+ sys-apps/setarch"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# I don't know how to get rid of these textrels
+QA_TEXTRELS_amd64="usr/$(get_libdir)/nspluginwrapper/i386/npviewer.bin"
+
+src_compile() {
+ econf --with-biarch \
+ --with-lib32=$(ABI=x86 get_libdir) \
+ --with-lib64=$(get_libdir) \
+ --pkglibdir=/usr/$(get_libdir)/${PN} || die
+ emake || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" DONT_STRIP=yes install || die
+
+ inst_plugin /usr/$(get_libdir)/nspluginwrapper/x86_64/linux/npwrapper.so
+ dosym /usr/$(get_libdir)/nspluginwrapper/x86_64/linux/npconfig /usr/bin/nspluginwrapper
+
+ dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ einfo "Auto installing 32bit plugins..."
+ nspluginwrapper -a -i
+ einfo "Any 32bit plugins you currently have installed have now been"
+ einfo "configured to work in a 64bit browser. Any plugins you install in"
+ einfo "the future will first need to be setup with:"
+ einfo " \"nspluginwrapper -i <path-to-32bit-plugin>\""
+ einfo "before they will function in a 64bit browser"
+ einfo
+}
+
+# this is terribly ugly, but without a way to query portage as to whether
+# we are upgrading/reinstalling a package versus unmerging, I can't think of
+# a better way
+
+pkg_prerm() {
+ einfo "Removing wrapper plugins..."
+ nspluginwrapper -a -r
+}
+
+pkg_postrm() {
+ if [[ -x /usr/bin/nspluginwrapper ]]; then
+ einfo "Auto installing 32bit plugins..."
+ nspluginwrapper -a -i
+ fi
+}