summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-18 13:55:27 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-18 13:55:27 +0000
commitb56493409d868b0901475a64c8b41877bb2b7406 (patch)
tree93f319e730be7b9dd4bfea1f8287c9bfdd33712e /net-www/netscape-flash
parentadded libstdc++ from gcc2 (diff)
downloadgentoo-2-b56493409d868b0901475a64c8b41877bb2b7406.tar.gz
gentoo-2-b56493409d868b0901475a64c8b41877bb2b7406.tar.bz2
gentoo-2-b56493409d868b0901475a64c8b41877bb2b7406.zip
added lib-compat as a DEPEND -- needs testing
Diffstat (limited to 'net-www/netscape-flash')
-rw-r--r--net-www/netscape-flash/ChangeLog9
-rw-r--r--net-www/netscape-flash/files/digest-netscape-flash-6.0.69-r12
-rw-r--r--net-www/netscape-flash/netscape-flash-6.0.69-r1.ebuild44
3 files changed, 54 insertions, 1 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 14f66f3412c7..0655e434fb17 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.12 2002/12/16 10:56:05 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.13 2002/12/18 13:55:27 seemant Exp $
+
+*netscape-flash-6.0.68 (18 Dec 2002)
+
+ 18 Dec 2002; Seemant Kulleen <seemant@gentoo.org>
+ netscape-flash-6.0.69-r1.ebuild files/digest-netscape-flash-6.0.69-r1 :
+
+ Added lib-compat-1.1 (with gcc2's libstdc++) as a DEPEND
*netscape-flash-6.0.69 (16 Dec 2002)
diff --git a/net-www/netscape-flash/files/digest-netscape-flash-6.0.69-r1 b/net-www/netscape-flash/files/digest-netscape-flash-6.0.69-r1
new file mode 100644
index 000000000000..1ddb862da791
--- /dev/null
+++ b/net-www/netscape-flash/files/digest-netscape-flash-6.0.69-r1
@@ -0,0 +1,2 @@
+MD5 3c94ccbc2d4535ab78ad2c3eb1cd1777 netscape-flash-6.0.69.tar.gz 706066
+MD5 9bf9ef915513a4ec4c7a7de179ea4a37 gflashplayer-6.0.69.tar.gz 700843
diff --git a/net-www/netscape-flash/netscape-flash-6.0.69-r1.ebuild b/net-www/netscape-flash/netscape-flash-6.0.69-r1.ebuild
new file mode 100644
index 000000000000..6444caadf678
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-6.0.69-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-6.0.69-r1.ebuild,v 1.1 2002/12/18 13:55:27 seemant Exp $
+
+inherit nsplugins
+
+IUSE="gtk"
+
+S=${WORKDIR}/install_flash_player_6_linux
+DESCRIPTION="Macromedia Shockwave Flash Player"
+SRC_URI="mirror://macromedia/${P}.tar.gz
+ gtk? mirror://macromedia/gflashplayer-${PV}.tar.gz"
+HOMEPAGE="http://www.macromedia.com/"
+
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+LICENSE="Macromedia"
+
+DEPEND=">=sys-libs/lib-compat-1.1
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+
+ insinto /opt/netscape/plugins
+ doins flashplayer.xpt
+
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+ inst_plugin /opt/netscape/plugins/flashplayer.xpt
+
+ dodoc readme.txt
+ dohtml ReadMe.htm
+
+ # Optionally install the standalone GTK flash player
+ if use gtk
+ then
+ cd ${S}_sa
+ docinto gflashplayer
+ dodoc readme.txt
+ dohtml ReadMe.htm
+ dobin gflashplayer flashplayer-installer
+ fi
+}