summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-08-30 19:54:45 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-08-30 19:54:45 +0000
commitd2584842a66375fa6f1d87747919230f5b8ab282 (patch)
treec1bd18456ab24363b665c2803b6d95e676cda2f9 /net-www/mplayerplug-in
parentAdded ~ppc64; bug #145605 (diff)
downloadgentoo-2-d2584842a66375fa6f1d87747919230f5b8ab282.tar.gz
gentoo-2-d2584842a66375fa6f1d87747919230f5b8ab282.tar.bz2
gentoo-2-d2584842a66375fa6f1d87747919230f5b8ab282.zip
Cleaned up the ebuild as suggested by Todd Merrill.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'net-www/mplayerplug-in')
-rw-r--r--net-www/mplayerplug-in/ChangeLog5
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild45
2 files changed, 13 insertions, 37 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 035542b4c923..df031adf6516 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.69 2006/08/30 02:43:59 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.70 2006/08/30 19:54:45 josejx Exp $
+
+ 30 Aug 2006; Joseph Jezak <josejx@gentoo.org> mplayerplug-in-3.31.ebuild:
+ Cleaned up the ebuild as suggested by Todd Merrill.
30 Aug 2006; Joseph Jezak <josejx@gentoo.org> mplayerplug-in-3.31.ebuild:
Fixed bug #145517 (Thanks to Aaron Slunt for a fix).
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild
index 001d50c017e2..c28aa70c6cf1 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild,v 1.2 2006/08/30 02:43:59 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild,v 1.3 2006/08/30 19:54:45 josejx Exp $
inherit eutils multilib nsplugins
@@ -49,42 +49,15 @@ src_compile() {
fi
# Media Playback Support (bug #145517)
- ### Divx Enable/Disable
- if use divx; then
- myconf="${myconf} --enable-dvx"
- else
- myconf="${myconf} --disable-dvx"
- fi
-
- ### Google Media Enable/Disable
- if use gmedia; then
- myconf="${myconf} --enable-gmp"
- else
- myconf="${myconf} --disable-gmp"
- fi
-
- ### Real Media Enable/Disable
- if use real; then
- myconf="${myconf} --enable-rm"
- else
- myconf="${myconf} --disable-rm"
- fi
-
- ### Quicktime Enable/Disable
- if use quicktime; then
- myconf="${myconf} --enable-qt"
- else
- myconf="${myconf} --disable-qt"
- fi
-
- ### Windows Media Enable/Disable
- if use wmp; then
- myconf="${myconf} --enable-wmp"
- else
- myconf="${myconf} --disable-wmp"
- fi
+ econf \
+ $(myconf) \
+ $(use_enable divx dvx) \
+ $(use_enable gmedia gmp) \
+ $(use_enable real rm) \
+ $(use_enable quicktime qt) \
+ $(use_enable wmp) \
+ || die "econf failed"
- econf ${myconf} || die "econf failed"
emake || die "emake failed"
}