summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-12-30 16:20:27 +0000
committerChris White <chriswhite@gentoo.org>2004-12-30 16:20:27 +0000
commita538477712de4a3e3dd24d4aa46b255b2a5064d9 (patch)
treef134b9f4557630440633c5c2ff0dfb178227e739 /net-www/mozilla
parentremoved acl and bmp (diff)
downloadgentoo-2-a538477712de4a3e3dd24d4aa46b255b2a5064d9.tar.gz
gentoo-2-a538477712de4a3e3dd24d4aa46b255b2a5064d9.tar.bz2
gentoo-2-a538477712de4a3e3dd24d4aa46b255b2a5064d9.zip
Sizzle, bye bye stackgrowth bug.. hello +debug working :D.
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog6
-rw-r--r--net-www/mozilla/files/mozilla-1.7.5-stackgrowth.patch37
-rw-r--r--net-www/mozilla/mozilla-1.7.5.ebuild5
3 files changed, 46 insertions, 2 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 91f36e99b81a..0f40461560d7 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mozilla
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.218 2004/12/29 12:11:56 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.219 2004/12/30 16:20:27 chriswhite Exp $
+
+ 31 Dec 2004; Chris White <chriswhite@gentoo.org>
+ +files/mozilla-1.7.5-stackgrowth.patch, mozilla-1.7.5.ebuild:
+ Added an upstream stack growth patch. This fixes some debug weirdness.
29 Dec 2004; <SeJo@gentoo.org> mozilla-1.7.5.ebuild:
stable on ppc glsa: 68976
diff --git a/net-www/mozilla/files/mozilla-1.7.5-stackgrowth.patch b/net-www/mozilla/files/mozilla-1.7.5-stackgrowth.patch
new file mode 100644
index 000000000000..af226b28ed9c
--- /dev/null
+++ b/net-www/mozilla/files/mozilla-1.7.5-stackgrowth.patch
@@ -0,0 +1,37 @@
+--- js/src/jscpucfg.c 15 Nov 2003 00:10:56 -0000 3.21
++++ js/src/jscpucfg.c 22 Oct 2004 05:45:36 -0000
+@@ -153,19 +153,34 @@ static int Log2(unsigned int n)
+ */
+ static void BitsPerByte(void)
+ {
+ bpb = 8;
+ }
+
++#ifdef __GNUC__
++#if (__GNUC__ > 2)
++__attribute__((noinline))
++#endif
++static int StackGrowthDirection(int *dummy1addr)
++{
++ int *dummy2 = alloca (sizeof (int));
++
++ return (dummy2 < dummy1addr) ? -1 : 1;
++}
++
++#else /* __GNUC__ */
++
+ static int StackGrowthDirection(int *dummy1addr)
+ {
+ int dummy2;
+
+ return (&dummy2 < dummy1addr) ? -1 : 1;
+ }
+
++#endif /* __GNUC__ */
++
+ int main(int argc, char **argv)
+ {
+ int sizeof_char, sizeof_short, sizeof_int, sizeof_int64, sizeof_long,
+ sizeof_float, sizeof_double, sizeof_word, sizeof_dword;
+ int bits_per_int64_log2, align_of_short, align_of_int, align_of_long,
+ align_of_int64, align_of_float, align_of_double, align_of_pointer,
diff --git a/net-www/mozilla/mozilla-1.7.5.ebuild b/net-www/mozilla/mozilla-1.7.5.ebuild
index 6c41d78c11cc..0811e3771e14 100644
--- a/net-www/mozilla/mozilla-1.7.5.ebuild
+++ b/net-www/mozilla/mozilla-1.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7.5.ebuild,v 1.7 2004/12/29 12:11:56 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7.5.ebuild,v 1.8 2004/12/30 16:20:27 chriswhite Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozconfig makeedit
@@ -55,6 +55,9 @@ src_unpack() {
fi
fi
+ # Fix stack growth logic
+ epatch ${FILESDIR}/${P}-stackgrowth.patch
+
# Fix logic error when using RAW target
# <azarah@gentoo.org> (23 Feb 2003)
epatch ${FILESDIR}/1.3/${PN}-1.3-fix-RAW-target.patch