summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-04-09 23:57:52 +0000
committerDonny Davies <woodchip@gentoo.org>2002-04-09 23:57:52 +0000
commita15be1832af13f0e425c36a70fc460c0996c4145 (patch)
tree589c10049eeb0f8f4d9ab239df12245de2465726 /net-www/mod_throttle
parentrewritten apache package; see changelog (diff)
downloadgentoo-2-a15be1832af13f0e425c36a70fc460c0996c4145.tar.gz
gentoo-2-a15be1832af13f0e425c36a70fc460c0996c4145.tar.bz2
gentoo-2-a15be1832af13f0e425c36a70fc460c0996c4145.zip
add a healthy selection of third-party modules to go along with the great apache rewrite ;)
Diffstat (limited to 'net-www/mod_throttle')
-rw-r--r--net-www/mod_throttle/ChangeLog9
-rw-r--r--net-www/mod_throttle/files/digest-mod_throttle-3.1.21
-rw-r--r--net-www/mod_throttle/files/mod_throttle.conf21
-rw-r--r--net-www/mod_throttle/mod_throttle-3.1.2.ebuild44
4 files changed, 75 insertions, 0 deletions
diff --git a/net-www/mod_throttle/ChangeLog b/net-www/mod_throttle/ChangeLog
new file mode 100644
index 000000000000..0396d2caa0a6
--- /dev/null
+++ b/net-www/mod_throttle/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/mod_throttle
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_throttle/ChangeLog,v 1.1 2002/04/09 23:57:52 woodchip Exp $
+
+*mod_throttle-3.1.2 (9 Apr 2002)
+
+ 9 Apr 2002; Donny Davies <woodchip@gentoo.org> :
+
+ New package to go along with the rewritten apache ebuild.
diff --git a/net-www/mod_throttle/files/digest-mod_throttle-3.1.2 b/net-www/mod_throttle/files/digest-mod_throttle-3.1.2
new file mode 100644
index 000000000000..df3d69409322
--- /dev/null
+++ b/net-www/mod_throttle/files/digest-mod_throttle-3.1.2
@@ -0,0 +1 @@
+MD5 6edc45c3ea8a0855d4b0b14cf0f76404 mod_throttle312.tgz 41397
diff --git a/net-www/mod_throttle/files/mod_throttle.conf b/net-www/mod_throttle/files/mod_throttle.conf
new file mode 100644
index 000000000000..d9d33423098e
--- /dev/null
+++ b/net-www/mod_throttle/files/mod_throttle.conf
@@ -0,0 +1,21 @@
+# Place "ThrottleBps 0" in all your VirtualHost directives to monitor vhosts
+
+<IfModule mod_throttle.c>
+
+#ThrottleUser websiteusername speed 300 60 m
+#ThrottleSlack 300
+ThrottleIndicator yellow 75
+ThrottleMaxDelay 5
+ThrottleContentType text/html
+
+# Enable status display handler
+<Location /throttle>
+
+SetHandler throttle-info
+Order deny,allow
+Deny from all
+Allow from 127.0.0.1
+
+</Location>
+
+</IfModule>
diff --git a/net-www/mod_throttle/mod_throttle-3.1.2.ebuild b/net-www/mod_throttle/mod_throttle-3.1.2.ebuild
new file mode 100644
index 000000000000..1b103fc4ddc2
--- /dev/null
+++ b/net-www/mod_throttle/mod_throttle-3.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_throttle/mod_throttle-3.1.2.ebuild,v 1.1 2002/04/09 23:57:52 woodchip Exp $
+
+DESCRIPTION="Bandwidth and request throttling for Apache"
+HOMEPAGE="http://www.snert.com/Software/mod_throttle/"
+
+MY_V="`echo ${PV} | sed -e 's:\.::g'`"
+S=${WORKDIR}/${P}
+SRC_URI="http://www.snert.com/Software/${PN}/${PN}${MY_V}.tgz"
+
+DEPEND="virtual/glibc >=net-www/apache-1.3.24"
+
+src_compile() {
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe mod_throttle.so
+
+ dodoc CHANGES.txt LICENSE.txt
+ dohtml index.shtml
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_throttle.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_throttle.so mod_throttle.c throttle_module \
+ define=THROTTLE addconf=conf/addon-modules/mod_throttle.conf
+ :;
+}