summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-28 20:43:41 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-28 20:43:41 +0000
commit2716a0fa80df6033d10ea02cdf697c785f6e1296 (patch)
tree2dd3318a3f5a225ee94fecf5fc93660d49d137af /net-www/mod_protection
parentnew Apache2 mod (diff)
downloadgentoo-2-2716a0fa80df6033d10ea02cdf697c785f6e1296.tar.gz
gentoo-2-2716a0fa80df6033d10ea02cdf697c785f6e1296.tar.bz2
gentoo-2-2716a0fa80df6033d10ea02cdf697c785f6e1296.zip
new Apache2 mod
Diffstat (limited to 'net-www/mod_protection')
-rw-r--r--net-www/mod_protection/ChangeLog8
-rw-r--r--net-www/mod_protection/files/26_mod_protection.conf12
-rw-r--r--net-www/mod_protection/files/digest-mod_protection-0.0.21
-rw-r--r--net-www/mod_protection/files/mod_protection-0.0.2-register.patch19
-rw-r--r--net-www/mod_protection/files/mod_protection.rules13
-rw-r--r--net-www/mod_protection/mod_protection-0.0.2.ebuild42
6 files changed, 95 insertions, 0 deletions
diff --git a/net-www/mod_protection/ChangeLog b/net-www/mod_protection/ChangeLog
new file mode 100644
index 000000000000..a13ea682871d
--- /dev/null
+++ b/net-www/mod_protection/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_protection
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_protection/ChangeLog,v 1.1 2002/11/28 20:43:41 woodchip Exp $
+
+*mod_protection-0.0.2 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_protection/files/26_mod_protection.conf b/net-www/mod_protection/files/26_mod_protection.conf
new file mode 100644
index 000000000000..5a495ac19b44
--- /dev/null
+++ b/net-www/mod_protection/files/26_mod_protection.conf
@@ -0,0 +1,12 @@
+<IfDefine PROTECTION>
+ <IfModule !mod_protection.c>
+ LoadModule protection_module extramodules/mod_protection.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_protection.c>
+ BlockTime 0
+# Menace "/home/httpd/htdocs/index.html.ru.iso-ru"
+ WarnHost 192.168.2.23 60080
+ Include "conf/modules.d/mod_protection.rules"
+</IfModule>
diff --git a/net-www/mod_protection/files/digest-mod_protection-0.0.2 b/net-www/mod_protection/files/digest-mod_protection-0.0.2
new file mode 100644
index 000000000000..e97ec2ed7f60
--- /dev/null
+++ b/net-www/mod_protection/files/digest-mod_protection-0.0.2
@@ -0,0 +1 @@
+MD5 b141b73ae9697c79dc674f25ff6209a4 mod_protection2-0.0.2.tar.bz2 69323
diff --git a/net-www/mod_protection/files/mod_protection-0.0.2-register.patch b/net-www/mod_protection/files/mod_protection-0.0.2-register.patch
new file mode 100644
index 000000000000..351ffc135b8e
--- /dev/null
+++ b/net-www/mod_protection/files/mod_protection-0.0.2-register.patch
@@ -0,0 +1,19 @@
+--- mod_protection.c 2002-04-20 09:33:31.000000000 -0400
++++ mod_protection.c.oden 2002-11-05 09:35:46.000000000 -0500
+@@ -799,8 +799,16 @@
+ return DECLINED;
+ }
+
++static int protection_init_handler(apr_pool_t *p, apr_pool_t *plog,
++ apr_pool_t *ptemp, server_rec *s)
++{
++ ap_add_version_component(p, "mod_protection/0.0.2");
++ return OK;
++}
++
+ static void register_hooks(apr_pool_t *p)
+ {
++ ap_hook_post_config(protection_init_handler, NULL, NULL, APR_HOOK_MIDDLE);
+ ap_hook_translate_name(trans_protection,NULL,NULL,APR_HOOK_MIDDLE);
+ }
+
diff --git a/net-www/mod_protection/files/mod_protection.rules b/net-www/mod_protection/files/mod_protection.rules
new file mode 100644
index 000000000000..7b58f8678234
--- /dev/null
+++ b/net-www/mod_protection/files/mod_protection.rules
@@ -0,0 +1,13 @@
+###
+### mod_protection 0.0.2
+### rules of 20020313
+###
+
+UriAlert /hsx.cgi
+UriAlert /cfdocs
+UriAlert /s.cgi
+ArgAlertMatch /wsisa.dll/WService
+ArgAlertMatch ala
+PairAlertMatch /h.cgi astro
+PairAlertMatch /al.html ass
+UriAlertMatch passwd
diff --git a/net-www/mod_protection/mod_protection-0.0.2.ebuild b/net-www/mod_protection/mod_protection-0.0.2.ebuild
new file mode 100644
index 000000000000..199fbb954384
--- /dev/null
+++ b/net-www/mod_protection/mod_protection-0.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_protection/mod_protection-0.0.2.ebuild,v 1.1 2002/11/28 20:43:41 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="Apache2 DSO providing basic IDS functions"
+HOMEPAGE="http://www.twlc.net/"
+
+NEWP="${PN}2-${PV}"
+S=${WORKDIR}/${NEWP}
+SRC_URI="mirror://gentoo/${NEWP}.tar.bz2"
+DEPEND="=net-www/apache-2*"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die
+ epatch ${FILESDIR}/mod_protection-0.0.2-register.patch
+}
+
+src_compile() {
+ apxs2 -c ${PN}.c || die
+}
+
+src_install() {
+ local i=26_mod_protection.conf
+ local j=mod_protection.rules
+
+ exeinto /usr/lib/apache2-extramodules
+ doexe ${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/$i
+ insopts -m 0644 -o root -g root
+ doins $j
+
+ dodoc ${FILESDIR}/$i $j COPYING Changes INSTALL README \
+ THANX TODO USAGE
+ docinto example-client; dodoc example-client/*
+}