summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-02 02:14:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-02 02:14:59 +0000
commit0485e042ccabdd97d8b33aa075cfcde2dbf94c23 (patch)
tree11734cbc7950b8fe83aff1090b4b99b803b71794 /net-www/mod_auth_mysql
parentfix bug #11254 (diff)
downloadgentoo-2-0485e042ccabdd97d8b33aa075cfcde2dbf94c23.tar.gz
gentoo-2-0485e042ccabdd97d8b33aa075cfcde2dbf94c23.tar.bz2
gentoo-2-0485e042ccabdd97d8b33aa075cfcde2dbf94c23.zip
fix bug #11254
Diffstat (limited to 'net-www/mod_auth_mysql')
-rw-r--r--net-www/mod_auth_mysql/ChangeLog8
-rw-r--r--net-www/mod_auth_mysql/Manifest4
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r21
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild49
4 files changed, 59 insertions, 3 deletions
diff --git a/net-www/mod_auth_mysql/ChangeLog b/net-www/mod_auth_mysql/ChangeLog
index 399f86f6a427..6ec97592d7fb 100644
--- a/net-www/mod_auth_mysql/ChangeLog
+++ b/net-www/mod_auth_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_auth_mysql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.4 2003/09/08 17:09:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.5 2003/10/02 02:14:57 robbat2 Exp $
+
+*mod_auth_mysql-20030510-r2 (01 Oct 2003)
+
+ 01 Oct 2003; Robin H. Johnson <robbat2@gentoo.org>
+ mod_auth_mysql-20030510-r2.ebuild:
+ fix bug #11254
*mod_auth_mysql-20030510-r1 (08 Sep 2003)
diff --git a/net-www/mod_auth_mysql/Manifest b/net-www/mod_auth_mysql/Manifest
index 09f560836971..27c85c640b09 100644
--- a/net-www/mod_auth_mysql/Manifest
+++ b/net-www/mod_auth_mysql/Manifest
@@ -1,8 +1,8 @@
MD5 7558bd0cff76d9d99775340cfe8166ae mod_auth_mysql-20030510.ebuild 1091
MD5 f3f510bb20c8bbb803ae214e448f0c22 mod_auth_mysql-20030510-r1.ebuild 1349
MD5 09fb204c261078f0b369ae499b255582 mod_auth_mysql-1.11.ebuild 934
-MD5 757dfdacc7dd46d36df1a6e26dd7da1f mod_auth_mysql-20030510-r2.ebuild 1382
-MD5 118bbb8a87e0f2bbb7020be2b56ee245 ChangeLog 864
+MD5 6a5c868230d7142af31bbbbcc42f8987 mod_auth_mysql-20030510-r2.ebuild 1382
+MD5 12c445a8a1a12421367b7e42c4ddf7c6 ChangeLog 864
MD5 01cc878ba30a6e2ad327de787e21a999 files/12_mod_auth_mysql.conf 3571
MD5 3513e598048c0060eb3758c19c4e4c60 files/digest-mod_auth_mysql-1.11 77
MD5 a9f56734948e06d5ed5f4b7eea9f6cd5 files/digest-mod_auth_mysql-20030510-r1 61
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r2 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r2
new file mode 100644
index 000000000000..7acd1a88ef08
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r2
@@ -0,0 +1 @@
+MD5 b6646a117703b3704091e8f19f02e43e mod_auth_mysql.tgz 9953
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild
new file mode 100644
index 000000000000..6b955a41d756
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild,v 1.1 2003/10/02 02:14:57 robbat2 Exp $
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database"
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+
+S=${WORKDIR}/${PN}
+SRC_URI="mirror://sourceforge/modauthmysql/${PN}.tgz"
+DEPEND="dev-db/mysql
+ net-www/apache
+ apache2? ( >=net-www/apache-2* )"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE="apache2"
+SLOT="0"
+
+if use apache2 ; then
+ APXS="apxs2 -D APACHE2"
+ DESTDIR=/usr/lib/apache2-extramodules
+ CONFDIR=/etc/apache2/conf/modules.d
+else
+ APXS="apxs -D APACHE1"
+ DESTDIR=/usr/lib/apache-extramodules
+ CONFDIR=/etc/apache/conf/addon-modules
+fi
+
+src_compile() {
+ $APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
+}
+
+src_install() {
+ exeinto ${DESTDIR}
+ doexe .libs/${PN}.so
+ insinto ${CONFDIR}
+ doins ${FILESDIR}/12_mod_auth_mysql.conf
+ cat mod_auth_mysql.c | head -81 \
+ | cut -c 4- > mod_auth_mysql.txt
+ dodoc ${FILESDIR}/12_mod_auth_mysql.conf \
+ README mod_auth_mysql.txt
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache2 APACHE2_OPTS setting"
+ else
+ einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache APACHE_OPTS setting"
+ fi
+}