summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-08-11 23:06:54 +0000
committerNed Ludd <solar@gentoo.org>2003-08-11 23:06:54 +0000
commit8ce1dc3864a2a3997a604a819567fe708ee597cc (patch)
tree0fe76447a399131ec43957432151921457796988 /net-www/middleman
parentThe changes in this release are as follows: (diff)
downloadgentoo-2-8ce1dc3864a2a3997a604a819567fe708ee597cc.tar.gz
gentoo-2-8ce1dc3864a2a3997a604a819567fe708ee597cc.tar.bz2
gentoo-2-8ce1dc3864a2a3997a604a819567fe708ee597cc.zip
The changes in this release are as follows:
A journal is now kept of all changes made to the cache, eliminating the need to scan the directory structure on startup. Some issues with caching on non-Linux systems were fixed. A new option was added to indicate to Web sites that it's acceptable to compress the content, which is buffered and decompresssed if the client doesn't support it. The proxy can now serve it's own proxy.pac file to easily configure browsers.
Diffstat (limited to 'net-www/middleman')
-rw-r--r--net-www/middleman/ChangeLog7
-rw-r--r--net-www/middleman/Manifest4
-rw-r--r--net-www/middleman/files/digest-middleman-1.8.21
-rw-r--r--net-www/middleman/middleman-1.8.2.ebuild68
4 files changed, 77 insertions, 3 deletions
diff --git a/net-www/middleman/ChangeLog b/net-www/middleman/ChangeLog
index 2ec2e9a0aed8..f47217d4c032 100644
--- a/net-www/middleman/ChangeLog
+++ b/net-www/middleman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/middleman
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/ChangeLog,v 1.2 2003/07/26 05:28:17 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/ChangeLog,v 1.3 2003/08/11 23:06:48 solar Exp $
+
+*middleman-1.8.2 (11 Aug 2003)
+
+ 11 Aug 2003; <solar@gentoo.org> middleman-1.8.2.ebuild:
+ version bump
26 Jul 2003; <solar@gentoo.org> middleman-1.8.1.ebuild:
Added missing support for pam and zlib, next version will have better
diff --git a/net-www/middleman/Manifest b/net-www/middleman/Manifest
index 0233ebe4d1c0..90939bc68cca 100644
--- a/net-www/middleman/Manifest
+++ b/net-www/middleman/Manifest
@@ -1,7 +1,7 @@
-MD5 4abaf446087ca36e18f225c02876dc85 ChangeLog 569
+MD5 d087484e7aafbdef0cd006e1b34848e9 ChangeLog 675
MD5 b3089a22f33a39676bb267f8d3d59c07 metadata.xml 1012
MD5 657ccc7549f417d41d360182fa6d80c5 middleman-1.8.1.ebuild 1647
-MD5 657ccc7549f417d41d360182fa6d80c5 middleman-1.8.2.ebuild 1647
+MD5 5e5d7deae43e0c5925faba90320f0d1a middleman-1.8.2.ebuild 1647
MD5 f310f39bd53b2a586b1f6ae1755dd09c files/digest-middleman-1.8.1 67
MD5 118e1d1a342e3e7faeb0cf43391f6aea files/digest-middleman-1.8.2 67
MD5 5cca318658e1fe03d10adece2c8e4d42 files/conf.d/mman 108
diff --git a/net-www/middleman/files/digest-middleman-1.8.2 b/net-www/middleman/files/digest-middleman-1.8.2
new file mode 100644
index 000000000000..784d0dbed312
--- /dev/null
+++ b/net-www/middleman/files/digest-middleman-1.8.2
@@ -0,0 +1 @@
+MD5 eb85a9308a129ff190176a20dc652fe6 middleman-1.8.2.tar.gz 611153
diff --git a/net-www/middleman/middleman-1.8.2.ebuild b/net-www/middleman/middleman-1.8.2.ebuild
new file mode 100644
index 000000000000..cb343d0b317c
--- /dev/null
+++ b/net-www/middleman/middleman-1.8.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/middleman-1.8.2.ebuild,v 1.1 2003/08/11 23:06:48 solar Exp $
+
+inherit eutils
+
+DESCRIPTION="Advanced HTTP/1.1 proxy server with features designed to increase privacy and remove unwanted content"
+SRC_URI="mirror://sourceforge/middle-man/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/middle-man"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="${IUSE} pam zlib"
+
+S=${WORKDIR}/${PN}
+
+DEPEND="virtual/glibc
+ dev-libs/libpcre
+ pam? ( sys-libs/pam )
+ zlib? ( sys-libs/zlib )
+"
+
+src_unpack() {
+ unpack ${A}
+ [ -f ${FILESDIR}/${P}-gentoo.diff ] && epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ local myconf=""
+ MAKEOPTS="-j1"
+
+ cd ${S}
+ for opt in ${IUSE}; do
+ use ${opt} &&
+ myconf="${myconf} --enable-${opt}" ||
+ myconf="$myconf --disable-${opt}"
+ done
+
+ econf --sysconfdir=/etc/mman ${myconf} || die "econf failed: ${myconf}"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ mkdir -p ${D}/usr/share/man/man8/
+ einstall || die "einstall failed"
+
+ dodoc CHANGELOG COPYING
+ dohtml README.html
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d/mman mman
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d/mman mman
+}
+
+#pkg_preinst() {
+# enewgroup mman 8080
+# enewuser mman 8080
+#}
+
+pkg_postinst() {
+ #einfo "A mman user has been added to your system if one did not already exist"
+ einfo "-"
+ einfo "Note: init/conf scripts and a sample config has been provided for you."
+ einfo "They can be found at or in /etc/conf.d/mman /etc/init.d/mman /etc/mman/"
+}