summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-25 16:14:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-25 16:14:55 +0000
commitc77fa2ac37c1f56b61e0c28640a32f3d8085630c (patch)
tree73f4867fe87201b323ecceca336b4bffa8ffc97f /net-www/htdig
parentmask new libglade (diff)
downloadgentoo-2-c77fa2ac37c1f56b61e0c28640a32f3d8085630c.tar.gz
gentoo-2-c77fa2ac37c1f56b61e0c28640a32f3d8085630c.tar.bz2
gentoo-2-c77fa2ac37c1f56b61e0c28640a32f3d8085630c.zip
bug fixes
Diffstat (limited to 'net-www/htdig')
-rw-r--r--net-www/htdig/ChangeLog9
-rw-r--r--net-www/htdig/files/digest-htdig-3.1.6-r21
-rw-r--r--net-www/htdig/htdig-3.1.6-r2.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/net-www/htdig/ChangeLog b/net-www/htdig/ChangeLog
index 9cae6a5a053d..2516999f30e0 100644
--- a/net-www/htdig/ChangeLog
+++ b/net-www/htdig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/htdig
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/ChangeLog,v 1.5 2002/04/24 18:59:23 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/ChangeLog,v 1.6 2002/04/25 16:14:55 seemant Exp $
+
+*htdig-3.1.6-r2 (25 Apr 2002)
+
+ 25 Apr 2002; Seemant Kulleen <seemant@gentoo.org> htdig-3.1.6-r2.ebuild
+ files/digest-htdig-3.1.6-r2 :
+
+ More fixes from StuBear to place things in correct locations.
*htdig-3.1.6-r1 (22 Apr 2002)
diff --git a/net-www/htdig/files/digest-htdig-3.1.6-r2 b/net-www/htdig/files/digest-htdig-3.1.6-r2
new file mode 100644
index 000000000000..a44fa14c97b5
--- /dev/null
+++ b/net-www/htdig/files/digest-htdig-3.1.6-r2
@@ -0,0 +1 @@
+MD5 7a2f20d8d6149efd8d119bb2ebf55f23 htdig-3.1.6.tar.gz 2068675
diff --git a/net-www/htdig/htdig-3.1.6-r2.ebuild b/net-www/htdig/htdig-3.1.6-r2.ebuild
new file mode 100644
index 000000000000..a1312e8b95f6
--- /dev/null
+++ b/net-www/htdig/htdig-3.1.6-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.6-r2.ebuild,v 1.1 2002/04/25 16:14:55 seemant Exp ${PN}/${PN}-3.1.5-r2.ebuild,v 1.2 2002/03/15 12:10:18 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTTP/HTML indexing and searching system"
+SRC_URI="http://www.htdig.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.htdig.org"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ app-arch/unzip"
+
+src_compile() {
+
+cd ${S}
+ ./configure \
+ --prefix=/usr \
+ --with-config-dir=/etc/${PN} \
+ --with-cgi-bin-dir=/home/httpd/cgi-bin \
+ --with-common-dir=/usr/share/${PN} \
+ --with-database-dir=/var/${PN} \
+ --with-image-dir=/home/httpd/htdocs/${PN} \
+ --with-default-config-file=/etc/${PN}/${PN}.conf \
+ || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ CONFIG_DIR=${D}/etc/${PN} \
+ SEARCH_DIR=${D}/home/httpd/htdocs/${PN} \
+ CGIBIN_DIR=${D}/home/httpd/cgi-bin \
+ COMMON_DIR=${D}/usr/share/${PN} \
+ DATABASE_DIR=${D}/var/${PN} \
+ IMAGE_DIR=${D}/home/httpd/htdocs/${PN} \
+ DEFAULT_CONFIG_FILE=${D}/etc/${PN}/${PN}.conf \
+ exec_prefix=${D}/usr \
+ install || die
+
+ dodoc ChangeLog COPYING README
+ dohtml -r htdoc
+
+ insinto /etc/conf.d
+ doins installdir/htdig.conf
+
+ dosed /etc/htdig/htdig.conf
+ dosed /usr/bin/rundig
+}