summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-05-12 18:49:05 +0000
committerDean Bailey <alron@gentoo.org>2003-05-12 18:49:05 +0000
commitc1c0e31be70dde129a946ef3f065fb5946188820 (patch)
treef9e6d0cf3c83968ddf7c9cf53aba8fd2553324ff /net-www/horde
parentnoticed bug with permissions on /usr/include/packer.h, fixed. (diff)
downloadgentoo-2-c1c0e31be70dde129a946ef3f065fb5946188820.tar.gz
gentoo-2-c1c0e31be70dde129a946ef3f065fb5946188820.tar.bz2
gentoo-2-c1c0e31be70dde129a946ef3f065fb5946188820.zip
version bump of horde to 2.2.3 final.
Diffstat (limited to 'net-www/horde')
-rw-r--r--net-www/horde/ChangeLog6
-rw-r--r--net-www/horde/files/digest-horde-2.2.31
-rw-r--r--net-www/horde/horde-2.2.3.ebuild70
3 files changed, 76 insertions, 1 deletions
diff --git a/net-www/horde/ChangeLog b/net-www/horde/ChangeLog
index cb4de0e38580..a242a1bc5964 100644
--- a/net-www/horde/ChangeLog
+++ b/net-www/horde/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/horde
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.8 2003/04/10 22:19:00 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.9 2003/05/12 18:49:05 alron Exp $
+
+*horde-2.2.3 (12 May 2003)
+ 12 May 2003; Dean Bailey <alron@gentoo.org> horde-2.2.3 :
+ Version bump to 2.2.3 final. Has the vfs stuff so no patch is needed any more.
*horde-2.2.1-r2 (10 Apr 2003)
10 Apr 2003;Dean Bailey <alron@gentoo.org> horde-2.2.1-r2 :
diff --git a/net-www/horde/files/digest-horde-2.2.3 b/net-www/horde/files/digest-horde-2.2.3
new file mode 100644
index 000000000000..05036ff729e4
--- /dev/null
+++ b/net-www/horde/files/digest-horde-2.2.3
@@ -0,0 +1 @@
+MD5 27e5c190a6a22a6aa2201e6b714a653d horde-2.2.3.tar.gz 568496
diff --git a/net-www/horde/horde-2.2.3.ebuild b/net-www/horde/horde-2.2.3.ebuild
new file mode 100644
index 000000000000..254afb25b72e
--- /dev/null
+++ b/net-www/horde/horde-2.2.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/horde-2.2.3.ebuild,v 1.1 2003/05/12 18:49:05 alron Exp $
+
+DESCRIPTION="Horde Application Framework ${PV}"
+HOMEPAGE="http://www.horde.org"
+SRC_URI="ftp://ftp.horde.org/pub/horde/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+DEPEND=""
+RDEPEND=">=dev-php/mod_php-4.1.0
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=net-www/horde-pear-1.0.1.1"
+IUSE=""
+
+# We will use these to set the permissions properly
+HTTPD_USER="apache"
+HTTPD_GROUP=`grep $HTTPD_USER /etc/passwd |cut -d: -f4`
+
+# Allow users to move the default data directory by setting the
+# home directory of the 'apache' user elsewhere.
+HTTPD_ROOT=`grep $HTTPD_USER /etc/passwd | cut -d: -f6`/htdocs
+
+
+
+pkg_setup() {
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eewarn "HTTPD_ROOT is null!"
+ eewarn "You probably want to check /etc/passwd"
+ die "Need to have a place to put horde in"
+ fi
+ if [ -L ${HTTPD_ROOT}/horde ] ; then
+ ewarn "You need to unmerge your old Horde version first."
+ ewarn "Horde will be installed into ${HTTPD_ROOT}/horde"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ dodir ${HTTPD_ROOT}/horde
+ cp -r . ${D}/${HTTPD_ROOT}/horde
+# cp ${FILESDIR}/${PV}/vfs.sql ${D}/${HTTPD_ROOT}/horde/scripts/db
+ # protecting files
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/horde
+ find ${D}/${HTTPD_ROOT}/horde/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/ -type d -exec chmod 0750 {} \;
+ chmod 0000 ${D}/${HTTPD_ROOT}/horde/test.php
+}
+
+pkg_postinst() {
+ einfo "Horde requires PHP to have :"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php4/php.ini."
+ einfo ""
+ einfo "Please read ${HTTPD_ROOT}/horde/docs/INSTALL !"
+}
+
+