summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-08 21:50:17 +0000
committerDean Bailey <alron@gentoo.org>2003-04-08 21:50:17 +0000
commit4e2a2065fafb2c366b387ad6a8bfc796e3a1db00 (patch)
tree0cf7d7c4f6aa95313f32220c925209ec7848ce8c /net-www/horde
parentupdated (diff)
downloadgentoo-2-4e2a2065fafb2c366b387ad6a8bfc796e3a1db00.tar.gz
gentoo-2-4e2a2065fafb2c366b387ad6a8bfc796e3a1db00.tar.bz2
gentoo-2-4e2a2065fafb2c366b387ad6a8bfc796e3a1db00.zip
revision bump to fix annoying pear issue
Diffstat (limited to 'net-www/horde')
-rw-r--r--net-www/horde/ChangeLog7
-rw-r--r--net-www/horde/files/digest-horde-2.2.1-r11
-rw-r--r--net-www/horde/horde-2.2.1-r1.ebuild70
3 files changed, 77 insertions, 1 deletions
diff --git a/net-www/horde/ChangeLog b/net-www/horde/ChangeLog
index 3d6aa63223f9..b17a867ec672 100644
--- a/net-www/horde/ChangeLog
+++ b/net-www/horde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/horde
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.6 2003/02/12 08:47:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.7 2003/04/08 21:48:05 alron Exp $
+
+*horde-2.2.1-r1 (08 Apr 2003)
+ 08 Apr 2003l Dean Bailey <alron@gentoo.org> horde-2.2.1-r1 :
+ Fixed an issue where alot of the required pear files were missing or outdated.
+ Added dependancy on horde-pear.
*horde-2.2.1 (09 Feb 2003)
09 Feb 2003; Dean Bailey <alron@gentoo.org> horde-2.2.1 :
diff --git a/net-www/horde/files/digest-horde-2.2.1-r1 b/net-www/horde/files/digest-horde-2.2.1-r1
new file mode 100644
index 000000000000..d14f36b4d994
--- /dev/null
+++ b/net-www/horde/files/digest-horde-2.2.1-r1
@@ -0,0 +1 @@
+MD5 0a1e087f5017524a6b1b3d62204f49bb horde-2.2.1.tar.gz 537836
diff --git a/net-www/horde/horde-2.2.1-r1.ebuild b/net-www/horde/horde-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..82a17039fe86
--- /dev/null
+++ b/net-www/horde/horde-2.2.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/horde-2.2.1-r1.ebuild,v 1.1 2003/04/08 21:48:05 alron Exp $
+
+DESCRIPTION="Horde Application Framework ${PV}"
+HOMEPAGE="http://www.horde.org"
+SRC_URI="ftp://ftp.horde.org/pub/horde/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+DEPEND=""
+RDEPEND=">=dev-php/mod_php-4.1.0
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=net-www/horde-pear-1.0.1"
+IUSE=""
+
+# We will use these to set the permissions properly
+HTTPD_USER="apache"
+HTTPD_GROUP=`grep $HTTPD_USER /etc/passwd |cut -d: -f4`
+
+# Allow users to move the default data directory by setting the
+# home directory of the 'apache' user elsewhere.
+HTTPD_ROOT=`grep $HTTPD_USER /etc/passwd | cut -d: -f6`/htdocs
+
+
+
+pkg_setup() {
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eewarn "HTTPD_ROOT is null!"
+ eewarn "You probably want to check /etc/passwd"
+ die "Need to have a place to put horde in"
+ fi
+ if [ -L ${HTTPD_ROOT}/horde ] ; then
+ ewarn "You need to unmerge your old Horde version first."
+ ewarn "Horde will be installed into ${HTTPD_ROOT}/horde"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ dodir ${HTTPD_ROOT}/horde
+ cp -r . ${D}/${HTTPD_ROOT}/horde
+
+ # protecting files
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/horde
+ find ${D}/${HTTPD_ROOT}/horde/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/ -type d -exec chmod 0750 {} \;
+ chmod 0000 ${D}/${HTTPD_ROOT}/horde/test.php
+}
+
+pkg_postinst() {
+ einfo "Horde requires PHP to have :"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php4/php.ini."
+ einfo ""
+ einfo "Please read ${HTTPD_ROOT}/horde/docs/INSTALL !"
+}
+
+