summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-10 19:47:55 +0000
committerDean Bailey <alron@gentoo.org>2003-04-10 19:47:55 +0000
commit6c8d2bf27f9ab9baed3c4963d3ceacd1241db794 (patch)
tree9ba2b7d71ac05b2de7d676e65f0cea0b384bbbc8 /net-www/horde-kronolith
parentRemoved -fstack-protector from ALLOWED_FLAGS (diff)
downloadgentoo-2-6c8d2bf27f9ab9baed3c4963d3ceacd1241db794.tar.gz
gentoo-2-6c8d2bf27f9ab9baed3c4963d3ceacd1241db794.tar.bz2
gentoo-2-6c8d2bf27f9ab9baed3c4963d3ceacd1241db794.zip
Bump to 1.1_rc3 because of breaks in 1.0 due to changes in horde framework
Diffstat (limited to 'net-www/horde-kronolith')
-rw-r--r--net-www/horde-kronolith/ChangeLog7
-rw-r--r--net-www/horde-kronolith/files/digest-horde-kronolith-1.1_rc31
-rw-r--r--net-www/horde-kronolith/horde-kronolith-1.1_rc3.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/net-www/horde-kronolith/ChangeLog b/net-www/horde-kronolith/ChangeLog
index a77e3500aea6..68eb8f89a9be 100644
--- a/net-www/horde-kronolith/ChangeLog
+++ b/net-www/horde-kronolith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/horde-kronolith
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.3 2003/04/08 23:09:08 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.4 2003/04/10 19:47:55 alron Exp $
+
+*horde-kronolith-1.1_rc3 (10 Apr 2003)
+ 10 Apr 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.1_rc3 :
+ Version bump to rc3 to fix issue with brokeness due to updates in primary
+ horde framework.
*horde-kronolith-1.0-r1 (08 Apr 2003)
08 Apr 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.0-r1 :
diff --git a/net-www/horde-kronolith/files/digest-horde-kronolith-1.1_rc3 b/net-www/horde-kronolith/files/digest-horde-kronolith-1.1_rc3
new file mode 100644
index 000000000000..894868caa27a
--- /dev/null
+++ b/net-www/horde-kronolith/files/digest-horde-kronolith-1.1_rc3
@@ -0,0 +1 @@
+MD5 e7f80c6d8739c505c118d2c1be85418e kronolith-1.1-RC3.tar.gz 397875
diff --git a/net-www/horde-kronolith/horde-kronolith-1.1_rc3.ebuild b/net-www/horde-kronolith/horde-kronolith-1.1_rc3.ebuild
new file mode 100644
index 000000000000..747c14dbeaef
--- /dev/null
+++ b/net-www/horde-kronolith/horde-kronolith-1.1_rc3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/horde-kronolith-1.1_rc3.ebuild,v 1.1 2003/04/10 19:47:55 alron Exp $
+
+DESCRIPTION="Kronolith ${PV} is the Horde calendar application"
+HOMEPAGE="http://www.horde.org"
+P=kronolith-1.1-RC3
+SRC_URI="ftp://ftp.horde.org/pub/kronolith/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.1"
+IUSE=""
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/kronolith
+ cp -r . ${D}/${HTTPD_ROOT}/horde/kronolith
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/kronolith
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ einfo "Please read ${HTTPD_ROOT}/horde/kronolith/docs/INSTALL !"
+}