summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-02-03 22:46:55 +0000
committerDean Bailey <alron@gentoo.org>2003-02-03 22:46:55 +0000
commit3cfd5bcb5ceb67396518693d2352c2fceb8c6fc6 (patch)
tree0118a2b5836d577f3ef560aa04acaca5f369ab35 /net-www/horde-kronolith
parentAdded a mailman rc file as suggested by Norberto Bensa on bug #14465 (diff)
downloadgentoo-2-3cfd5bcb5ceb67396518693d2352c2fceb8c6fc6.tar.gz
gentoo-2-3cfd5bcb5ceb67396518693d2352c2fceb8c6fc6.tar.bz2
gentoo-2-3cfd5bcb5ceb67396518693d2352c2fceb8c6fc6.zip
added horde-kronolith into porage
Diffstat (limited to 'net-www/horde-kronolith')
-rw-r--r--net-www/horde-kronolith/ChangeLog7
-rw-r--r--net-www/horde-kronolith/files/digest-horde-kronolith-1.01
-rw-r--r--net-www/horde-kronolith/horde-kronolith-1.0.ebuild85
3 files changed, 93 insertions, 0 deletions
diff --git a/net-www/horde-kronolith/ChangeLog b/net-www/horde-kronolith/ChangeLog
new file mode 100644
index 000000000000..314c363b9bb8
--- /dev/null
+++ b/net-www/horde-kronolith/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-www/horde-kronolith
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.1 2003/02/03 22:46:55 alron Exp $
+
+*horde-kronolith-1.0 (03 Feb 2003)
+ 03 Feb 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.0 :
+ Initial import.
diff --git a/net-www/horde-kronolith/files/digest-horde-kronolith-1.0 b/net-www/horde-kronolith/files/digest-horde-kronolith-1.0
new file mode 100644
index 000000000000..963254cbe2fd
--- /dev/null
+++ b/net-www/horde-kronolith/files/digest-horde-kronolith-1.0
@@ -0,0 +1 @@
+MD5 ae94df3b0a44d7349b36e30997b3dfb4 kronolith-1.0.tar.gz 270604
diff --git a/net-www/horde-kronolith/horde-kronolith-1.0.ebuild b/net-www/horde-kronolith/horde-kronolith-1.0.ebuild
new file mode 100644
index 000000000000..dd8c23ad79db
--- /dev/null
+++ b/net-www/horde-kronolith/horde-kronolith-1.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/horde-kronolith-1.0.ebuild,v 1.1 2003/02/03 22:46:55 alron Exp $
+
+DESCRIPTION="Kronolith ${PV} is the Horde calendar application"
+HOMEPAGE="http://www.horde.org"
+P=kronolith-1.0
+SRC_URI="ftp://ftp.horde.org/pub/kronolith/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2"
+IUSE=""
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/kronolith
+ cp -r . ${D}/${HTTPD_ROOT}/horde/kronolith
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/kronolith
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ # add module in horde
+ sed -e "/^\/\/.*\(\$this->applications\['kronolith'\].*\)/ \
+ { : next ; N ; /\;/ { s/\/\///g ; b } ; b next }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+
+ einfo "Please read ${HTTPD_ROOT}/horde/kronolith/docs/INSTALL !"
+}
+
+pkg_prerm() {
+ find_http_root
+ # rm module from horde
+ sed -e "/\(\$this->applications\['kronolith'\].*\)/ \
+ { s/\(.*\)/\/\/\1/g; : suite ; N ; /\;/ { s/\n/\n\/\//g ; b } ; \
+ b suite }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+}