summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-02-23 12:38:46 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-02-23 12:38:46 +0000
commit61a52b8c1837c0b2f27f2d22d98731a13f69db57 (patch)
tree1a10dd1a5ee985634d6dde4a605c7689aceaf77e /net-www/gnash
parentmove variables into the right place, bug 168051 (diff)
downloadgentoo-2-61a52b8c1837c0b2f27f2d22d98731a13f69db57.tar.gz
gentoo-2-61a52b8c1837c0b2f27f2d22d98731a13f69db57.tar.bz2
gentoo-2-61a52b8c1837c0b2f27f2d22d98731a13f69db57.zip
Improve qt3 detection thanks to Sarath Menon <sarathmenon@gmail.com> in bug 168112
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-www/gnash')
-rw-r--r--net-www/gnash/ChangeLog6
-rw-r--r--net-www/gnash/gnash-0.7.2_p20099999.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index d7c9b62885fc..0ad0c05ca214 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.35 2007/02/05 13:24:47 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.36 2007/02/23 12:38:46 genstef Exp $
+
+ 23 Feb 2007; <genstef@gentoo.org> gnash-0.7.2_p20099999.ebuild:
+ Improve qt3 detection thanks to Sarath Menon <sarathmenon@gmail.com> in bug
+ 168112
05 Feb 2007; <genstef@gentoo.org> gnash-0.7.2.ebuild,
gnash-0.7.2_p20099999.ebuild:
diff --git a/net-www/gnash/gnash-0.7.2_p20099999.ebuild b/net-www/gnash/gnash-0.7.2_p20099999.ebuild
index 26603c7fa985..166a6319d03e 100644
--- a/net-www/gnash/gnash-0.7.2_p20099999.ebuild
+++ b/net-www/gnash/gnash-0.7.2_p20099999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2_p20099999.ebuild,v 1.6 2007/02/05 13:24:47 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2_p20099999.ebuild,v 1.7 2007/02/23 12:38:46 genstef Exp $
WANT_AUTOCONF=latest
-inherit nsplugins autotools cvs kde-functions
+inherit nsplugins autotools cvs kde-functions qt3 multilib
set-kdedir
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
@@ -97,12 +97,16 @@ src_compile() {
myconf="${myconf} --with-mp3-decoder=ffmpeg"
fi
+ if use kde; then
+ myconf="${myconf} --enable-klash --with-qt-incl=${QTDIR}/include
+ --with-qt-lib=${QTDIR}/$(get_libdir)"
+ fi
+
econf \
$(use_enable nsplugin plugin) \
$(use_enable xml) \
$(use_enable video_cards_i810 i810-lod-bias) \
--without-gcc-arch \
- $(use_enable kde klash) \
${myconf} || die "econf failed"
emake -j1 || die "emake failed"
}