summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-10-31 20:20:38 +0000
committerMichael Januszewski <spock@gentoo.org>2004-10-31 20:20:38 +0000
commit7178d8d6278867a780ffc8ae3e1d92d0a4da8a1c (patch)
treebe15821de4cec2142181241dc8f1783fbdc87c40 /net-www/elinks
parentstop using old WANT_AUTOTOOL_#_# syntax (Manifest recommit) (diff)
downloadgentoo-2-7178d8d6278867a780ffc8ae3e1d92d0a4da8a1c.tar.gz
gentoo-2-7178d8d6278867a780ffc8ae3e1d92d0a4da8a1c.tar.bz2
gentoo-2-7178d8d6278867a780ffc8ae3e1d92d0a4da8a1c.zip
Version bump - once again.
Diffstat (limited to 'net-www/elinks')
-rw-r--r--net-www/elinks/ChangeLog10
-rw-r--r--net-www/elinks/elinks-0.10_pre2.ebuild94
-rw-r--r--net-www/elinks/elinks-0.9.2.ebuild4
-rw-r--r--net-www/elinks/files/digest-elinks-0.10_pre22
4 files changed, 107 insertions, 3 deletions
diff --git a/net-www/elinks/ChangeLog b/net-www/elinks/ChangeLog
index 08e769f59edf..059c32cf7af3 100644
--- a/net-www/elinks/ChangeLog
+++ b/net-www/elinks/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-www/elinks
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/ChangeLog,v 1.36 2004/10/31 19:56:46 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/ChangeLog,v 1.37 2004/10/31 20:20:38 spock Exp $
+
+*elinks-0.10_pre2 (31 Oct 2004)
+
+ 31 Oct 2004; Michal Januszewski <spock@gentoo.org>
+ +elinks-0.10_pre2.ebuild, elinks-0.9.2.ebuild:
+ Added an ebuild for the current unstable version. Marked the current stable
+ version (0.9.2) stable on x86. There have been only minor changes since
+ _rc4, so it doesn't need a long testing period.
*elinks-0.9.2 (31 Oct 2004)
diff --git a/net-www/elinks/elinks-0.10_pre2.ebuild b/net-www/elinks/elinks-0.10_pre2.ebuild
new file mode 100644
index 000000000000..95f855a1b07b
--- /dev/null
+++ b/net-www/elinks/elinks-0.10_pre2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/elinks-0.10_pre2.ebuild,v 1.1 2004/10/31 20:20:38 spock Exp $
+
+IUSE="gpm zlib ssl ipv6 X lua guile"
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz"
+SRC_URI="http://elinks.or.cz/download/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~spock/portage/distfiles/elinks-0.9.1.conf.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
+
+DEPEND="virtual/libc
+ >=app-arch/bzip2-1.0.2*
+ >=dev-libs/expat-1.95.4*
+ >=sys-apps/portage-2.0.45-r3
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ X? ( virtual/x11 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ lua? ( >=dev-lang/lua-4* )
+ gpm? ( >=sys-libs/ncurses-5.2* >=sys-libs/gpm-1.20.0-r5 )
+ guile? ( >=dev-util/guile-1.6.4-r1 )"
+PROVIDE="virtual/textbrowser"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+
+ mv "${PN}-0.9.1.conf" "${PN}.conf"
+ sed -i \
+ -e 's:CONFIG_256_COLORS=.*:CONFIG_256_COLORS=yes:' \
+ -e 's:CONFIG_LEDS=.*:CONFIG_LEDS=yes:' \
+ -e 's:CONFIG_HTML_HIGHLIGHT=.*:CONFIG_HTML_HIGHLIGHT=yes:' \
+ ${S}/features.conf
+}
+
+src_compile() {
+ # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
+ # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
+ # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
+
+ econf --sysconfdir=/etc/elinks \
+ --enable-leds \
+ `use_with gpm` \
+ `use_with zlib` \
+ `use_with ssl openssl` \
+ `use_with X x` \
+ `use_enable ipv6` \
+ `use_with lua` \
+ `use_with guile` || die
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die
+
+ insopts -m 644 ; insinto /etc/elinks
+ doins ${WORKDIR}/elinks.conf
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ insinto /usr/share/doc/${PF}/contrib/lua ; doins contrib/lua/{*.lua,elinks-remote}
+ insinto /usr/share/doc/${PF}/contrib/conv ; doins contrib/conv/*.*
+ insinto /usr/share/doc/${PF}/contrib/guile ; doins contrib/guile/*.scm
+}
+
+pkg_postinst() {
+ einfo "This ebuild provides a default config for ELinks."
+ einfo "Please check /etc/elinks/elinks.conf"
+ einfo
+ einfo "You may want to convert your html.cfg and links.cfg of"
+ einfo "Links or older ELinks versions to the new ELinks elinks.conf"
+ einfo "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ einfo
+ einfo "Please have a look at /etc/elinks/keybind-full.sample and"
+ einfo "/etc/elinks/keybind.conf.sample for some bindings examples."
+ einfo
+ einfo "If you have compiled ELinks with Guile support, you will have to"
+ einfo "copy internal-hooks.scm and user-hooks.scm from"
+ einfo "/usr/share/doc/${PF}/contrib/guile/ to ~/.elinks/"
+ einfo
+ einfo "You will have to set your TERM variable to 'xterm-256color'"
+ einfo "to be able to use 256 colors in elinks."
+ echo
+}
diff --git a/net-www/elinks/elinks-0.9.2.ebuild b/net-www/elinks/elinks-0.9.2.ebuild
index c6a9bc27c78a..7c2ed65c236b 100644
--- a/net-www/elinks/elinks-0.9.2.ebuild
+++ b/net-www/elinks/elinks-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/elinks-0.9.2.ebuild,v 1.1 2004/10/31 19:56:46 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/elinks-0.9.2.ebuild,v 1.2 2004/10/31 20:20:38 spock Exp $
IUSE="gpm zlib ssl ipv6 X lua guile"
@@ -13,7 +13,7 @@ SRC_URI="http://elinks.or.cz/download/${MY_P}.tar.bz2
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~amd64 ~alpha"
DEPEND="virtual/libc
>=app-arch/bzip2-1.0.2*
diff --git a/net-www/elinks/files/digest-elinks-0.10_pre2 b/net-www/elinks/files/digest-elinks-0.10_pre2
new file mode 100644
index 000000000000..2c71da3fc6c3
--- /dev/null
+++ b/net-www/elinks/files/digest-elinks-0.10_pre2
@@ -0,0 +1,2 @@
+MD5 fef5cd85c75d4778fd848a6c3d01c8a0 elinks-0.10pre2.tar.bz2 2104768
+MD5 ea3df881970bfd6f7bbed3039c22e8a6 elinks-0.9.1.conf.bz2 5398