summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-14 09:45:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-14 09:45:57 +0000
commit86011ac37c98b1e424638ef7294940f2d6d030e8 (patch)
tree7a60ded748c4da191e0ebafd62c6a731bd08dada /net-www/dillo
parentcleaned up 5.33.0. This is really old now, and should probably disappear when... (diff)
downloadgentoo-2-86011ac37c98b1e424638ef7294940f2d6d030e8.tar.gz
gentoo-2-86011ac37c98b1e424638ef7294940f2d6d030e8.tar.bz2
gentoo-2-86011ac37c98b1e424638ef7294940f2d6d030e8.zip
alternate iconsets
Diffstat (limited to 'net-www/dillo')
-rw-r--r--net-www/dillo/ChangeLog5
-rw-r--r--net-www/dillo/dillo-0.7.1.2.ebuild99
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.1.21
3 files changed, 66 insertions, 39 deletions
diff --git a/net-www/dillo/ChangeLog b/net-www/dillo/ChangeLog
index c3679a6e21d5..a2ba9ea5b703 100644
--- a/net-www/dillo/ChangeLog
+++ b/net-www/dillo/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-www/dillo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.16 2003/03/14 05:39:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.17 2003/03/14 09:45:57 seemant Exp $
*dillo-0.7.1.2 (13 Mar 2003)
+ 14 Mar 2003; Seemant Kulleen <seemant@gentoo.org> dillo-0.7.1.2.ebuild:
+ added support for alternate iconsets
+
13 Mar 2003; Seemant Kulleen <seemant@gentoo.org> dillo-0.6.6-r2.ebuild,
dillo-0.6.6-r2.ebuild, dillo-0.7.1.2.ebuild:
version bump to newest bugfix release
diff --git a/net-www/dillo/dillo-0.7.1.2.ebuild b/net-www/dillo/dillo-0.7.1.2.ebuild
index e1a8d0eb5525..2e86b77e63ee 100644
--- a/net-www/dillo/dillo-0.7.1.2.ebuild
+++ b/net-www/dillo/dillo-0.7.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.1.2.ebuild,v 1.1 2003/03/14 05:39:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.1.2.ebuild,v 1.2 2003/03/14 09:45:57 seemant Exp $
inherit flag-o-matic
@@ -11,8 +11,8 @@ S2=${WORKDIR}/gentoo-dillo-extras-patch
DESCRIPTION="Lean GTK+-based web browser"
HOMEPAGE="http://dillo.auriga.wearlab.de/"
-SRC_URI="http://dillo.auriga.wearlab.de/download/${P}.tar.gz"
-# mirror://gentoo/gentoo-dillo-extras-patch.tar.bz2"
+SRC_URI="http://dillo.auriga.wearlab.de/download/${P}.tar.gz
+ mirror://gentoo/dillo-gentoo-extras-patch.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
@@ -25,25 +25,40 @@ DEPEND="=x11-libs/gtk+-1.2*
>=sys-libs/zlib-1.1.3
>=media-libs/libpng-1.2.1"
-#
-# The custom icons seem to break compilation, so we'll need to wait
-# for a new release
-
-#src_unpack() {
-# unpack ${A}
-# cd ${S}
-#
-# if use kde
-# then
-# cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
-# elif use gnome
-# then
-# cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
-# elif use mozilla
-# then
-# cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
-# fi
-#}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ ebegin "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ ebegin "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ ebegin "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ ebegin "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ ebegin "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ eend 0
+ else
+ ebegin "Using default Dillo icon set"
+ eend 0
+ fi
+}
src_compile() {
econf `use_enable ipv6` || die
@@ -58,19 +73,27 @@ src_install() {
dodoc doc/*.txt doc/README
}
-#pkg_postinst() {
-# einfo "This ebuild for dillo comes with different toolbar icons"
-# einfo "If you want mozilla style icons then try"
-# einfo " USE=\"-kde -gnome mozilla\" emerge dillo"
-# einfo
-# einfo "If you prefer konqueror style icons then try"
-# einfo " USE=\"-mozilla -gnome kde\" emerge dillo"
-# einfo
-# einfo "If you prefer ximian gnome style icons then try"
-# einfo " USE=\"-mozilla -kde gnome\" emerge dillo"
-# einfo
-# einfo "Otherwise, if you want the default icon set, then do"
-# einfo " USE=\"-mozilla -kde -gnome\" emerge dillo"
-# einfo
-# einfo "Do not worry, no extra dependencies will be pulled in"
-#}
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/net-www/dillo/files/digest-dillo-0.7.1.2 b/net-www/dillo/files/digest-dillo-0.7.1.2
index a2dfe6799d5a..87cfa21696d4 100644
--- a/net-www/dillo/files/digest-dillo-0.7.1.2
+++ b/net-www/dillo/files/digest-dillo-0.7.1.2
@@ -1 +1,2 @@
MD5 b6b340d30657e51a48dc32f926be45c0 dillo-0.7.1.2.tar.gz 365171
+MD5 e803699d5472790046837e8d33b3db39 dillo-gentoo-extras-patch.tar.bz2 26644