summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-04 00:23:25 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-04 00:23:25 +0000
commit8d23fc5c6d99276d6c27311d989c3fd9d26b8a47 (patch)
tree306dd7f7481fdc6093652328cb2825670613864d /net-www/cocoon
parentadded libieee1284 in DEPEND (diff)
downloadgentoo-2-8d23fc5c6d99276d6c27311d989c3fd9d26b8a47.tar.gz
gentoo-2-8d23fc5c6d99276d6c27311d989c3fd9d26b8a47.tar.bz2
gentoo-2-8d23fc5c6d99276d6c27311d989c3fd9d26b8a47.zip
Fixes #4007.
Diffstat (limited to 'net-www/cocoon')
-rw-r--r--net-www/cocoon/ChangeLog12
-rw-r--r--net-www/cocoon/cocoon-2.0.2.ebuild75
-rw-r--r--net-www/cocoon/files/cocoon-2.0.2.patch36
-rw-r--r--net-www/cocoon/files/digest-cocoon-2.0.21
4 files changed, 123 insertions, 1 deletions
diff --git a/net-www/cocoon/ChangeLog b/net-www/cocoon/ChangeLog
index c7240399a06c..129a0c48e877 100644
--- a/net-www/cocoon/ChangeLog
+++ b/net-www/cocoon/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-www/cocoon
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/cocoon/ChangeLog,v 1.1 2002/02/01 21:53:36 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/cocoon/ChangeLog,v 1.2 2002/07/04 00:23:25 karltk Exp $
+
+*cocoon-2.0.2 (25 Jun 2002)
+
+ 25 Jun 2002; Sean E. Russell <ser@germane-software.com> ChangeLog files/cocoon-2.0.2.patch files/digest-cocoon-2.0.2 cocoon-2.0.2.ebuild
+
+ Upstream upgrade. Added a patch to make cocoon compile with JDK1.4 (WRT
+ JDBC3). The ebuild has temporary hacks to install PHP and JFOR support;
+ this will be replaced when PHP and JFOR Portage packages are available.
+ Also, JNDI support is enabled if JNDI is available. This ebuild works with
+ both JDK1.4 and 1.3. Tom von Schwerdtner contributed to this ebuild.
*cocoon-1.8.2 (1 Feb 2002)
diff --git a/net-www/cocoon/cocoon-2.0.2.ebuild b/net-www/cocoon/cocoon-2.0.2.ebuild
new file mode 100644
index 000000000000..5bd5f4d4b311
--- /dev/null
+++ b/net-www/cocoon/cocoon-2.0.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/cocoon/cocoon-2.0.2.ebuild,v 1.1 2002/07/04 00:23:25 karltk Exp $
+
+A=cocoon-${PV}-src.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Web Publishing Framework for Apache"
+SRC_URI="http://xml.apache.org/cocoon/dist/${A}"
+HOMEPAGE="http://xml.apache.org/cocoon/"
+
+# FIXME: tomcat 4.0.x, x != 3 is okay
+DEPEND=">=virtual/jdk-1.3
+ >=net-www/tomcat-4.0.4
+ jikes? ( >=dev-java/jikes-1.15 )
+ "
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ echo -e `pwd`
+ echo -e 'Patching Cocoon to fix JDBC3 filter bug'
+ patch -p0 < ${FILESDIR}/${P}.patch || die
+
+ # FIXME: We should rather depend on packages for JFOR
+
+ # JFOR is required for the optional fo2rtf serializer.
+ # Get the JFOR package from http://www.jfor.org/ and place the jar in ${DISTDIR}
+ JFOR_JAR="jfor.jar"
+ JFOR_HOME="http://www.jfor.org/"
+ if [ ! -f ${DISTDIR}/${JFOR_JAR} ]; then
+ einfo "Download ${JFOR_JAR} from ${JFOR_HOME} and place it in ${DISTDIR} for optional fo2rtf support"
+ else
+ cp ${DISTDIR}/${JFOR_JAR} ${S}/lib/optional/
+ fi
+
+ # FIXME: We should rather depend on packages for PHP
+
+ # PHP is required for the optional php generator.
+ # Get the PHP servlet (phpsrvlt.jar) from http://www.php.net/ and place the jar in ${DISTDIR}
+ PHP_JAR="phpsrvlt.jar"
+ PHP_HOME="http://www.php.net/"
+ if [ ! -f ${DISTDIR}/${PHP_JAR} ]; then
+ einfo "Download ${PHP_JAR} from ${PHP_HOME} and place it in ${DISTDIR} for optional PHP support"
+ else
+ cp ${DISTDIR}/${PHP_JAR} ${S}/lib/optional/
+ fi
+}
+
+src_compile() {
+ local myconf
+ use jikes && myconf="-Dbuild.compiler=jikes"
+
+ sh build.sh \
+ ${myconf} \
+ -Dinclude.webapp.libs=yes \
+ -Dinstall.war=$CATALINA_HOME/webapps \
+ webapp \
+ || die
+}
+
+src_install() {
+ dodir ${CATALINA_HOME}/webapps
+ insinto ${CATALINA_HOME}/webapps
+ doins ${S}/build/cocoon/cocoon.war
+
+ dodoc CREDITS INSTALL KEYS README
+ dodoc changes.xml announcement.xml todo.xml
+
+ dohtml -r docs/*
+}
+
+pkg_postinst() {
+ echo -e "\e[32;01m You must restart tomcat to have access to Cocoon. \033[0m"
+}
diff --git a/net-www/cocoon/files/cocoon-2.0.2.patch b/net-www/cocoon/files/cocoon-2.0.2.patch
new file mode 100644
index 000000000000..26eb109388c1
--- /dev/null
+++ b/net-www/cocoon/files/cocoon-2.0.2.patch
@@ -0,0 +1,36 @@
+*** src/java/org/apache/cocoon/components/language/markup/xsp/EsqlConnection.java Mon Mar 25 23:27:25 2002
+--- src/java/org/apache/cocoon/components/language/markup/xsp/EsqlConnection.java_NEW Tue Jun 25 11:40:24 2002
+***************
+*** 233,239 ****
+ return(connection.prepareCall(s,i1,i2));
+ }
+
+! /*
+ public void setHoldability(int holdability)
+ throws SQLException
+ {
+--- 233,239 ----
+ return(connection.prepareCall(s,i1,i2));
+ }
+
+! @JDBC3_START@
+ public void setHoldability(int holdability)
+ throws SQLException
+ {
+***************
+*** 316,322 ****
+ {
+ return prepareStatement(sql, columnNames);
+ }
+! */
+
+ }
+
+--- 316,322 ----
+ {
+ return prepareStatement(sql, columnNames);
+ }
+! @JDBC3_END@
+
+ }
+
diff --git a/net-www/cocoon/files/digest-cocoon-2.0.2 b/net-www/cocoon/files/digest-cocoon-2.0.2
new file mode 100644
index 000000000000..3503db120490
--- /dev/null
+++ b/net-www/cocoon/files/digest-cocoon-2.0.2
@@ -0,0 +1 @@
+MD5 1be1992d0440294bec24e9ed35719bbd cocoon-2.0.2-src.tar.gz 18016220