summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-01-25 17:09:11 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-01-25 17:09:11 +0000
commitadd413030ae342c32d2b216e425b5a9f774d2f2c (patch)
treed70766677523f6566444621be228b07902240cd9 /net-www/boa
parentk3studio, initial ebuild (diff)
downloadgentoo-2-add413030ae342c32d2b216e425b5a9f774d2f2c.tar.gz
gentoo-2-add413030ae342c32d2b216e425b5a9f774d2f2c.tar.bz2
gentoo-2-add413030ae342c32d2b216e425b5a9f774d2f2c.zip
Latest version.
Diffstat (limited to 'net-www/boa')
-rw-r--r--net-www/boa/boa-0.94.12_pre3.ebuild91
-rw-r--r--net-www/boa/files/digest-boa-0.94.12_pre21
-rw-r--r--net-www/boa/files/digest-boa-0.94.12_pre31
3 files changed, 93 insertions, 0 deletions
diff --git a/net-www/boa/boa-0.94.12_pre3.ebuild b/net-www/boa/boa-0.94.12_pre3.ebuild
new file mode 100644
index 000000000000..306712a072e4
--- /dev/null
+++ b/net-www/boa/boa-0.94.12_pre3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jon Nelson <jnelson@boa.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+#Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}
+P0=boa-0.94.12pre3
+S=${WORKDIR}/${P0}
+
+#Short one-line description
+DESCRIPTION="Boa - A very small and very fast http daemon."
+
+#Point to any required sources; these will be automatically downloaded
+# by Portage
+SRC_URI="http://www.boa.org/${P0}.tar.gz"
+
+#Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://www.boa.org/"
+
+#build-time dependencies
+DEPEND="virtual/glibc
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/texinfo
+ tex? ( app-text/tetex )"
+
+#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd src
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ #Note the use of --infodir and --mandir, above. This is to make
+ # this package FHS 2.2-compliant
+ #(/usr/share is used for info and man now).
+
+ emake || die
+ cd ../docs
+ make boa.html boa.info || die
+ echo "`use tex`"
+ if [ ! -z "`use tex`" ]; then
+ make boa.dvi || die
+ fi
+}
+
+src_install () {
+ # make prefix=${D}/usr install
+ dosbin src/boa || die
+ doman docs/boa.8 || die
+ dodoc docs/boa.html || die
+ dodoc docs/boa_banner.png || die
+ doinfo docs/boa.info || die
+ if [ ! -z "`use tex`" ]; then
+ dodoc docs/boa.dvi || die
+ fi
+
+ dodir /var/log/boa || die
+ dodir /home/httpd/html || die
+ dodir /home/httpd/cgi-bin || die
+
+ exeinto /usr/lib/boa
+ doexe src/boa_indexer || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/boa.rc6 boa || die
+
+ insinto /etc/boa
+ insopts -m700
+ insopts -m600
+ doins ${FILESDIR}/boa.conf || die
+ doins ${FILESDIR}/mime.types || die
+
+ # make DESTDIR=${D} install || die
+}
+
+pkg_prerm() {
+
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/boa ] ; then
+ /etc/init.d/boa stop
+ fi
+ return # dont fail
+}
+
+pkg_preinst() {
+
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/boa ] ; then
+ /etc/init.d/boa stop
+ fi
+ return # dont fail
+}
diff --git a/net-www/boa/files/digest-boa-0.94.12_pre2 b/net-www/boa/files/digest-boa-0.94.12_pre2
new file mode 100644
index 000000000000..332ebe5454aa
--- /dev/null
+++ b/net-www/boa/files/digest-boa-0.94.12_pre2
@@ -0,0 +1 @@
+MD5 1fd2b292ebb43544c706bbdda7411989 boa-0.94.12pre2.tar.gz 131072
diff --git a/net-www/boa/files/digest-boa-0.94.12_pre3 b/net-www/boa/files/digest-boa-0.94.12_pre3
new file mode 100644
index 000000000000..7af5672e7798
--- /dev/null
+++ b/net-www/boa/files/digest-boa-0.94.12_pre3
@@ -0,0 +1 @@
+MD5 928b9541f95cba70046bf2824fb6ccfb boa-0.94.12pre3.tar.gz 131072