summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-08-16 17:09:20 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-08-16 17:09:20 +0000
commitfec7f2b770ff0f25f67909790bfea074a7bc9065 (patch)
tree637b19d53217693c76f64ea1430acc507e883a41 /net-www/apache
parentavoid pre-stripping files - patch from Tristan Heaven via bug #137834 (diff)
downloadgentoo-2-fec7f2b770ff0f25f67909790bfea074a7bc9065.tar.gz
gentoo-2-fec7f2b770ff0f25f67909790bfea074a7bc9065.tar.bz2
gentoo-2-fec7f2b770ff0f25f67909790bfea074a7bc9065.zip
Actually create /var/www/localhost before trying to put stuff in it.
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/ChangeLog6
-rw-r--r--net-www/apache/apache-2.2.3.ebuild4
2 files changed, 8 insertions, 2 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index a8c2621428a3..48cfb9a427c1 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/apache
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.492 2006/07/30 05:56:28 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.493 2006/08/16 17:09:20 vericgar Exp $
+
+ 02 Aug 2006; Michael Stewart <vericgar@gentoo.org> apache-2.2.3.ebuild:
+ Actually create /var/www/localhost before trying to put stuff in it. Thanks
+ to Conrad Kostecki for the report
*apache-2.2.3 (30 Jul 2006)
diff --git a/net-www/apache/apache-2.2.3.ebuild b/net-www/apache/apache-2.2.3.ebuild
index b37446e1cd14..3782ca9c3fd3 100644
--- a/net-www/apache/apache-2.2.3.ebuild
+++ b/net-www/apache/apache-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.3.ebuild,v 1.1 2006/07/30 05:56:28 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.3.ebuild,v 1.2 2006/08/16 17:09:20 vericgar Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -387,6 +387,7 @@ pkg_postinst() {
einfo "emerge --config =${PF}"
else
einfo "Installing default webroot to ${ROOT}/var/www/localhost"
+ mkdir -p ${ROOT}/var/www/localhost
cp -r ${ROOT}/usr/share/doc/${PF}/webroot/* ${ROOT}/var/www/localhost
chown -R apache: ${ROOT}/var/www/localhost
fi
@@ -424,6 +425,7 @@ pkg_postinst() {
pkg_config() {
einfo "Installing default webroot to ${ROOT}/var/www/localhost"
+ mkdir -p ${ROOT}/var/www/localhost
cp -r ${ROOT}/usr/share/doc/${PF}/webroot/* ${ROOT}/var/www/localhost
chown -R apache: ${ROOT}/var/www/localhost