summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-04-05 06:34:01 +0000
committerDonny Davies <woodchip@gentoo.org>2003-04-05 06:34:01 +0000
commit937bb69bd36f92fbd58a6a59991117bbea2d5fc2 (patch)
tree3816b72ff6ec9cfba0e320300feb2f926b75724b /net-www/apache
parentnumerous fixes and cleanups for arm-headers (diff)
downloadgentoo-2-937bb69bd36f92fbd58a6a59991117bbea2d5fc2.tar.gz
gentoo-2-937bb69bd36f92fbd58a6a59991117bbea2d5fc2.tar.bz2
gentoo-2-937bb69bd36f92fbd58a6a59991117bbea2d5fc2.zip
Bump + small fixes.
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/ChangeLog10
-rw-r--r--net-www/apache/apache-2.0.45.ebuild322
-rw-r--r--net-www/apache/files/2.0.40/40_mod_ssl.conf5
-rw-r--r--net-www/apache/files/2.0.40/apache2.initd3
-rw-r--r--net-www/apache/files/2.0.40/commonapache2.conf6
-rw-r--r--net-www/apache/files/apache-2.0.45-gentoo.diff162
-rw-r--r--net-www/apache/files/digest-apache-2.0.4537
7 files changed, 535 insertions, 10 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index c84dcd09c3d4..f08b143a679b 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-www/apache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.49 2003/03/26 18:46:39 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.50 2003/04/05 06:34:01 woodchip Exp $
+
+*apache-2.0.45 (06 Apr 2003)
+
+ 06 Apr 2003; Donny Davies <woodchip@gentoo.org> apache-2.0.45.ebuild,
+ files/apache-2.0.45-gentoo.diff, files/2.0.40/40_mod_ssl.conf,
+ files/2.0.40/apache2.initd, files/2.0.40/commonapache2.conf:
+ New version. Added optional ldap mods, couple of small config
+ file cleanups. Fix bugs #17651, 17145.
*apache-1.3.27-r4 (23 Feb 2003)
diff --git a/net-www/apache/apache-2.0.45.ebuild b/net-www/apache/apache-2.0.45.ebuild
new file mode 100644
index 000000000000..36bf12ddfe31
--- /dev/null
+++ b/net-www/apache/apache-2.0.45.ebuild
@@ -0,0 +1,322 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.45.ebuild,v 1.1 2003/04/05 06:34:01 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="Apache Web Server, Version 2.0.x"
+HOMEPAGE="http://www.apache.org/"
+
+S="${WORKDIR}/httpd-${PV}"
+SRC_URI="http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc ~alpha ~hppa ~mips ~sparc"
+LICENSE="Apache-1.1"
+SLOT="2"
+
+DEPEND="dev-util/yacc
+ dev-lang/perl
+ sys-libs/zlib
+ dev-libs/expat
+ dev-libs/openssl
+ berkdb? sys-libs/db
+ gdbm? sys-libs/gdbm
+ ldap? =net-nds/openldap-2*"
+IUSE="berkdb gdbm ldap"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ #give it the stamp
+ perl -pi -e 's|" PLATFORM "|Gentoo/Linux|;' server/core.c
+ #fix perl with perl!
+ find -type f | xargs perl -pi -e \
+ "s|/usr/local/bin/perl|/usr/bin/perl|g; \
+ s|/usr/local/bin/perl5|/usr/bin/perl|g; \
+ s|/path/to/bin/perl|/usr/bin/perl|g;"
+ #dont want this cruft in /usr/bin
+ perl -pi -e 's|\@exp_bindir\@(/envvars)|\@exp_installbuilddir\@\1|;' \
+ support/apachectl.in
+
+ #allow users to customize their data directory by setting the
+ #home directory of the 'apache' user elsewhere.
+ local datadir=`grep ^apache: /etc/passwd | cut -d: -f6`
+ if [ -z "$datadir" ]
+ then
+ datadir="/home/httpd"
+ eerror "Please create the apache user and set his home"
+ eerror "directory to your desired datadir location."
+ eerror "Defaulting to \"/home/httpd\"."
+ else
+ einfo "$datadir is your Apache2 data directory ..."
+ fi
+
+ #setup the filesystem layout config
+ local prefix=/usr
+ cat >>config.layout <<-EOF
+ <Layout Gentoo>
+ prefix: ${prefix}
+ exec_prefix: ${prefix}
+ bindir: ${prefix}/bin
+ sbindir: ${prefix}/sbin
+ libdir: ${prefix}/lib
+ libexecdir: ${prefix}/lib/apache2
+ mandir: ${prefix}/share/man
+ infodir: ${prefix}/share/info
+ includedir: ${prefix}/include/apache2
+ installbuilddir: ${prefix}/lib/apache2/build
+ datadir: ${datadir}
+ errordir: ${datadir}/error
+ iconsdir: ${datadir}/icons
+ htdocsdir: ${datadir}/htdocs
+ cgidir: ${datadir}/cgi-bin
+ manualdir: /usr/share/doc/${PF}/manual
+ sysconfdir: /etc/apache2/conf
+ localstatedir: /var
+ runtimedir: /var/run
+ logfiledir: /var/log/apache2
+ proxycachedir: /var/cache/apache2
+ </Layout>
+ EOF
+
+ #gotta do these next two as well :\
+ cat >>srclib/apr/config.layout <<-EOF
+ <Layout Gentoo>
+ prefix: ${prefix}
+ exec_prefix: ${prefix}
+ bindir: ${prefix}/bin
+ sbindir: ${prefix}/sbin
+ libdir: ${prefix}/lib
+ libexecdir: ${prefix}/lib/apache2
+ mandir: ${prefix}/share/man
+ sysconfdir: /etc/apache2/conf
+ datadir: ${datadir}
+ installbuilddir: ${prefix}/lib/apache2/build
+ includedir: ${prefix}/include/apache2
+ localstatedir: /var
+ libsuffix: -\${APR_MAJOR_VERSION}
+ </Layout>
+ EOF
+
+ cat >>srclib/apr-util/config.layout <<-EOF
+ <Layout Gentoo>
+ prefix: ${prefix}
+ exec_prefix: ${prefix}
+ bindir: ${prefix}/bin
+ sbindir: ${prefix}/sbin
+ libdir: ${prefix}/lib
+ libexecdir: ${prefix}/lib/apache2
+ mandir: ${prefix}/share/man
+ sysconfdir: /etc/apache2/conf
+ datadir: ${datadir}
+ installbuilddir: ${prefix}/lib/apache2/build
+ includedir: ${prefix}/include/apache2
+ localstatedir: /var
+ libsuffix: -\${APRUTIL_MAJOR_VERSION}
+ </Layout>
+ EOF
+
+ ./buildconf || die "buildconf failed"
+}
+
+src_compile() {
+ local myconf
+ use ldap && \
+ myconf="--with-ldap --enable-auth-ldap=shared --enable-ldap=shared"
+
+ select_modules_config || die "determining modules"
+
+ SSL_BASE="SYSTEM" \
+ ./configure \
+ --with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
+ --with-suexec-logfile=/var/log/apache2/suexec_log \
+ --with-suexec-bin=/usr/sbin/suexec2 \
+ --with-suexec-userdir=public_html \
+ --with-suexec-caller=apache \
+ --with-suexec-docroot=/home \
+ --with-suexec-uidmin=1000 \
+ --with-suexec-gidmin=100 \
+ --with-suexec-umask=077 \
+ --enable-suexec=shared \
+ \
+ ${MY_BUILTINS} \
+ \
+ --with-perl=/usr/bin/perl \
+ --with-expat=/usr \
+ --with-ssl=/usr \
+ --with-z=/usr \
+ --with-port=80 \
+ --with-mpm=${MPM:=prefork} \
+ --enable-layout=Gentoo \
+ --with-program-name=apache2 \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+ #--with-mpm={worker|prefork|perchild|leader|threadpool}
+
+ emake || die "problem compiling Apache2 :("
+
+ #build ssl version of apache bench (ab-ssl)
+ cd support; rm -f ab .libs/ab ab.lo ab.o
+ make ab CFLAGS="${CFLAGS} -DUSE_SSL -lcrypto -lssl \
+ -I/usr/include/openssl -L/usr/lib" || die
+ mv ab ab-ssl; mv .libs/ab .libs/ab-ssl; rm -f ab.lo ab.o
+ make ab || die
+}
+
+src_install () {
+ local i
+ make DESTDIR=${D} install || die
+ dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT \
+ LICENSE README* ${FILESDIR}/robots.txt
+
+ #bogus values pointing at /var/tmp/portage
+ perl -pi -e "s/(APR_SOURCE_DIR=).*/\1\"\"/" ${D}/usr/bin/apr-config
+ perl -pi -e "s/(APU_SOURCE_DIR=).*/\1\"\"/" ${D}/usr/bin/apu-config
+ perl -pi -e "s/(APU_BUILD_DIR=).*/\1\"\"/" ${D}/usr/bin/apu-config
+
+ #protect the suexec binary
+ local gid=`grep ^apache: /etc/group |cut -d: -f3`
+ [ -z "${gid}" ] && gid=81
+ fowners root.${gid} /usr/sbin/suexec
+ fperms 4710 /usr/sbin/suexec
+
+ #setup links in /etc/apache2
+ cd ${D}/etc/apache2
+ ln -sf ../../usr/lib/apache2 modules
+ #apxs needs this to pickup the right lib for install
+ ln -sf ../../usr/lib lib
+ ln -sf ../../var/log/apache2 logs
+ ln -sf ../../usr/lib/apache2-extramodules extramodules
+ cd ${S}
+
+ #credits to advx.org people for these scripts. Heck, thanks for
+ #the nice layout and everything else ;-)
+ exeinto /usr/sbin
+ for i in apache2logserverstatus apache2splitlogfile
+ do
+ doexe ${FILESDIR}/2.0.40/$i
+ done
+ exeinto /usr/lib/ssl/apache2-mod_ssl
+ doexe ${FILESDIR}/2.0.40/gentestcrt.sh
+
+ #some more scripts
+ exeinto /usr/sbin
+ for i in split-logfile list_hooks.pl logresolve.pl log_server_status
+ do
+ doexe ${S}/support/$i
+ done
+ #the ssl version of apache bench
+ doexe support/.libs/ab-ssl
+
+ #move some mods to extramodules
+ dodir /usr/lib/apache2-extramodules
+ for i in mod_ssl.so mod_ldap.so mod_auth_ldap.so
+ do
+ [ -x ${D}/usr/lib/apache2/$i ] && \
+ mv ${D}/usr/lib/apache2/$i ${D}/usr/lib/apache2-extramodules
+ done
+
+ #modules.d config file snippets
+ insinto /etc/apache2/conf/modules.d
+ for i in 40_mod_ssl.conf 41_mod_ssl.default-vhost.conf 45_mod_dav.conf
+ do
+ doins ${FILESDIR}/2.0.40/$i
+ done
+ use ldap && doins ${FILESDIR}/2.0.40/46_mod_ldap.conf
+
+ #drop in a convenient link to the manual
+ local datadir=`grep ^apache: /etc/passwd | cut -d: -f6`
+ [ -z "$datadir" ] && datadir="/home/httpd"
+ dosym /usr/share/doc/${PF}/manual ${datadir}/htdocs/manual
+
+ #SLOT=2!!!
+ cd ${D}
+ mv -v usr/sbin/apachectl usr/sbin/apache2ctl
+ mv -v usr/sbin/htdigest usr/sbin/htdigest2
+ mv -v usr/sbin/htpasswd usr/sbin/htpasswd2
+ mv -v usr/sbin/logresolve usr/sbin/logresolve2
+ mv -v usr/sbin/apxs usr/sbin/apxs2
+ mv -v usr/sbin/ab usr/sbin/ab2
+ mv -v usr/sbin/ab-ssl usr/sbin/ab2-ssl
+ mv -v usr/sbin/suexec usr/sbin/suexec2
+ mv -v usr/sbin/rotatelogs usr/sbin/rotatelogs2
+ mv -v usr/sbin/dbmmanage usr/sbin/dbmmanage2
+ mv -v usr/sbin/checkgid usr/sbin/checkgid2
+ mv -v usr/sbin/split-logfile usr/sbin/split-logfile2
+ mv -v usr/sbin/list_hooks.pl usr/sbin/list_hooks2.pl
+ mv -v usr/sbin/logresolve.pl usr/sbin/logresolve2.pl
+ mv -v usr/sbin/log_server_status usr/sbin/log_server_status2
+ mv -v usr/share/man/man1/htdigest.1 usr/share/man/man1/htdigest2.1
+ mv -v usr/share/man/man1/htpasswd.1 usr/share/man/man1/htpasswd2.1
+ mv -v usr/share/man/man1/dbmmanage.1 usr/share/man/man1/dbmmanage2.1
+ mv -v usr/share/man/man8/ab.8 usr/share/man/man8/ab2.8
+ mv -v usr/share/man/man8/apxs.8 usr/share/man/man8/apxs2.8
+ mv -v usr/share/man/man8/apachectl.8 usr/share/man/man8/apache2ctl.8
+ mv -v usr/share/man/man8/httpd.8 usr/share/man/man8/apache2.8
+ mv -v usr/share/man/man8/logresolve.8 usr/share/man/man8/logresolve2.8
+ mv -v usr/share/man/man8/rotatelogs.8 usr/share/man/man8/rotatelogs2.8
+ mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+
+ #tidy up
+ mv ${D}/usr/sbin/envvars* ${D}/usr/lib/apache2/build
+ dodoc ${D}/etc/apache2/conf/*-std.conf
+ rm -f ${D}/etc/apache2/conf/*.conf
+ rm -rf ${D}/var/run ${D}/var/log
+
+ #config files
+ insinto /etc/conf.d; newins ${FILESDIR}/2.0.40/apache2.confd apache2
+ exeinto /etc/init.d; newexe ${FILESDIR}/2.0.40/apache2.initd apache2
+ insinto /etc/apache2; doins ${FILESDIR}/2.0.40/apache2-builtin-mods
+ insinto /etc/apache2/conf
+ doins ${FILESDIR}/2.0.40/commonapache2.conf
+ doins ${FILESDIR}/2.0.40/apache2.conf
+ insinto /etc/apache2/conf/vhosts
+ doins ${FILESDIR}/2.0.40/virtual-homepages.conf
+ doins ${FILESDIR}/2.0.40/dynamic-vhosts.conf
+ doins ${FILESDIR}/2.0.40/vhosts.conf
+}
+
+parse_modules_config() {
+ local filename=$1
+ local name=""
+ local dso=""
+ local disable=""
+ [ -f ${filename} ] || return 1
+ for i in `cat $filename | sed "s/^#.*//"` ; do
+ if [ $i == "-" ] ; then
+ disable="true"
+ elif [ -z "$name" ] && [ ! -z "`echo $i | grep "mod_"`" ] ; then
+ name=`echo $i | sed "s/mod_//"`
+ elif [ "$disable" ] && ( [ $i == "static" ] || [ $i == "shared" ] ) ; then
+ MY_BUILTINS="${MY_BUILTINS} --disable-$name"
+ name="" ; disable=""
+ elif [ $i == "static" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-$name=yes"
+ name="" ; disable=""
+ elif [ $i == "shared" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-$name=shared"
+ name="" ; disable=""
+ fi
+ done
+ einfo "${filename} options:\n${MY_BUILTINS}"
+}
+
+select_modules_config() {
+ parse_modules_config /etc/apache2/apache2-builtin-mods || \
+ parse_modules_config ${FILESDIR}/2.0.40/apache2-builtin-mods || \
+ return 1
+}
+
+pkg_postinst() {
+ #empty dirs...
+ install -d -m0755 -o apache -g apache ${ROOT}/var/lib/dav
+ install -d -m0755 -o root -g root ${ROOT}/var/log/apache2
+ install -d -m0755 -o root -g root ${ROOT}/var/cache/apache2
+ install -d -m0755 -o root -g root ${ROOT}/etc/apache2/conf/ssl
+
+ cd ${ROOT}/etc/apache2/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache2/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/apache2-mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
diff --git a/net-www/apache/files/2.0.40/40_mod_ssl.conf b/net-www/apache/files/2.0.40/40_mod_ssl.conf
index 6942b8da2202..2db5457d3b17 100644
--- a/net-www/apache/files/2.0.40/40_mod_ssl.conf
+++ b/net-www/apache/files/2.0.40/40_mod_ssl.conf
@@ -69,9 +69,8 @@ SSLPassPhraseDialog builtin
#SSLSessionCache none
#SSLSessionCache shmht:logs/ssl_scache(512000)
#SSLSessionCache shmcb:logs/ssl_scache(512000)
-
-SSLSessionCache dbm:logs/ssl_scache
-#SSLSessionCache shmht:logs/ssl_scache(128000)
+#SSLSessionCache dbm:logs/ssl_scache
+SSLSessionCache shm:logs/ssl_scache(128000)
SSLSessionCacheTimeout 300
diff --git a/net-www/apache/files/2.0.40/apache2.initd b/net-www/apache/files/2.0.40/apache2.initd
index d7461a61d1d2..d56a3b36d5e1 100644
--- a/net-www/apache/files/2.0.40/apache2.initd
+++ b/net-www/apache/files/2.0.40/apache2.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2.initd,v 1.7 2003/02/25 21:56:56 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2.initd,v 1.8 2003/04/05 06:34:01 woodchip Exp $
opts="${opts} reload"
@@ -12,6 +12,7 @@ depend() {
start() {
ebegin "Starting apache2"
+ [ -f /var/log/apache2/ssl_scache ] && rm /var/log/apache2/ssl_scache
start-stop-daemon --quiet --start --startas /usr/sbin/apache2 \
--pidfile /var/run/apache2.pid -- -k start ${APACHE2_OPTS}
eend $?
diff --git a/net-www/apache/files/2.0.40/commonapache2.conf b/net-www/apache/files/2.0.40/commonapache2.conf
index 85d2d8fd04b5..ef0d7b3f0fd0 100644
--- a/net-www/apache/files/2.0.40/commonapache2.conf
+++ b/net-www/apache/files/2.0.40/commonapache2.conf
@@ -1,5 +1,5 @@
### /etc/apache2/conf/commonapache2.conf
-### $Id: commonapache2.conf,v 1.3 2003/02/23 19:39:22 woodchip Exp $
+### $Id: commonapache2.conf,v 1.4 2003/04/05 06:34:01 woodchip Exp $
###
### Common server configuration.
###
@@ -898,10 +898,6 @@ ServerSignature On
</IfModule>
</Directory>
-<Directory /home/httpd/htdocs/addon-modules>
- Options Indexes FollowSymLinks
-</Directory>
-
<Location /index.shtml>
Options +Includes
</Location>
diff --git a/net-www/apache/files/apache-2.0.45-gentoo.diff b/net-www/apache/files/apache-2.0.45-gentoo.diff
new file mode 100644
index 000000000000..21d9d089f85d
--- /dev/null
+++ b/net-www/apache/files/apache-2.0.45-gentoo.diff
@@ -0,0 +1,162 @@
+diff -uNr httpd-2.0.45.orig/acinclude.m4 httpd-2.0.45/acinclude.m4
+--- httpd-2.0.45.orig/acinclude.m4 2002-11-29 06:05:57.000000000 -0500
++++ httpd-2.0.45/acinclude.m4 2003-04-06 03:36:53.000000000 -0400
+@@ -60,6 +60,7 @@
+ APACHE_SUBST(HTTPD_LDFLAGS)
+ APACHE_SUBST(UTIL_LDFLAGS)
+ APACHE_SUBST(LIBS)
++ APACHE_SUBST(SSL_LIBS)
+ APACHE_SUBST(DEFS)
+ APACHE_SUBST(INCLUDES)
+ APACHE_SUBST(NOTEST_CPPFLAGS)
+@@ -190,7 +191,7 @@
+ ])dnl
+
+ dnl
+-dnl APACHE_MODULE(name, helptext[, objects[, structname[, default[, config]]]])
++dnl APACHE_MODULE(name, helptext[, objects[, structname[, default[, config[, libs]]]]])
+ dnl
+ dnl default is one of:
+ dnl yes -- enabled by default. user must explicitly disable.
+@@ -266,7 +267,7 @@
+ fi
+ shared="";;
+ esac
+- APACHE_MODPATH_ADD($1, $shared, $3)
++ APACHE_MODPATH_ADD($1, $shared, $3,, $7)
+ fi
+ ])dnl
+
+@@ -488,7 +489,7 @@
+ APR_ADDTO(LDFLAGS, [$ap_platform_runtime_link_flag$ap_ssltk_libdir])
+ fi
+ fi
+- APR_ADDTO(LIBS, [-lssl -lcrypto])
++ APR_ADDTO(SSL_LIBS, [-lssl -lcrypto])
+ ap_cv_ssltk="$ap_ssltk_base"
+ fi
+ ])
+diff -uNr httpd-2.0.45.orig/docs/man/suexec.8 httpd-2.0.45/docs/man/suexec.8
+--- httpd-2.0.45.orig/docs/man/suexec.8 2003-02-02 15:50:05.000000000 -0500
++++ httpd-2.0.45/docs/man/suexec.8 2003-04-06 03:36:53.000000000 -0400
+@@ -1,4 +1,4 @@
+-.TH suexec 8 "March 2001"
++.TH suexec2 8 "March 2001"
+ .\" The Apache Software License, Version 1.1
+ .\"
+ .\" Copyright (c) 2000-2003 The Apache Software Foundation. All rights
+@@ -51,25 +51,25 @@
+ .\" <http://www.apache.org/>.
+ .\"
+ .SH NAME
+-suexec \- Switch User For Exec
++suexec2 \- Switch User For Exec
+ .SH SYNOPSIS
+-.B suexec -V
++.B suexec2 -V
+ .PP
+ No other synopsis for usage, because this program
+ is otherwise only used internally by the Apache HTTP server.
+ .PP
+ .SH DESCRIPTION
+-.B suexec
+-is the "wrapper" support program for the suexec behaviour for the
++.B suexec2
++is the "wrapper" support program for the suexec2 behaviour for the
+ Apache HTTP server. It is run from within the server automatically
+ to switch the user when an external program has to be run under a
+-different user. For more information about suexec, see the online
++different user. For more information about suexec2, see the online
+ document `Apache suexec Support' on the HTTP server project's
+ Web site at http://httpd.apache.org/docs/suexec.html .
+ .SH OPTIONS
+ .IP -V
+-Display the list of compile-time settings used when \fBsuexec\fP
++Display the list of compile-time settings used when \fBsuexec2\fP
+ was built. No other action is taken.
+ .PD
+ .SH SEE ALSO
+-.BR httpd(8)
++.BR apache2(8)
+diff -uNr httpd-2.0.45.orig/modules/ssl/config.m4 httpd-2.0.45/modules/ssl/config.m4
+--- httpd-2.0.45.orig/modules/ssl/config.m4 2002-03-29 02:36:01.000000000 -0500
++++ httpd-2.0.45/modules/ssl/config.m4 2003-04-06 03:36:53.000000000 -0400
+@@ -79,7 +79,7 @@
+ APACHE_CHECK_SSL_TOOLKIT
+ AC_CHECK_FUNCS(SSL_set_state)
+ AC_CHECK_FUNCS(SSL_set_cert_store)
+-])
++], [\$(SSL_LIBS)])
+
+ dnl # end of module specific part
+ APACHE_MODPATH_FINISH
+diff -uNr httpd-2.0.45.orig/os/unix/unixd.c httpd-2.0.45/os/unix/unixd.c
+--- httpd-2.0.45.orig/os/unix/unixd.c 2003-02-03 12:31:58.000000000 -0500
++++ httpd-2.0.45/os/unix/unixd.c 2003-04-06 03:36:53.000000000 -0400
+@@ -228,23 +228,20 @@
+
+ AP_DECLARE(void) unixd_pre_config(apr_pool_t *ptemp)
+ {
+- apr_finfo_t wrapper;
++ struct stat wrapper;
+
+ unixd_config.user_name = DEFAULT_USER;
+ unixd_config.user_id = ap_uname2id(DEFAULT_USER);
+ unixd_config.group_id = ap_gname2id(DEFAULT_GROUP);
+
+ /* Check for suexec */
+- unixd_config.suexec_enabled = 0;
+- if ((apr_stat(&wrapper, SUEXEC_BIN,
+- APR_FINFO_NORM, ptemp)) != APR_SUCCESS) {
+- return;
+- }
+-
+- /* XXX - apr_stat is incapable of checking suid bits (grumble) */
+- /* if ((wrapper.filetype & S_ISUID) && wrapper.user == 0) { */
++ if (stat(SUEXEC_BIN, &wrapper) == 0 &&
++ (wrapper.st_mode & S_ISUID) && wrapper.st_uid == 0) {
+ unixd_config.suexec_enabled = 1;
+- /* } */
++ } else {
++ unixd_config.suexec_enabled = 0;
++ }
++
+ }
+
+
+diff -uNr httpd-2.0.45.orig/support/apachectl.in httpd-2.0.45/support/apachectl.in
+--- httpd-2.0.45.orig/support/apachectl.in 2003-02-03 12:32:08.000000000 -0500
++++ httpd-2.0.45/support/apachectl.in 2003-04-06 03:37:37.000000000 -0400
+@@ -28,7 +28,8 @@
+ # -------------------- --------------------
+ #
+ # the path to your httpd binary, including options if necessary
+-HTTPD='@exp_sbindir@/@progname@'
++. /etc/conf.d/apache2
++HTTPD="@exp_sbindir@/@progname@ ${APACHE2_OPTS}"
+ #
+ # pick up any necessary environment variables
+ if test -f @exp_bindir@/envvars; then
+diff -uNr httpd-2.0.45.orig/support/apxs.in httpd-2.0.45/support/apxs.in
+--- httpd-2.0.45.orig/support/apxs.in 2003-02-22 10:50:13.000000000 -0500
++++ httpd-2.0.45/support/apxs.in 2003-04-06 03:36:53.000000000 -0400
+@@ -237,19 +237,6 @@
+ ($httpd = $0) =~ s:support/apxs$::;
+ }
+
+-unless (-x "$httpd") {
+- error("$httpd not found or not executable");
+- exit 1;
+-}
+-
+-unless (grep /mod_so/, `. $envvars && $httpd -l`) {
+- error("Sorry, no shared object support for Apache");
+- error("available under your platform. Make sure");
+- error("the Apache module mod_so is compiled into");
+- error("your server binary `$httpd'.");
+- exit 1;
+-}
+-
+ sub get_config_vars{
+ my ($file, $rh_config) = @_;
+
diff --git a/net-www/apache/files/digest-apache-2.0.45 b/net-www/apache/files/digest-apache-2.0.45
new file mode 100644
index 000000000000..5e8f9d62d639
--- /dev/null
+++ b/net-www/apache/files/digest-apache-2.0.45
@@ -0,0 +1,37 @@
+MD5 161245c7aa1eb785db53b34d6a10be43 /files/suexec_pam_gentoo.patch 2149
+MD5 97c7a2efed7a3fd05614167426c495d9 /files/apache-builtin-mods 2465
+MD5 d3626a1e31a675c60d066c111d552adf /files/suexec.pam 59
+MD5 f2c60b199c12729b25716ed451a24e38 /files/apache-2.0.44-gentoo.diff 4895
+MD5 de4bb52edc581b44224e7006846aff43 /files/apache.rc6 1021
+MD5 8d790bf68c47c08951c761815cd66a1c /files/apachelogserverstatus 4763
+MD5 df54361aa8754197cf3bafe99d32c7ec /files/robots.txt 340
+MD5 02db12f0d91e1f89e0b173fea6c5151d /files/apacheaddmod 5977
+MD5 bae4b9d941cd38a32943533e958aa1b3 /files/apachedelmod 3185
+MD5 9dc40e1918a2d30a578ebf1653f7182c /files/apache-2.0.45-gentoo.diff 5448
+MD5 a90bef6fb0fb6d05f74c36eaf26285d6 /files/apachesplitlogfile 4959
+MD5 df1290566bb25603dbe5a649daec5185 /files/apache.confd 1012
+MD5 f440f0a32308bc9dc9d9acd041c8b6c5 /files/conf/apache.conf 7247
+MD5 e68da4777c0641e3bc5b284ee7f6fcf2 /files/conf/commonapache.conf 22140
+MD5 c774e0c7ddc6d55bddc164a9b5af0cb6 /files/conf/VirtualHomePages.conf 907
+MD5 f820076adb31912c060052154d08eecb /files/conf/Vhosts.conf 1909
+MD5 fd9b211c5078739d4aadbe6b3e53aead /files/conf/DynamicVhosts.conf 963
+MD5 14aebf386646fe7ab2623dad993a32fa /files/2.0.40/40_mod_ssl.conf 3420
+MD5 819ee444395cf42ccc8009529a94af37 /files/2.0.40/45_mod_dav.conf 583
+MD5 50b76a8df795c79378c02f1edea750a4 /files/2.0.40/46_mod_ldap.conf 902
+MD5 b610d37fd521de1f8fc782069e165969 /files/2.0.40/apache2logserverstatus 4652
+MD5 a14d8565fd5ca2b5753799477a85b1af /files/2.0.40/apache2splitlogfile 4844
+MD5 e14a1f0add1f5400e97cc6df5ad84429 /files/2.0.40/apache2-builtin-mods 2230
+MD5 b335411e582a8fd58aacf2f35e75291f /files/2.0.40/gentestcrt.sh 8805
+MD5 9375735d739344987fe4b2a3990de273 /files/2.0.40/highperformance.conf 1959
+MD5 5c47dec8c730edf1cb755b581327bd49 /files/2.0.40/httpd.conf 35481
+MD5 0055923f696c9ba3be7eeb5518603d40 /files/2.0.40/ssl.conf 11082
+MD5 8ce666f3b8ad3ed00c081dc29e19fe90 /files/2.0.40/41_mod_ssl.default-vhost.conf 8039
+MD5 1ea0af5a7b339e83ad1d045d8602469d /files/2.0.40/commonapache2.conf 30913
+MD5 4f46808418e644590002e78e98d88f21 /files/2.0.40/apache2.confd 776
+MD5 f807a994fd6bfe85da325fab19c16b34 /files/2.0.40/apache2.initd 1121
+MD5 8203712c2d827475922d031ffb4061d4 /files/2.0.40/apache2.conf 7643
+MD5 548304216950e0192bf40ae0f5ace370 /files/2.0.40/vhosts.conf 1683
+MD5 b69bf7c3126e471a2abff013e716367f /files/2.0.40/virtual-homepages.conf 780
+MD5 23416b00cbdc46b67e672f272e49ba40 /files/2.0.40/dynamic-vhosts.conf 840
+MD5 817d8a540193c3ecda1a587a77cd693e /apache-2.0.45.ebuild 10229
+MD5 1f33e9a2e2de06da190230fa72738d75 httpd-2.0.45.tar.gz 5549120