summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-02-23 19:39:22 +0000
committerDonny Davies <woodchip@gentoo.org>2003-02-23 19:39:22 +0000
commit6605462442e10060aea408503d29af4d0c61d02d (patch)
tree78578ea53f89de5e94bfd0bc1cd21c78917a1763 /net-www/apache
parentdon't call die from a subshell (diff)
downloadgentoo-2-6605462442e10060aea408503d29af4d0c61d02d.tar.gz
gentoo-2-6605462442e10060aea408503d29af4d0c61d02d.tar.bz2
gentoo-2-6605462442e10060aea408503d29af4d0c61d02d.zip
fix a shitload of bugs
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/ChangeLog5
-rw-r--r--net-www/apache/apache-2.0.44.ebuild4
-rw-r--r--net-www/apache/files/2.0.40/40_mod_ssl.conf4
-rw-r--r--net-www/apache/files/2.0.40/apache2-builtin-mods12
-rw-r--r--net-www/apache/files/2.0.40/apache2.conf12
-rw-r--r--net-www/apache/files/2.0.40/apache2.initd14
-rw-r--r--net-www/apache/files/2.0.40/commonapache2.conf3
-rw-r--r--net-www/apache/files/apache.rc69
8 files changed, 35 insertions, 28 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index ff32731d8926..d0f65fb3fbab 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/apache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.40 2003/02/18 10:07:08 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.41 2003/02/23 19:39:22 woodchip Exp $
+
+ 23 Feb 2003; Donny Davies <woodchip@gentoo.org> :
+ Fix #14561, #14589, #14724, #14818, #15592, #15806, #16158.
*apache-2.0.44 (21 Jan 2003)
diff --git a/net-www/apache/apache-2.0.44.ebuild b/net-www/apache/apache-2.0.44.ebuild
index 831be8fbe03e..e7a711fa1b00 100644
--- a/net-www/apache/apache-2.0.44.ebuild
+++ b/net-www/apache/apache-2.0.44.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.44.ebuild,v 1.4 2003/02/18 09:59:30 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.44.ebuild,v 1.5 2003/02/23 19:39:22 woodchip Exp $
inherit eutils
@@ -273,7 +273,7 @@ select_modules_config() {
pkg_postinst() {
#empty dirs...
- install -d -m0755 -o root -g root ${ROOT}/var/lib/dav
+ install -d -m0755 -o apache -g apache ${ROOT}/var/lib/dav
install -d -m0755 -o root -g root ${ROOT}/var/log/apache2
install -d -m0755 -o root -g root ${ROOT}/var/cache/apache2
install -d -m0755 -o root -g root ${ROOT}/etc/apache2/conf/ssl
diff --git a/net-www/apache/files/2.0.40/40_mod_ssl.conf b/net-www/apache/files/2.0.40/40_mod_ssl.conf
index 1be3e65d105c..6942b8da2202 100644
--- a/net-www/apache/files/2.0.40/40_mod_ssl.conf
+++ b/net-www/apache/files/2.0.40/40_mod_ssl.conf
@@ -70,8 +70,8 @@ SSLPassPhraseDialog builtin
#SSLSessionCache shmht:logs/ssl_scache(512000)
#SSLSessionCache shmcb:logs/ssl_scache(512000)
-#SSLSessionCache dbm:logs/ssl_scache
-SSLSessionCache shmht:logs/ssl_scache(128000)
+SSLSessionCache dbm:logs/ssl_scache
+#SSLSessionCache shmht:logs/ssl_scache(128000)
SSLSessionCacheTimeout 300
diff --git a/net-www/apache/files/2.0.40/apache2-builtin-mods b/net-www/apache/files/2.0.40/apache2-builtin-mods
index 9fc9f10ad4e3..ab80ad525062 100644
--- a/net-www/apache/files/2.0.40/apache2-builtin-mods
+++ b/net-www/apache/files/2.0.40/apache2-builtin-mods
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2-builtin-mods,v 1.2 2002/11/28 20:23:09 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2-builtin-mods,v 1.3 2003/02/23 19:39:22 woodchip Exp $
#
# This file will be installed into /etc/apache2 when you first emerge
# Apache2. If/when you upgrade, it will be consulted for your options,
@@ -48,11 +48,11 @@ mod_proxy-connect shared
mod_proxy-ftp shared
mod_proxy-http shared
mod_ssl shared
-mod_optional-hook-export shared
-mod_optional-hook-import shared
-mod_optional-fn-import shared
-mod_optional-fn-export shared
-mod_bucketeer shared
+- mod_optional-hook-export shared
+- mod_optional-hook-import shared
+- mod_optional-fn-import shared
+- mod_optional-fn-export shared
+- mod_bucketeer shared
mod_info shared
mod_include shared
mod_cgi shared
diff --git a/net-www/apache/files/2.0.40/apache2.conf b/net-www/apache/files/2.0.40/apache2.conf
index 811b6a8053a7..f0e3b5cf54bb 100644
--- a/net-www/apache/files/2.0.40/apache2.conf
+++ b/net-www/apache/files/2.0.40/apache2.conf
@@ -1,5 +1,5 @@
### /etc/apache2/conf/apache2.conf
-### $Id: apache2.conf,v 1.1 2002/11/28 20:23:09 woodchip Exp $
+### $Id: apache2.conf,v 1.2 2003/02/23 19:39:22 woodchip Exp $
###
### Main Configuration Section
### You really shouldn't change these settings unless you're a guru
@@ -68,11 +68,11 @@ LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule case_filter_module modules/mod_case_filter.so
LoadModule case_filter_in_module modules/mod_case_filter_in.so
LoadModule deflate_module modules/mod_deflate.so
-LoadModule optional_hook_export_module modules/mod_optional_hook_export.so
-LoadModule optional_hook_import_module modules/mod_optional_hook_import.so
-LoadModule optional_fn_import_module modules/mod_optional_fn_import.so
-LoadModule optional_fn_export_module modules/mod_optional_fn_export.so
-LoadModule bucketeer_module modules/mod_bucketeer.so
+#LoadModule optional_hook_export_module modules/mod_optional_hook_export.so
+#LoadModule optional_hook_import_module modules/mod_optional_hook_import.so
+#LoadModule optional_fn_import_module modules/mod_optional_fn_import.so
+#LoadModule optional_fn_export_module modules/mod_optional_fn_export.so
+#LoadModule bucketeer_module modules/mod_bucketeer.so
LoadModule logio_module modules/mod_logio.so
###
diff --git a/net-www/apache/files/2.0.40/apache2.initd b/net-www/apache/files/2.0.40/apache2.initd
index accec79d5186..c3f139638eb2 100644
--- a/net-www/apache/files/2.0.40/apache2.initd
+++ b/net-www/apache/files/2.0.40/apache2.initd
@@ -1,11 +1,13 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2.initd,v 1.5 2003/02/14 23:10:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2.initd,v 1.6 2003/02/23 19:39:22 woodchip Exp $
+
+opts="${opts} reload"
depend() {
need net
- use mysql dns logger
+ use mysql dns logger netmount
}
start() {
@@ -22,12 +24,12 @@ stop() {
eend $?
}
-svc_restart() {
- ebegin "Gracefully restarting apache"
- /usr/sbin/apache2 -t ${APACHE_OPTS} &>/dev/null
+reload() {
+ ebegin "Gracefully restarting apache2"
+ /usr/sbin/apache2 -t ${APACHE2_OPTS} &>/dev/null
if [ "$?" != "0" ]; then
svc_stop
- eend 1 "Apache configuration error"
+ eend 1 "Apache2 configuration error"
else
killall -USR1 apache2 &> /dev/null
svc_start &>/dev/null
diff --git a/net-www/apache/files/2.0.40/commonapache2.conf b/net-www/apache/files/2.0.40/commonapache2.conf
index 02a0a14b61dd..85d2d8fd04b5 100644
--- a/net-www/apache/files/2.0.40/commonapache2.conf
+++ b/net-www/apache/files/2.0.40/commonapache2.conf
@@ -1,5 +1,5 @@
### /etc/apache2/conf/commonapache2.conf
-### $Id: commonapache2.conf,v 1.2 2003/01/22 04:57:49 woodchip Exp $
+### $Id: commonapache2.conf,v 1.3 2003/02/23 19:39:22 woodchip Exp $
###
### Common server configuration.
###
@@ -640,6 +640,7 @@ ServerSignature On
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carfully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^gnome-vfs" redirect-carefully
+ BrowserMatch "^WebDAVFS" redirect-carefully
</IfModule>
# End of browser customization directives
diff --git a/net-www/apache/files/apache.rc6 b/net-www/apache/files/apache.rc6
index 4eb30962b951..09e106ad1492 100644
--- a/net-www/apache/files/apache.rc6
+++ b/net-www/apache/files/apache.rc6
@@ -1,11 +1,13 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/apache.rc6,v 1.9 2003/02/14 23:09:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/apache.rc6,v 1.10 2003/02/23 19:39:22 woodchip Exp $
+
+opts="${opts} reload"
depend() {
need net
- use mysql dns logger
+ use mysql dns logger netmount
}
start() {
@@ -22,10 +24,9 @@ stop() {
eend $?
}
-svc_restart() {
+reload() {
ebegin "Gracefully restarting apache"
/usr/sbin/apache -t ${APACHE_OPTS} &>/dev/null
-
if [ "$?" != "0" ]; then
svc_stop
eend 1 "Apache configuration error"