summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-09-19 20:57:24 +0000
committerMike Frysinger <vapier@gentoo.org>2002-09-19 20:57:24 +0000
commit06178af0f94d1c252daf7dd5460ed57a0856d6fd (patch)
tree92213326af2ec84bba55c51e03302f69ccf9e6b1 /net-www/apache
parentAdded missing dependancy (diff)
downloadgentoo-2-06178af0f94d1c252daf7dd5460ed57a0856d6fd.tar.gz
gentoo-2-06178af0f94d1c252daf7dd5460ed57a0856d6fd.tar.bz2
gentoo-2-06178af0f94d1c252daf7dd5460ed57a0856d6fd.zip
Fix bugs #5556 & #8124
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/ChangeLog7
-rw-r--r--net-www/apache/apache-1.3.26-r3.ebuild6
-rw-r--r--net-www/apache/apache-1.3.26-r4.ebuild8
-rw-r--r--net-www/apache/files/apache.rc62
4 files changed, 15 insertions, 8 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 867b9fa9f980..15d026e72c54 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -19,6 +19,10 @@ B
*apache-1.3.26-r4 (3 Jul 2002)
+ 19 Sep 2002; Michael Frysinger <vapier@gentoo.org> apache-1.3.26-r4.ebuild files/apache.rc6 :
+ Fixed the grep expressions for DATA_DIR and GID ... #8124
+ Fixed 'use named' (was already added to 2.0.x just not 1.3.x) ... #5556
+
17 Sep 2002; Nicholas Jones <carpaski@gentoo.org> :
Fixed the graceful restart... It wasn't paying heed to ${APACHE_OPTS}
@@ -44,6 +48,9 @@ B
*apache-1.3.26-r3 (2 Jul 2002)
+ 19 Sep 2002; Michael Frysinger <vapier@gentoo.org> apache-1.3.26-r3.ebuild :
+ Fixed the grep expressions for DATA_DIR ... #8124
+
14 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> apache-1.3.26-r3.ebuild :
Added KEYWORDS.
diff --git a/net-www/apache/apache-1.3.26-r3.ebuild b/net-www/apache/apache-1.3.26-r3.ebuild
index 062ee1570ddf..9be04fb709ab 100644
--- a/net-www/apache/apache-1.3.26-r3.ebuild
+++ b/net-www/apache/apache-1.3.26-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.26-r3.ebuild,v 1.4 2002/08/16 03:01:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.26-r3.ebuild,v 1.5 2002/09/19 20:57:24 vapier Exp $
mod_ssl_ver=2.8.9-${PV}
HARD_SERVER_LIMIT=512
@@ -73,7 +73,7 @@ src_compile() {
# Allow users to move the default data directory by setting the
# home directory of the 'apache' user elsewhere.
- DATA_DIR=`grep apache /etc/passwd | cut -d: -f6`
+ DATA_DIR=`grep ^apache: /etc/passwd | cut -d: -f6`
if [ -z "$DATA_DIR" ]; then
eerror "DATA_DIR is null! Using defaults."
@@ -137,7 +137,7 @@ src_compile() {
src_install() {
# Allow users to move the default data directory by setting the
# home directory of the 'apache' user elsewhere.
- DATA_DIR=`grep apache /etc/passwd | cut -d: -f6`
+ DATA_DIR=`grep ^apache: /etc/passwd | cut -d: -f6`
if [ -z "$DATA_DIR" ]; then
eerror "DATA_DIR is null! Using defaults."
diff --git a/net-www/apache/apache-1.3.26-r4.ebuild b/net-www/apache/apache-1.3.26-r4.ebuild
index bd92d43cd766..1f5ce22804ad 100644
--- a/net-www/apache/apache-1.3.26-r4.ebuild
+++ b/net-www/apache/apache-1.3.26-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.26-r4.ebuild,v 1.5 2002/09/18 13:21:24 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.26-r4.ebuild,v 1.6 2002/09/19 20:57:24 vapier Exp $
mod_ssl_ver=2.8.9-${PV}
HARD_SERVER_LIMIT=512
@@ -72,7 +72,7 @@ src_compile() {
# Allow users to move the default data directory by setting the
# home directory of the 'apache' user elsewhere.
- DATA_DIR=`grep apache /etc/passwd | cut -d: -f6`
+ DATA_DIR=`grep ^apache: /etc/passwd | cut -d: -f6`
if [ -z "$DATA_DIR" ]; then
DATA_DIR="/home/httpd"
@@ -136,7 +136,7 @@ src_compile() {
src_install() {
# Allow users to move the default data directory by setting the
# home directory of the 'apache' user elsewhere.
- DATA_DIR=`grep apache /etc/passwd | cut -d: -f6`
+ DATA_DIR=`grep ^apache: /etc/passwd | cut -d: -f6`
if [ -z "$DATA_DIR" ]; then
eerror "DATA_DIR is null! Using defaults."
@@ -144,7 +144,7 @@ src_install() {
DATA_DIR="/home/httpd"
fi
- GID=`grep apache /etc/group |cut -d: -f3`
+ GID=`grep ^apache: /etc/group |cut -d: -f3`
if [ -z "${GID}" ]; then
einfo "Using default GID of 81 for Apache"
GID=81
diff --git a/net-www/apache/files/apache.rc6 b/net-www/apache/files/apache.rc6
index 356c535b8a74..1bdb72e0318c 100644
--- a/net-www/apache/files/apache.rc6
+++ b/net-www/apache/files/apache.rc6
@@ -5,7 +5,7 @@
depend() {
need net
- use mysql
+ use mysql named
}
start() {