summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-12-12 03:05:07 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-12-12 03:05:07 +0000
commitf3f556070211dd9e488dad8b22cbeaf1e41a0bec (patch)
treea605b7496eeb9d22c8936d6c7d961946fdfbef24 /net-wireless
parentInstall the correct screensaver migration instructions, bug 202004 (diff)
downloadgentoo-2-f3f556070211dd9e488dad8b22cbeaf1e41a0bec.tar.gz
gentoo-2-f3f556070211dd9e488dad8b22cbeaf1e41a0bec.tar.bz2
gentoo-2-f3f556070211dd9e488dad8b22cbeaf1e41a0bec.zip
Third times a charm, fix bug #191031
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/iwlwifi/ChangeLog7
-rw-r--r--net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild11
2 files changed, 15 insertions, 3 deletions
diff --git a/net-wireless/iwlwifi/ChangeLog b/net-wireless/iwlwifi/ChangeLog
index 357593ef6a1a..b9c3b19ad252 100644
--- a/net-wireless/iwlwifi/ChangeLog
+++ b/net-wireless/iwlwifi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/iwlwifi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/iwlwifi/ChangeLog,v 1.14 2007/12/12 03:01:04 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/iwlwifi/ChangeLog,v 1.15 2007/12/12 03:05:07 compnerd Exp $
+
+ 12 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ iwlwifi-1.2.22.ebuild:
+ restrict tests as they fail, and add firmware loading support in the kernel.
+ Thanks to MATSUU Takuto (bug #191031)
12 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
iwlwifi-1.2.22.ebuild:
diff --git a/net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild b/net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild
index 2db2fc9d8de8..ad91d1f2c3cf 100644
--- a/net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild
+++ b/net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild,v 1.2 2007/12/12 03:01:04 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/iwlwifi/iwlwifi-1.2.22.ebuild,v 1.3 2007/12/12 03:05:07 compnerd Exp $
inherit eutils linux-mod
@@ -18,13 +18,15 @@ RDEPEND="ipw3945? ( =net-wireless/iwl3945-ucode-2.14.1.5 )
ipw4965? ( =net-wireless/iwl4965-ucode-4.44.1.18 )
!ipw3945? ( !ipw4965? ( =net-wireless/iwl3945-ucode-2.14.1.5 =net-wireless/iwl4965-ucode-4.44.1.18 ) )"
+RESTRICT="test"
+
pkg_setup() {
if kernel_is lt 2 6 22 ; then
eerror "iwlwifi requires a kernel >=2.6.22."
eerror "Please set your /usr/src/linux symlink accordingly."
die "invalid /usr/src/linux symlink"
else
- CONFIG_CHECK="MAC80211"
+ CONFIG_CHECK="MAC80211 FW_LOADER"
fi
if kernel_is gt 2 6 23 ; then
@@ -58,3 +60,8 @@ pkg_setup() {
BUILD_PARAMS="${BUILD_PARAMS} CONFIG_IWL3945=m CONFIG_IWL4965=m"
fi
}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CHANGES ISSUES README.iwlwifi
+}