summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-02-01 19:47:46 +0000
committerPacho Ramos <pacho@gentoo.org>2010-02-01 19:47:46 +0000
commitef1a65578f9073053890c7b2bef28a5fcbdd7ead (patch)
tree67f98c56fe06a4d2c6dce261d395c4268b5c4998 /net-wireless
parentamd64 stable, bug #299942 (diff)
downloadgentoo-2-ef1a65578f9073053890c7b2bef28a5fcbdd7ead.tar.gz
gentoo-2-ef1a65578f9073053890c7b2bef28a5fcbdd7ead.tar.bz2
gentoo-2-ef1a65578f9073053890c7b2bef28a5fcbdd7ead.zip
Version bump and lots of fixes
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/ChangeLog12
-rw-r--r--net-wireless/bluez/bluez-4.60.ebuild161
-rw-r--r--net-wireless/bluez/files/4.60/bluetooth-conf.d7
-rw-r--r--net-wireless/bluez/files/4.60/bluetooth-init.d31
-rw-r--r--net-wireless/bluez/files/4.60/cups-location.patch13
5 files changed, 223 insertions, 1 deletions
diff --git a/net-wireless/bluez/ChangeLog b/net-wireless/bluez/ChangeLog
index 990ddba06949..31f25e9321e6 100644
--- a/net-wireless/bluez/ChangeLog
+++ b/net-wireless/bluez/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-wireless/bluez
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.21 2010/01/14 01:24:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.22 2010/02/01 19:47:45 pacho Exp $
+
+*bluez-4.60 (01 Feb 2010)
+
+ 01 Feb 2010; Pacho Ramos <pacho@gentoo.org> +files/4.60/bluetooth-conf.d,
+ +files/4.60/bluetooth-init.d, +files/4.60/cups-location.patch,
+ +bluez-4.60.ebuild:
+ Version bump (bug 270859), includes lots of bugfixes, thanks to Gustavo F.
+ Padovan, Davide Pesavento, James Le Cuirot, Matthew Schultz, rg b,
+ emerald, Eric Smith... and probably more people I forgot. Dropped keywords
+ for some arches due new depend on sys-libs/libcap-ng (bug 284655)
14 Jan 2010; Jeroen Roovers <jer@gentoo.org> bluez-4.39-r2.ebuild:
Stable for HPPA (bug #284661).
diff --git a/net-wireless/bluez/bluez-4.60.ebuild b/net-wireless/bluez/bluez-4.60.ebuild
new file mode 100644
index 000000000000..c4bbad7b2e00
--- /dev/null
+++ b/net-wireless/bluez/bluez-4.60.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-4.60.ebuild,v 1.1 2010/02/01 19:47:45 pacho Exp $
+
+EAPI="2"
+
+inherit autotools multilib eutils
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa caps +consolekit cups debug gstreamer old-daemons pcmcia test-programs usb"
+
+CDEPEND="alsa? (
+ media-libs/alsa-lib[alsa_pcm_plugins_extplug,alsa_pcm_plugins_ioplug]
+ )
+ caps? ( >=sys-libs/libcap-ng-0.6.2 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10 )
+ usb? ( dev-libs/libusb )
+ cups? ( net-print/cups )
+ sys-fs/udev
+ dev-libs/glib
+ sys-apps/dbus
+ media-libs/libsndfile
+ >=dev-libs/libnl-1.1
+ !net-wireless/bluez-libs
+ !net-wireless/bluez-utils"
+DEPEND="sys-devel/flex
+ >=dev-util/pkgconfig-0.20
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ consolekit? ( sys-auth/pambase[consolekit] )
+ test-programs? (
+ dev-python/dbus-python
+ dev-python/pygobject )"
+
+src_prepare() {
+ if ! use consolekit; then
+ # No consolekit for at_console etc, so we grant plugdev the rights
+ epatch "${FILESDIR}/bluez-plugdev.patch"
+ fi
+
+ if use cups; then
+ epatch "${FILESDIR}/4.60/cups-location.patch"
+ fi
+
+ # needed for both patches
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable caps capng) \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --enable-audio \
+ --enable-service \
+ $(use_enable gstreamer) \
+ $(use_enable alsa) \
+ $(use_enable usb) \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ $(use_enable old-daemons hidd) \
+ $(use_enable old-daemons pand) \
+ $(use_enable old-daemons dund) \
+ $(use_enable cups) \
+ $(use_enable test-programs test) \
+ --enable-udevrules \
+ --enable-configfiles \
+ $(use_enable pcmcia) \
+ $(use_enable debug) \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog README || die
+
+ if use test-programs ; then
+ cd "${S}/test"
+ dobin simple-agent simple-service monitor-bluetooth
+ newbin list-devices list-bluetooth-devices
+ for b in apitest hsmicro hsplay test-* ; do
+ newbin "${b}" "bluez-${b}"
+ done
+ insinto /usr/share/doc/${PF}/test-services
+ doins service-*
+
+ cd "${S}"
+ fi
+
+ if use old-daemons; then
+ newconfd "${FILESDIR}/4.18/conf.d-hidd" hidd || die
+ newinitd "${FILESDIR}/4.18/init.d-hidd" hidd || die
+ fi
+
+ insinto /etc/bluetooth
+ doins \
+ input/input.conf \
+ audio/audio.conf \
+ network/network.conf \
+ serial/serial.conf \
+ || die
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}/${PN}-4.18-udev.rules" 70-bluetooth.rules || die
+ exeinto /$(get_libdir)/udev/
+ newexe "${FILESDIR}/${PN}-4.18-udev.script" bluetooth.sh || die
+
+ newinitd "${FILESDIR}/4.60/bluetooth-init.d" bluetooth || die
+ newconfd "${FILESDIR}/4.60/bluetooth-conf.d" bluetooth || die
+}
+
+pkg_postinst() {
+ udevadm control --reload-rules && udevadm trigger --subsystem-match=bluetooth
+
+ elog
+ elog "To use dial up networking you must install net-dialup/ppp."
+ elog
+ elog "For a password agent, there is for example net-wireless/bluez-gnome"
+ elog "for gnome and net-wireless/kdebluetooth for kde. You can also give a"
+ elog "try to net-wireless/blueman"
+ elog
+ elog "Use the old-daemons use flag to get the old daemons like hidd"
+ elog "installed. Please note that the init script doesn't stop the old"
+ elog "daemons after you update it so it's recommended to run:"
+ elog " /etc/init.d/bluetooth stop"
+ elog "before updating your configuration files or you can manually kill"
+ elog "the extra daemons you previously enabled in /etc/conf.d/bluetooth."
+
+ if use consolekit; then
+ elog ""
+ elog "If you want to use rfcomm as a normal user, you need to add the user"
+ elog "to the uucp group."
+ else
+ elog ""
+ elog "Since you have the consolekit use flag disabled, you will only be able to run"
+ elog "bluetooth clients as root. If you want to be able to run bluetooth clientes as "
+ elog "a regular user, you need to enable the consolekit use flag for this package."
+ fi
+
+ if use old-daemons; then
+ elog ""
+ elog "The hidd init script was installed because you have the old-daemons"
+ elog "use flag on. It is not started by default via udev so please add it"
+ elog "to the required runlevels using rc-update <runlevel> add hidd. If"
+ elog "you need init scripts for the other daemons, please file requests"
+ elog "to https://bugs.gentoo.org."
+ fi
+}
diff --git a/net-wireless/bluez/files/4.60/bluetooth-conf.d b/net-wireless/bluez/files/4.60/bluetooth-conf.d
new file mode 100644
index 000000000000..b0cc744415ad
--- /dev/null
+++ b/net-wireless/bluez/files/4.60/bluetooth-conf.d
@@ -0,0 +1,7 @@
+# Bluetooth configuraton file
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/net-wireless/bluez/files/4.60/bluetooth-init.d b/net-wireless/bluez/files/4.60/bluetooth-init.d
new file mode 100644
index 000000000000..111902aaeb55
--- /dev/null
+++ b/net-wireless/bluez/files/4.60/bluetooth-init.d
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/4.60/bluetooth-init.d,v 1.1 2010/02/01 19:47:46 pacho Exp $
+
+depend() {
+ after coldplug
+ need dbus localmount
+}
+
+start() {
+ ebegin "Starting Bluetooth"
+
+ udevadm trigger --subsystem-match=bluetooth
+ eend $?
+
+ if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
+ if [ -f "${RFCOMM_CONFIG}" ]; then
+ ebegin " Starting rfcomm"
+ /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
+ eend $?
+ else
+ ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
+ fi
+ fi
+}
+
+stop() {
+ ebegin "Shutting down Bluetooth"
+ eend 0
+}
diff --git a/net-wireless/bluez/files/4.60/cups-location.patch b/net-wireless/bluez/files/4.60/cups-location.patch
new file mode 100644
index 000000000000..66ed8dc22e5b
--- /dev/null
+++ b/net-wireless/bluez/files/4.60/cups-location.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.tools b/Makefile.tools
+index d9a2425..a382e05 100644
+--- a/Makefile.tools
++++ b/Makefile.tools
+@@ -122,7 +122,7 @@ EXTRA_DIST += tools/dfubabel.1 tools/avctrl.8
+
+
+ if CUPS
+-cupsdir = $(libdir)/cups/backend
++cupsdir = `cups-config --serverbin`/backend
+
+ cups_PROGRAMS = cups/bluetooth
+