summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-11-25 22:01:34 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-11-25 22:01:34 +0000
commitd6c051fc94896a8ec86e363a393c2b9ab15de826 (patch)
tree4c74c90b24e93c7f4fda3b501ee0d97ac63c7399 /net-wireless
parentStable on amd64, bug #200329. (diff)
downloadgentoo-2-d6c051fc94896a8ec86e363a393c2b9ab15de826.tar.gz
gentoo-2-d6c051fc94896a8ec86e363a393c2b9ab15de826.tar.bz2
gentoo-2-d6c051fc94896a8ec86e363a393c2b9ab15de826.zip
Fix build problems thanks to Alon Bar-Lev <alonbl@gentoo.org> in bug 195137
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/ipw3945/ChangeLog6
-rw-r--r--net-wireless/ipw3945/files/ipw3945-1.2.2-build.patch56
-rw-r--r--net-wireless/ipw3945/ipw3945-1.2.2.ebuild17
3 files changed, 70 insertions, 9 deletions
diff --git a/net-wireless/ipw3945/ChangeLog b/net-wireless/ipw3945/ChangeLog
index 689ae762acc2..bd49efd93c45 100644
--- a/net-wireless/ipw3945/ChangeLog
+++ b/net-wireless/ipw3945/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/ipw3945
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945/ChangeLog,v 1.34 2007/11/05 21:14:16 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945/ChangeLog,v 1.35 2007/11/25 22:01:33 genstef Exp $
+
+ 25 Nov 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/ipw3945-1.2.2-build.patch, ipw3945-1.2.2.ebuild:
+ Fix build problems thanks to Alon Bar-Lev <alonbl@gentoo.org> in bug 195137
05 Nov 2007; Jim Ramsay <lack@gentoo.org> metadata.xml:
Changing maintainers to myself, dang, and jkt
diff --git a/net-wireless/ipw3945/files/ipw3945-1.2.2-build.patch b/net-wireless/ipw3945/files/ipw3945-1.2.2-build.patch
new file mode 100644
index 000000000000..4eb147d09f1d
--- /dev/null
+++ b/net-wireless/ipw3945/files/ipw3945-1.2.2-build.patch
@@ -0,0 +1,56 @@
+diff -urNp ipw3945-1.2.2.org/Makefile ipw3945-1.2.2/Makefile
+--- ipw3945-1.2.2.org/Makefile 2007-04-30 06:44:56.000000000 +0300
++++ ipw3945-1.2.2/Makefile 2007-11-14 19:23:07.000000000 +0200
+@@ -111,7 +111,7 @@ IEEE80211_API := $(shell $(DIR)/snapshot
+ EXTRA_CFLAGS += -DIPW3945_COMPAT=$(IEEE80211_API)
+
+ ifeq ($(CONFIG_IPW3945_DEBUG),y)
+- EXTRA_CFLAGS += -g -Wa,-adhlms=$@.lst
++ EXTRA_CFLAGS += -g -Wa,-adhlms=$(T)/$@.lst
+ endif
+
+ ifdef KBUILD_EXTMOD
+@@ -193,34 +193,6 @@ utils:
+ @[ ! -d util ] || make -C util IEEE80211_PATH=$(IEEE80211_PATH)
+
+ check_inc:
+- @( [ "$(IEEE80211_DUPLICATE)" ] && echo -e \
+-"\n WARNING: Your kernel contains ieee80211 symbol definitions and you\n"\
+-"are not using the kernel's default ieee80211 subsystem. (Perhaps you\n"\
+-"used the out-of-tree ieee80211 subsystem's 'make install' or have\n"\
+-"provided a path to the ieee80211 subsystem via IEEE80211_INC.)\n\n"\
+-"If you wish to use the out-of-tree ieee80211 subsystem then it is\n"\
+-"recommended to use that projects' \"make patch_kernel\" facility\n"\
+-"and rebuild your kernel to update the Module symbol version information.\n"\
+-"\n"\
+-"Failure to do this may result in build warnings and unexpected\n"\
+-"behavior when running modules which rely on the ieee80211 subsystem.\n\n"\ || \
+- exit 0)
+-
+- @( [ "$(IEEE80211_DUPLICATE)" ] && \
+- [ ! "$(IEEE80211_IGNORE_DUPLICATE)" ] && echo -e \
+-" Aborting the build. You can force the build to continue by adding:\n\n"\
+-"\tIEEE80211_IGNORE_DUPLICATE=y\n\n"\
+-"to your make command line.\n\n" && exit 1 || exit 0)
+-
+- @( [ ! "$(IEEE80211_API)" ] && echo -e \
+-"\n ERROR: A compatible subsystem was not found in the following path[s]:\n\n"\
+-"\t$(IEEE80211_RES)\n\n"\
+-"You need to install the ieee80211 subsystem from http://ieee80211.sf.net\n"\
+-"and point this build to the location where you installed those sources, eg.:\n\n"\
+-"\t% make IEEE80211_INC=/usr/src/ieee80211/\n\n"\
+-"or use the 'make patch_kernel' within the ieee80211 subsystem to patch your\n"\
+-"kernel sources.\n" && exit 1 || exit 0)
+-
+ @echo -e \
+ " Using ieee80211 subsystem version API v$(IEEE80211_API) from:\n\n" \
+ "\tBase: $(IEEE80211_BASE)\n" \
+@@ -241,7 +213,7 @@ codingstyle:
+
+ clean:
+ @[ ! -d util ] || make -C util clean || true
+- rm -f *.{mod.c,mod,o,ko,rej,orig} .*.{stamp,flags,cmd} .lst *.lst *~
++ rm -f *.{mod.c,mod,o,ko,rej,orig} .*.{stamp,flags,cmd} $(T)/.lst $(T)/*.lst *~
+ rm -rf $(DIR)/tmp $(DIR)/.tmp_versions Module.symvers Modules.symvers
+ for file in *.{c,h}; do \
+ sed -i -e "s:\ *$$::g" -e "s:\t*$$::g" $$file; \
diff --git a/net-wireless/ipw3945/ipw3945-1.2.2.ebuild b/net-wireless/ipw3945/ipw3945-1.2.2.ebuild
index 43481394811c..9f37392732d8 100644
--- a/net-wireless/ipw3945/ipw3945-1.2.2.ebuild
+++ b/net-wireless/ipw3945/ipw3945-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945/ipw3945-1.2.2.ebuild,v 1.3 2007/09/11 15:48:45 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945/ipw3945-1.2.2.ebuild,v 1.4 2007/11/25 22:01:33 genstef Exp $
inherit linux-mod eutils
@@ -42,6 +42,13 @@ pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KSRC=${KV_DIR} KSRC_OUTPUT=${KV_OUT_DIR} SHELL=/bin/bash"
+ BUILD_PARAMS="${BUILD_PARAMS} T=${T}"
+ BUILD_PARAMS="${BUILD_PARAMS} CONFIG_IPW3945_MONITOR=y CONFIG_IEEE80211_RADIOTAP=y CONFIG_IPW3945_PROMISCUOUS=y"
+ if use debug; then
+ BUILD_PARAMS="${BUILD_PARAMS} CONFIG_IPW3945_DEBUG=y"
+ else
+ BUILD_PARAMS="${BUILD_PARAMS} CONFIG_IPW3945_DEBUG=n"
+ fi
# users don't read the ChangeLog and wonder why the kernel check fails
# (1) check if the kernel dir (/usr/src/linux) is missing ieee80211
@@ -64,14 +71,8 @@ pkg_setup() {
src_unpack() {
unpack ${P/_pre/-pre}.tgz
-
cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.2.0-Makefile.patch
-
- if use debug ; then
- sed -i -e "s:^\(CONFIG_IPW3945_DEBUG\)=.*:\1=y:" "${S}"/Makefile || \
- die "Failed to enable debugging support!"
- fi
+ epatch "${FILESDIR}/${P}-build.patch"
}
src_install() {