summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-20 08:24:10 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-20 08:24:10 +0000
commitce73d017300a2d1bd072d3e6ff70a7a1f66960f2 (patch)
treec0de774870c85f39de2af5c45c3e93e872375810 /net-wireless
parentVersion bump, wrt bug #430014 (diff)
downloadgentoo-2-ce73d017300a2d1bd072d3e6ff70a7a1f66960f2.tar.gz
gentoo-2-ce73d017300a2d1bd072d3e6ff70a7a1f66960f2.tar.bz2
gentoo-2-ce73d017300a2d1bd072d3e6ff70a7a1f66960f2.zip
Revision bump: EAPI 4, base eclass, respect LDFLAGS wrt bug #334949
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostap-utils/ChangeLog8
-rw-r--r--net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch31
-rw-r--r--net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild34
3 files changed, 72 insertions, 1 deletions
diff --git a/net-wireless/hostap-utils/ChangeLog b/net-wireless/hostap-utils/ChangeLog
index 9488595bba07..39a274400a7d 100644
--- a/net-wireless/hostap-utils/ChangeLog
+++ b/net-wireless/hostap-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/hostap-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-utils/ChangeLog,v 1.36 2012/11/18 11:16:12 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-utils/ChangeLog,v 1.37 2012/11/20 08:24:10 pinkbyte Exp $
+
+*hostap-utils-0.4.7-r1 (20 Nov 2012)
+
+ 20 Nov 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +hostap-utils-0.4.7-r1.ebuild, +files/hostap-utils-0.4.7-makefile.patch:
+ Revision bump: EAPI 4, base eclass, respect LDFLAGS wrt bug #334949
18 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop mobile herd as talked in gentoo-dev ML
diff --git a/net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch b/net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch
new file mode 100644
index 000000000000..366a878b7b62
--- /dev/null
+++ b/net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch
@@ -0,0 +1,31 @@
+--- Makefile.orig 2012-11-20 12:16:39.747881769 +0400
++++ Makefile 2012-11-20 12:17:39.248881307 +0400
+@@ -1,7 +1,3 @@
+-ifndef CFLAGS
+-CFLAGS = -O2 -Wall
+-endif
+-
+ # Include directory for CVS version
+ CFLAGS += -I../driver/modules
+
+@@ -14,17 +10,17 @@
+ hostap_crypt_conf: hostap_crypt_conf.c
+
+ hostap_diag: hostap_diag.o util.o
+- $(CC) -o hostap_diag $(CFLAGS) hostap_diag.o util.o
++ $(CC) -o hostap_diag $(CFLAGS) $(LDFLAGS) hostap_diag.o util.o
+
+ hostap_diag.o: hostap_diag.c util.h
+
+ util.o: util.c util.h
+
+ hostap_io_debug: hostap_io_debug.c
+- $(CC) -o hostap_io_debug $(CFLAGS) hostap_io_debug.c
++ $(CC) -o hostap_io_debug $(CFLAGS) $(LDFLAGS) hostap_io_debug.c
+
+ hostap_rid: hostap_rid.o util.o
+- $(CC) -o hostap_rid $(CFLAGS) hostap_rid.o util.o
++ $(CC) -o hostap_rid $(CFLAGS) $(LDFLAGS) hostap_rid.o util.o
+
+ hostap_rid.o: hostap_rid.c util.h
+
diff --git a/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild b/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..ccb5e3fead2c
--- /dev/null
+++ b/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild,v 1.1 2012/11/20 08:24:10 pinkbyte Exp $
+
+EAPI=4
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Utilities for Intersil Prism2/2.5/3 based IEEE 802.11b wireless LAN products"
+HOMEPAGE="http://hostap.epitest.fi/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin hostap_{crypt_conf,diag,fw_load,io_debug,rid}
+ dosbin prism2_{param,srec}
+ dosbin split_combined_hex
+
+ dodoc README
+}